summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDennis Herbrich2024-02-11 21:53:20 +0100
committerDennis Herbrich2024-02-11 21:53:20 +0100
commit2dc6850be4283887713f138c09f33ea744788861 (patch)
treef548398d7860bce667b87113ac605cc55b5fc737
parent75b41450c17e6bcbd28d0a849755b805bedf9677 (diff)
downloadaur-2dc6850be4283887713f138c09f33ea744788861.tar.gz
upgpkg: 0.7.2-1; adopt, refactor PKGBUILD, update release
- move `intltool` from depends to makedepends - remove unneeded install file, icon caches are updated by pacman hook - add running available build tests in check() - normalize source, build() and package() for consistency with PKGBUILD guidelines, and other `xfce4-foo-plugin` packages in extra - change pkgdesc to one-liner from upstream's gitlab repo - change url from goodies.xfce.org to docs.xfce.org as per upstream README - change license `GPL` to SPDX id `GPL-2.0-or-later` - change maintainer/contributor list after orphan adoption
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD47
-rw-r--r--xfce4-calculator-plugin.install11
3 files changed, 36 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26ae9cb4a890..517bdd9eb481 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = xfce4-calculator-plugin
- pkgdesc = Calculator plugin for the Xfce4 panel.
- pkgver = 0.7.1
+ pkgdesc = Simple command line based calculator for the Xfce panel
+ pkgver = 0.7.2
pkgrel = 1
- url = http://goodies.xfce.org/projects/panel-plugins/xfce4-calculator-plugin
- install = xfce4-calculator-plugin.install
+ url = https://docs.xfce.org/panel-plugins/xfce4-calculator-plugin
arch = i686
arch = x86_64
- license = GPL
- depends = intltool
+ license = GPL-2.0-or-later
+ makedepends = intltool
depends = xfce4-panel
- source = https://archive.xfce.org/src/panel-plugins/xfce4-calculator-plugin/0.7/xfce4-calculator-plugin-0.7.1.tar.bz2
- sha256sums = e4016a03c3ef4ebddd97e4135f5e304f80677033c98e19644b9989ec6f5ada81
+ source = https://archive.xfce.org/src/panel-plugins/xfce4-calculator-plugin/0.7/xfce4-calculator-plugin-0.7.2.tar.bz2
+ sha256sums = d1f622bea41a90c1686bf9f13c488ab28e995e2762b84712dea9027e0c94028b
pkgname = xfce4-calculator-plugin
diff --git a/PKGBUILD b/PKGBUILD
index 25b4e0bd0eba..1be026445b01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,39 @@
-# Maintainer : Yamada Hayao <hayao@fascode.net>
-# Contributer: Bernhard Landauer <oberon@manjaro.org>
-
-pkgname="xfce4-calculator-plugin"
-_maj=0.7
-pkgver="${_maj}.1"
+# Maintainer: Dennis Herbrich (Gyroplast) <dennis.herbrich@veloxis.de>
+# Contributor: Yamada Hayao <hayao@fascode.net>
+# Contributor: Bernhard Landauer <oberon@manjaro.org>
+pkgname=xfce4-calculator-plugin
+pkgver=0.7.2
pkgrel=1
-pkgdesc="Calculator plugin for the Xfce4 panel."
+pkgdesc="Simple command line based calculator for the Xfce panel"
arch=('i686' 'x86_64')
-url="http://goodies.xfce.org/projects/panel-plugins/${pkgname}"
-license=('GPL')
-depends=('intltool' 'xfce4-panel')
-install="${pkgname}.install"
-source=("https://archive.xfce.org/src/panel-plugins/xfce4-calculator-plugin/${_maj}/xfce4-calculator-plugin-${pkgver}.tar.bz2")
-sha256sums=('e4016a03c3ef4ebddd97e4135f5e304f80677033c98e19644b9989ec6f5ada81')
+url="https://docs.xfce.org/panel-plugins/xfce4-calculator-plugin"
+license=('GPL-2.0-or-later')
+depends=('xfce4-panel')
+makedepends=('intltool')
+source=("https://archive.xfce.org/src/panel-plugins/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('d1f622bea41a90c1686bf9f13c488ab28e995e2762b84712dea9027e0c94028b')
build() {
- cd "${pkgname}-${pkgver}"
- [[ -f "./Makefile" ]] && make distclean
- "./configure" --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib --disable-static
- make
+ cd "${pkgname}-${pkgver}"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-debug
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
}
package() {
cd "${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}/" install
}
+# vim:set ts=2 sw=2 et:
diff --git a/xfce4-calculator-plugin.install b/xfce4-calculator-plugin.install
deleted file mode 100644
index 8882af6e18e4..000000000000
--- a/xfce4-calculator-plugin.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- xdg-icon-resource forceupdate
-}
-
-post_upgrade() {
- post_install "${1}"
-}
-
-post_remove() {
- post_install "${1}"
-}