summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2021-08-23 20:23:24 +0900
committerhayao2021-08-23 20:23:24 +0900
commit75b41450c17e6bcbd28d0a849755b805bedf9677 (patch)
treeee44b24fc443ebb5b6ae69d43d39e3a8c15552da
parentf024c1ca5e6507bbd694a22678194f6b2bd0572c (diff)
downloadaur-75b41450c17e6bcbd28d0a849755b805bedf9677.tar.gz
[update] : Updated 0.7.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD27
-rw-r--r--xfce4-calculator-plugin.install6
3 files changed, 21 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7b55f356579..26ae9cb4a890 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xfce4-calculator-plugin
pkgdesc = Calculator plugin for the Xfce4 panel.
- pkgver = 0.7.0
+ pkgver = 0.7.1
pkgrel = 1
url = http://goodies.xfce.org/projects/panel-plugins/xfce4-calculator-plugin
install = xfce4-calculator-plugin.install
@@ -9,8 +9,7 @@ pkgbase = xfce4-calculator-plugin
license = GPL
depends = intltool
depends = xfce4-panel
- source = http://archive.xfce.org/src/panel-plugins/xfce4-calculator-plugin/0.7/xfce4-calculator-plugin-0.7.0.tar.bz2
- sha256sums = 7b50ab947ab058e1c079113e7f0f8b38ef242fec36ec9f31bb4e3c19cb3f9de9
+ source = https://archive.xfce.org/src/panel-plugins/xfce4-calculator-plugin/0.7/xfce4-calculator-plugin-0.7.1.tar.bz2
+ sha256sums = e4016a03c3ef4ebddd97e4135f5e304f80677033c98e19644b9989ec6f5ada81
pkgname = xfce4-calculator-plugin
-
diff --git a/PKGBUILD b/PKGBUILD
index ed08eea351a4..25b4e0bd0eba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,28 @@
-# Maintainer: Bernhard Landauer <oberon@manjaro.org>
+# Maintainer : Yamada Hayao <hayao@fascode.net>
+# Contributer: Bernhard Landauer <oberon@manjaro.org>
-pkgname=xfce4-calculator-plugin
+pkgname="xfce4-calculator-plugin"
_maj=0.7
-pkgver=$_maj.0
+pkgver="${_maj}.1"
pkgrel=1
pkgdesc="Calculator plugin for the Xfce4 panel."
arch=('i686' 'x86_64')
-url="http://goodies.xfce.org/projects/panel-plugins/$pkgname"
+url="http://goodies.xfce.org/projects/panel-plugins/${pkgname}"
license=('GPL')
depends=('intltool' 'xfce4-panel')
-install=$pkgname.install
-source=(http://archive.xfce.org/src/panel-plugins/$pkgname/$_maj/$pkgname-$pkgver.tar.bz2)
-sha256sums=('7b50ab947ab058e1c079113e7f0f8b38ef242fec36ec9f31bb4e3c19cb3f9de9')
+install="${pkgname}.install"
+source=("https://archive.xfce.org/src/panel-plugins/xfce4-calculator-plugin/${_maj}/xfce4-calculator-plugin-${pkgver}.tar.bz2")
+sha256sums=('e4016a03c3ef4ebddd97e4135f5e304f80677033c98e19644b9989ec6f5ada81')
build() {
- cd $pkgname-$pkgver
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib --disable-static
- make
+ cd "${pkgname}-${pkgver}"
+ [[ -f "./Makefile" ]] && make distclean
+ "./configure" --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib --disable-static
+ make
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir/" install
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}
+
diff --git a/xfce4-calculator-plugin.install b/xfce4-calculator-plugin.install
index 2c455e952b7b..8882af6e18e4 100644
--- a/xfce4-calculator-plugin.install
+++ b/xfce4-calculator-plugin.install
@@ -1,11 +1,11 @@
post_install() {
- xdg-icon-resource forceupdate
+ xdg-icon-resource forceupdate
}
post_upgrade() {
- post_install $1
+ post_install "${1}"
}
post_remove() {
- post_install $1
+ post_install "${1}"
}