summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Parnell2016-10-04 20:01:34 -0500
committerMatt Parnell2016-10-04 20:01:34 -0500
commite0081d44c17b4fe45e14ceb77adeec2376a87f0d (patch)
tree5247696c2d1371a9b80e29d8e19442c3b4cc5034
downloadaur-e0081d44c17b4fe45e14ceb77adeec2376a87f0d.tar.gz
initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD43
-rw-r--r--xfce4-clipman-plugin.install12
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..92874fd8ed41
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Wed Oct 5 01:01:21 UTC 2016
+pkgbase = xfce4-clipman-plugin-classic
+ pkgdesc = A clipboard plugin for the Xfce4 panel. Classic 1.2.6 version (fewer bugs, maintainer thinks)
+ pkgver = 1.2.6
+ pkgrel = 1
+ url = http://goodies.xfce.org/projects/panel-plugins/xfce4-clipman-plugin
+ install = xfce4-clipman-plugin.install
+ arch = i686
+ arch = x86_64
+ groups = xfce4-goodies
+ license = GPL
+ makedepends = xfce4-dev-tools
+ makedepends = intltool
+ makedepends = git
+ depends = xfce4-panel
+ depends = libunique
+ depends = libxtst
+ depends = qrencode
+ provides = xfce4-clipman-plugin
+ conflicts = xfce4-clipman-plugin
+ conflicts = xfce4-clipman-plugin-git
+ options = !libtool
+ source = git://git.xfce.org/panel-plugins/xfce4-clipman-plugin#tag=1.2.6
+ sha256sums = SKIP
+
+pkgname = xfce4-clipman-plugin-classic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4c5e32f3d76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Matt Parnell <parwok@gmail.com>
+# Contributor: Christian Hesse <mail@eworm.de>
+# Contributor: tobias <tobias at archlinux.org>
+# Contributor: Aurelien Foret <orelien@chez.com>
+
+pkgname=xfce4-clipman-plugin-classic
+pkgver=1.2.6
+pkgrel=1
+pkgdesc='A clipboard plugin for the Xfce4 panel. Classic 1.2.6 version (fewer bugs, maintainer thinks)'
+arch=('i686' 'x86_64')
+license=('GPL')
+url='http://goodies.xfce.org/projects/panel-plugins/xfce4-clipman-plugin'
+groups=('xfce4-goodies')
+depends=('xfce4-panel' 'libunique' 'libxtst' 'qrencode')
+conflicts=('xfce4-clipman-plugin' 'xfce4-clipman-plugin-git')
+provides=('xfce4-clipman-plugin')
+makedepends=('xfce4-dev-tools' 'intltool' 'git')
+options=('!libtool')
+install=xfce4-clipman-plugin.install
+source=("git://git.xfce.org/panel-plugins/xfce4-clipman-plugin#tag=${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ cd xfce4-clipman-plugin/
+
+ ./autogen.sh
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-unique \
+ --enable-maintainer-mode \
+ --disable-debug
+ make
+}
+
+package() {
+ cd xfce4-clipman-plugin/
+
+ make DESTDIR="${pkgdir}" install
+}
+
diff --git a/xfce4-clipman-plugin.install b/xfce4-clipman-plugin.install
new file mode 100644
index 000000000000..6204edafc8f6
--- /dev/null
+++ b/xfce4-clipman-plugin.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+