summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-29 16:22:32 +0200
committerChristian Hesse2015-06-29 16:22:32 +0200
commit13459cd68f89b62bd3fcd66864c73db62cfb78ee (patch)
tree79c4d7417191542f1b71ed5d9b787b5377b42ff8
downloadaur-13459cd68f89b62bd3fcd66864c73db62cfb78ee.tar.gz
initial import of xfce4-clipman-plugin-git 1.2.3.r86.g130aa64-1
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD53
-rw-r--r--xfce4-clipman-plugin.install12
3 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..848b2089e6a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = xfce4-clipman-plugin-git
+ pkgdesc = A clipboard plugin for the Xfce4 panel - git checkout
+ pkgver = 1.2.3.r86.g130aa64
+ pkgrel = 1
+ url = http://goodies.xfce.org/projects/panel-plugins/xfce4-clipman-plugin
+ install = xfce4-clipman-plugin.install
+ arch = i686
+ arch = x86_64
+ groups = xfce4-goodies
+ license = GPL
+ makedepends = xfce4-dev-tools
+ makedepends = intltool
+ makedepends = git
+ depends = xfce4-panel
+ depends = libunique
+ depends = libxtst
+ depends = qrencode
+ provides = xfce4-clipman-plugin
+ conflicts = xfce4-clipman-plugin
+ options = !libtool
+ source = git://git.xfce.org/panel-plugins/xfce4-clipman-plugin
+ sha256sums = SKIP
+
+pkgname = xfce4-clipman-plugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..288d4b94c9b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+# Contributor: tobias <tobias at archlinux.org>
+# Contributor: Aurelien Foret <orelien@chez.com>
+
+pkgname=xfce4-clipman-plugin-git
+pkgver=1.2.3.r86.g130aa64
+pkgrel=1
+pkgdesc='A clipboard plugin for the Xfce4 panel - git checkout'
+arch=('i686' 'x86_64')
+license=('GPL')
+url='http://goodies.xfce.org/projects/panel-plugins/xfce4-clipman-plugin'
+groups=('xfce4-goodies')
+depends=('xfce4-panel' 'libunique' 'libxtst' 'qrencode')
+conflicts=('xfce4-clipman-plugin')
+provides=('xfce4-clipman-plugin')
+makedepends=('xfce4-dev-tools' 'intltool' 'git')
+options=('!libtool')
+install=xfce4-clipman-plugin.install
+source=('git://git.xfce.org/panel-plugins/xfce4-clipman-plugin')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd xfce4-clipman-plugin/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+
+build() {
+ cd xfce4-clipman-plugin/
+
+ ./autogen.sh
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-unique \
+ --enable-maintainer-mode \
+ --disable-debug
+ make
+}
+
+package() {
+ cd xfce4-clipman-plugin/
+
+ make DESTDIR="${pkgdir}" install
+}
+
diff --git a/xfce4-clipman-plugin.install b/xfce4-clipman-plugin.install
new file mode 100644
index 000000000000..6204edafc8f6
--- /dev/null
+++ b/xfce4-clipman-plugin.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+