summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanny Dutton2015-12-01 12:11:40 -0500
committerDanny Dutton2015-12-01 12:11:40 -0500
commit0a19f3e574502992df0475b5d5539d0e6713764c (patch)
tree6b5d1bb78b8a7403900bbd20770c0b2a5d112d41
downloadaur-0a19f3e574502992df0475b5d5539d0e6713764c.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3125a7b1670
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = xfce4-composite-editor
+ pkgdesc = Simple GUI to control the various Xfce4 WM tweaks that are not available via the "Window Manager Tweaks" control panel.
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = http://gtk-apps.org/content/show.php/Xfce4-Composite-Editor?content=149523
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = pkg-config
+ makedepends = make
+ makedepends = autoconf
+ depends = gtk2
+ depends = libxfce4ui
+ depends = xfconf
+ optdepends = xfce-theme-manager: Theme manager allowing configuration of themes, window borders, controls, icons and cursors for Xfce.
+ source = https://dl.dropboxusercontent.com/s/kpqqgn2ty7iocgi/Xfwm4CompositeEditor-0.2.1.tar.gz
+ md5sums = 541fdd17a4d19166c7a362624a8ae453
+
+pkgname = xfce4-composite-editor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ba492f6043f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Danny Dutton <duttondj@vt.edu>
+
+pkgname=xfce4-composite-editor
+_pkgname=Xfwm4CompositeEditor
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="A simple GUI to control the various Xfce4 WM tweaks that are not available via the \"Window Manager Tweaks\" control
+panel."
+arch=('i686' 'x86_64')
+url="http://gtk-apps.org/content/show.php/Xfce4-Composite-Editor?content=149523"
+license=("GPL3")
+depends=('gtk2' 'libxfce4ui' 'xfconf')
+optdepends=('xfce-theme-manager: Theme manager allowing configuration of themes, window borders, controls, icons and cursors for Xfce.')
+makedepends=('pkg-config' 'make' 'autoconf')
+source=("https://dl.dropboxusercontent.com/s/kpqqgn2ty7iocgi/$_pkgname-${pkgver}.tar.gz")
+md5sums=('541fdd17a4d19166c7a362624a8ae453')
+
+build() {
+ cd "$srcdir"/$_pkgname-$pkgver
+ ./autogen.sh --prefix="$pkgdir"/usr
+ make
+}
+
+package() {
+ install -m 755 -d "$pkgdir"/usr/bin "$pkgdir"/usr/share/applications "$pkgdir"/usr/share/pixmaps "$pkgdir"/usr/share/Xfwm4CompositeEditor
+ cd "$srcdir"/$_pkgname-$pkgver
+ make PREFIX="$pkgdir/usr" install
+}