summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2021-01-16 20:35:33 -0500
committerMario Finelli2021-01-16 20:38:45 -0500
commit2c2898fd125db76c46409716b2523642ed716ed5 (patch)
tree0b8656f18e669c9901030a55f13a23aa9fd79308
parent0a19f3e574502992df0475b5d5539d0e6713764c (diff)
downloadaur-2c2898fd125db76c46409716b2523642ed716ed5.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 25 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3125a7b1670..8446af67648d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,15 @@
pkgbase = xfce4-composite-editor
- pkgdesc = Simple GUI to control the various Xfce4 WM tweaks that are not available via the "Window Manager Tweaks" control panel.
- pkgver = 0.2.1
+ pkgdesc = A simple composite manager for xfce4
+ pkgver = 0.2.2
pkgrel = 1
- url = http://gtk-apps.org/content/show.php/Xfce4-Composite-Editor?content=149523
+ url = https://github.com/KeithDHedger/Xfwm4CompositeEditor
arch = i686
arch = x86_64
license = GPL3
- makedepends = pkg-config
- makedepends = make
- makedepends = autoconf
depends = gtk2
- depends = libxfce4ui
- depends = xfconf
- optdepends = xfce-theme-manager: Theme manager allowing configuration of themes, window borders, controls, icons and cursors for Xfce.
- source = https://dl.dropboxusercontent.com/s/kpqqgn2ty7iocgi/Xfwm4CompositeEditor-0.2.1.tar.gz
- md5sums = 541fdd17a4d19166c7a362624a8ae453
+ depends = xfwm4
+ source = https://github.com/KeithDHedger/Xfwm4CompositeEditor/archive/xfce4-composite-editor-0.2.2.tar.gz
+ sha256sums = 9b58096ae5c0ce2c66e7b6fad1781824421ce0e5f65012117231c308c801f93a
pkgname = xfce4-composite-editor
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 6ba492f6043f..c5c7155bb473 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,26 @@
-# Maintainer: Danny Dutton <duttondj@vt.edu>
+# Maintainer: Mario Finelli <mario at finel dot li>
pkgname=xfce4-composite-editor
_pkgname=Xfwm4CompositeEditor
-pkgver=0.2.1
+pkgver=0.2.2
pkgrel=1
-pkgdesc="A simple GUI to control the various Xfce4 WM tweaks that are not available via the \"Window Manager Tweaks\" control
-panel."
-arch=('i686' 'x86_64')
-url="http://gtk-apps.org/content/show.php/Xfce4-Composite-Editor?content=149523"
-license=("GPL3")
-depends=('gtk2' 'libxfce4ui' 'xfconf')
-optdepends=('xfce-theme-manager: Theme manager allowing configuration of themes, window borders, controls, icons and cursors for Xfce.')
-makedepends=('pkg-config' 'make' 'autoconf')
-source=("https://dl.dropboxusercontent.com/s/kpqqgn2ty7iocgi/$_pkgname-${pkgver}.tar.gz")
-md5sums=('541fdd17a4d19166c7a362624a8ae453')
+pkgdesc="A simple composite manager for xfce4"
+arch=(i686 x86_64)
+url=https://github.com/KeithDHedger/Xfwm4CompositeEditor
+license=(GPL3)
+depends=(gtk2 xfwm4)
+source=(https://github.com/KeithDHedger/Xfwm4CompositeEditor/archive/$pkgname-$pkgver.tar.gz)
+sha256sums=('9b58096ae5c0ce2c66e7b6fad1781824421ce0e5f65012117231c308c801f93a')
build() {
- cd "$srcdir"/$_pkgname-$pkgver
- ./autogen.sh --prefix="$pkgdir"/usr
+ cd $_pkgname-$pkgname-$pkgver
+ ./configure --prefix=/usr
make
}
package() {
- install -m 755 -d "$pkgdir"/usr/bin "$pkgdir"/usr/share/applications "$pkgdir"/usr/share/pixmaps "$pkgdir"/usr/share/Xfwm4CompositeEditor
- cd "$srcdir"/$_pkgname-$pkgver
- make PREFIX="$pkgdir/usr" install
+ cd $_pkgname-$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
}
+
+# vim: set ts=2 sw=2 et: