summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Kamil Kozar2015-06-08 20:50:36 +0200
committerDaniel Kamil Kozar2015-06-08 20:51:56 +0200
commite6ebfbe8370e3fa83d47297d974120bc8cb8e313 (patch)
tree5e289a52d14c16c10ff2b879c818d961e076703b
downloadaur-e6ebfbe8370e3fa83d47297d974120bc8cb8e313.tar.gz
initial import from old AUR
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD46
-rw-r--r--xfce4-cpufreq-plugin.install11
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed6cb9c44100
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = xfce4-cpufreq-plugin-git
+ pkgdesc = CPU frequency plugin for the Xfce4 panel
+ pkgver = 1450.05848bb
+ pkgrel = 1
+ url = http://goodies.xfce.org/projects/panel-plugins/xfce4-cpufreq-plugin
+ install = xfce4-cpufreq-plugin.install
+ arch = i686
+ arch = x86_64
+ groups = xfce4-goodies
+ license = GPL2
+ makedepends = intltool
+ makedepends = git
+ makedepends = xfce4-dev-tools
+ makedepends = autoconf
+ makedepends = libtool
+ depends = xfce4-panel>=4.7.4
+ depends = libxfcegui4
+ depends = hicolor-icon-theme
+ provides = xfce4-cpufreq-plugin
+ conflicts = xfce4-cpufreq-plugin
+ options = !libtool
+ source = git://git.xfce.org/panel-plugins/xfce4-cpufreq-plugin
+ source = xfce4-cpufreq-plugin.install
+ sha256sums = SKIP
+ sha256sums = 72645ae7d2dfdc919becbda9e38c2c26e8d8047716fb324e46aa3f2cb3162473
+
+pkgname = xfce4-cpufreq-plugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2f290c4d273
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Adapted for git by xavery <dkk089@gmail.com>, based on original PKGBUILD by :
+# Maintainer: AndyRTR <andyrtr@archlinux.org>
+# Contributor: tobias <tobias funnychar archlinux.org>
+
+pkgname=xfce4-cpufreq-plugin-git
+_gitname=xfce4-cpufreq-plugin
+pkgver=1450.05848bb
+pkgrel=1
+pkgdesc="CPU frequency plugin for the Xfce4 panel"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-cpufreq-plugin"
+groups=('xfce4-goodies')
+depends=('xfce4-panel>=4.7.4' 'libxfcegui4' 'hicolor-icon-theme')
+makedepends=('intltool' 'git' 'xfce4-dev-tools' 'autoconf' 'libtool')
+provides=('xfce4-cpufreq-plugin')
+conflicts=('xfce4-cpufreq-plugin')
+options=('!libtool')
+install=${_gitname}.install
+source=('git://git.xfce.org/panel-plugins/xfce4-cpufreq-plugin'
+ ${_gitname}.install)
+sha256sums=('SKIP'
+ '72645ae7d2dfdc919becbda9e38c2c26e8d8047716fb324e46aa3f2cb3162473')
+
+pkgver() {
+ cd ${_gitname}
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd ${_gitname}
+ mkdir m4
+ NOCONFIGURE=1 ./autogen.sh
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-debug
+ make
+}
+
+package() {
+ cd ${_gitname}
+ make DESTDIR=${pkgdir} install
+}
diff --git a/xfce4-cpufreq-plugin.install b/xfce4-cpufreq-plugin.install
new file mode 100644
index 000000000000..21b79d2d44de
--- /dev/null
+++ b/xfce4-cpufreq-plugin.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}