summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkunnyk2016-05-02 18:15:49 +0200
committerSkunnyk2016-05-02 18:15:49 +0200
commit92c54933cb5e0d5a437b43d65e97199a9e64ba83 (patch)
tree31a831a539f117b2ee44eac395ac02c6770a16db
downloadaur-xfce4-datetime-plugin-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
-rw-r--r--xfce4-datetime-plugin.install12
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..820e763e76be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = xfce4-datetime-plugin-git
+ pkgdesc = A date and time display plugin for the Xfce panel
+ pkgver = datetime.0.6.2.r80.gd8a4ed9
+ pkgrel = 1
+ url = http://goodies.xfce.org/projects/panel-plugins/xfce4-datetime-plugin
+ install = xfce4-datetime-plugin.install
+ arch = i686
+ arch = x86_64
+ groups = xfce4-goodies
+ license = GPL
+ makedepends = xfce4-dev-tools
+ makedepends = intltool
+ makedepends = git
+ depends = xfce4-panel
+ provides = xfce4-datetime-plugin
+ conflicts = xfce4-datetime-plugin
+ options = !libtool
+ source = git://git.xfce.org/panel-plugins/xfce4-datetime-plugin
+ sha256sums = SKIP
+
+pkgname = xfce4-datetime-plugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d5e52d2c454
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+pkgname=xfce4-datetime-plugin-git
+_pkgname=${pkgname%-git}
+pkgver=datetime.0.6.2.r80.gd8a4ed9
+pkgrel=1
+pkgdesc='A date and time display plugin for the Xfce panel'
+arch=('i686' 'x86_64')
+license=('GPL')
+url='http://goodies.xfce.org/projects/panel-plugins/xfce4-datetime-plugin'
+groups=('xfce4-goodies')
+depends=('xfce4-panel')
+conflicts=('xfce4-datetime-plugin')
+provides=('xfce4-datetime-plugin')
+makedepends=('xfce4-dev-tools' 'intltool' 'git')
+options=('!libtool')
+install=xfce4-datetime-plugin.install
+source=('git://git.xfce.org/panel-plugins/xfce4-datetime-plugin')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ }
+
+build() {
+ cd "$_pkgname"/
+
+ ./autogen.sh --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-maintainer-mode \
+ --disable-debug
+ make
+}
+
+package() {
+ cd "$_pkgname"
+
+ make DESTDIR="${pkgdir}" install
+}
+
diff --git a/xfce4-datetime-plugin.install b/xfce4-datetime-plugin.install
new file mode 100644
index 000000000000..6204edafc8f6
--- /dev/null
+++ b/xfce4-datetime-plugin.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+