summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2015-06-14 00:43:44 +0200
committerSanskritFritz2015-06-14 00:43:44 +0200
commit6cd89206390c1d0eb8f914a900ac0e631a8c00e7 (patch)
tree9c098dd0a581c55aad8b5294b26835c9aa01ad9f
downloadaur-6cd89206390c1d0eb8f914a900ac0e631a8c00e7.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b379c3495920
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xfce4-embed-plugin
+ pkgdesc = Plugin that enables embedding of any application window into the Xfce panel.
+ pkgver = 1.4.1
+ pkgrel = 1
+ url = http://goodies.xfce.org/projects/panel-plugins/xfce4-embed-plugin
+ arch = i686
+ arch = x86_64
+ groups = xfce4-goodies
+ license = GPL
+ makedepends = intltool
+ depends = xfce4-panel
+ source = http://archive.xfce.org/src/panel-plugins/xfce4-embed-plugin/1.4/xfce4-embed-plugin-1.4.1.tar.bz2
+ md5sums = 6d1021c0af861241d73971085cde5e52
+
+pkgname = xfce4-embed-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69c78b712443
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: SanskritFritz (gmail)
+
+pkgname=xfce4-embed-plugin
+pkgver=1.4.1
+pkgrel=1
+pkgdesc="Plugin that enables embedding of any application window into the Xfce panel."
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://goodies.xfce.org/projects/panel-plugins/${pkgname}"
+groups=('xfce4-goodies')
+depends=('xfce4-panel')
+makedepends=('intltool')
+#options=('!libtool')
+source=(http://archive.xfce.org/src/panel-plugins/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2)
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-debug
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+md5sums=('6d1021c0af861241d73971085cde5e52')
+