summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjgmdev2016-03-22 00:20:12 -0400
committerjgmdev2016-03-22 00:20:12 -0400
commit41293cafce1a033b44d18d6a22aa809516396d62 (patch)
treede1c0e5db4cf0d200fdf5b24217b091908f0cb28
downloadaur-41293cafce1a033b44d18d6a22aa809516396d62.tar.gz
Initial commit.
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
-rw-r--r--xfce4-equake-plugin.install13
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3fc5207fa3d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Mar 22 04:18:49 UTC 2016
+pkgbase = xfce4-equake-plugin
+ pkgdesc = Equake monitors and displays earthquakes in your Xfce panel
+ pkgver = 1.3.8
+ pkgrel = 1
+ url = https://sourceforge.net/projects/equake/
+ install = xfce4-equake-plugin.install
+ arch = i686
+ arch = x86_64
+ groups = xfce4-goodies
+ license = GPL2
+ makedepends = intltool
+ depends = xfce4-panel
+ source = https://sourceforge.net/projects/equake/files/xfce4-equake-plugin-1.3.8.tar.gz
+ sha256sums = a0b0c7e033eab5980d5513aafaf20314b3203ec9977f06006483076977e7df8f
+
+pkgname = xfce4-equake-plugin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f52b2f5a9940
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ea3e0a1a861
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jefferson Gonzalez <jgmdev@gmail.com>
+
+pkgname=xfce4-equake-plugin
+pkgver=1.3.8
+pkgrel=1
+pkgdesc="Equake monitors and displays earthquakes in your Xfce panel"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="https://sourceforge.net/projects/equake/"
+groups=('xfce4-goodies')
+depends=('xfce4-panel')
+makedepends=('intltool')
+install="${pkgname}.install"
+source=(https://sourceforge.net/projects/equake/files/${pkgname}-${pkgver}.tar.gz)
+sha256sums=('a0b0c7e033eab5980d5513aafaf20314b3203ec9977f06006483076977e7df8f')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-debug
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/xfce4-equake-plugin.install b/xfce4-equake-plugin.install
new file mode 100644
index 000000000000..e4f8fd06c1ed
--- /dev/null
+++ b/xfce4-equake-plugin.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et: