summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHakan Erduman2022-01-03 11:45:26 +0100
committerHakan Erduman2022-01-03 11:45:26 +0100
commit06cadd658e9d157998ca47554d4e529da7347653 (patch)
treea5f4b2f28472b095103cb4716387234c33530fe8
parentb0783d8206e9d5fd7f84beb7f5249c1c45c47828 (diff)
downloadaur-06cadd658e9d157998ca47554d4e529da7347653.tar.gz
Upstream version 1.17
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7779c4f06888..05f8f74e5b52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xfce4-hamster-plugin
pkgdesc = A recreation of the gnome-shell hamster extension as a xfce4 panel plugin.
- pkgver = 1.15
- pkgrel = 2
+ pkgver = 1.17
+ pkgrel = 0
url = https://github.com/projecthamster/xfce4-hamster-plugin
arch = x86_64
arch = i686
@@ -11,7 +11,7 @@ pkgbase = xfce4-hamster-plugin
makedepends = cmake
makedepends = hamster-time-tracker
depends = xfce4-panel
- source = https://github.com/projecthamster/xfce4-hamster-plugin/archive/v1.15.tar.gz
- sha256sums = ea0894bd5531e71bcf1c385505290ef8c0a8b070edbdc6d4e1e992598570e1d6
+ source = https://github.com/projecthamster/xfce4-hamster-plugin/archive/v1.17.tar.gz
+ sha256sums = 1ceeaadec163ac5c6ee53548cd426283dd66b3c29a656a2361266da6e848e9bb
pkgname = xfce4-hamster-plugin
diff --git a/PKGBUILD b/PKGBUILD
index 167d1c6b2643..2a74904527c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Hakan Erduman <hakan at erduman dot de>
pkgname=xfce4-hamster-plugin
-pkgver=1.15
-pkgrel=2
+pkgver=1.17
+pkgrel=0
pkgdesc="A recreation of the gnome-shell hamster extension as a xfce4 panel plugin."
url="https://github.com/projecthamster/${pkgname}"
arch=('x86_64' 'i686')
@@ -10,19 +10,18 @@ depends=('xfce4-panel')
#optdepends=('hamster-time-tracker')
makedepends=('pkgconfig' 'intltool' 'cmake' 'hamster-time-tracker')
source=("https://github.com/projecthamster/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('ea0894bd5531e71bcf1c385505290ef8c0a8b070edbdc6d4e1e992598570e1d6')
+sha256sums=('1ceeaadec163ac5c6ee53548cd426283dd66b3c29a656a2361266da6e848e9bb')
build() {
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
-S $pkgname-$pkgver \
.
- make
+ cmake --build .
}
package() {
- make DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir/" cmake --install .
}
# vim:set ts=2 sw=2 et: