summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaphael Scholer2015-06-13 02:39:10 +0200
committerRaphael Scholer2015-06-13 02:39:10 +0200
commita6bd7adbbc46c114b3b629ca642b45b55f19f10d (patch)
treeef8473d70a4981584157648e77e5c7cb22df2403
downloadaur-a6bd7adbbc46c114b3b629ca642b45b55f19f10d.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--xfce4-kbdleds-plugin.install13
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18d24a5b6591
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = xfce4-kbdleds-plugin
+ pkgdesc = Xfce keyboard LEDs panel plugin
+ pkgver = 0.0.6
+ pkgrel = 8
+ url = http://goodies.xfce.org/projects/panel-plugins/xfce4-kbdleds-plugin
+ install = xfce4-kbdleds-plugin.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = intltool
+ depends = xfce4-panel
+ conflicts = xfce4-kbdleds-plugin-git
+ source = http://git.xfce.org/panel-plugins/xfce4-kbdleds-plugin/snapshot/xfce4-kbdleds-plugin-0.0.6.tar.bz2
+ sha256sums = 2c36c6ac5ef2bd564058e6040888b21a67939ba79041249d10a9ccc2b6b6bca2
+
+pkgname = xfce4-kbdleds-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..106d5a960bff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Raphael Scholer <rscholer@gmx.de>
+# Contributor: tomberry88 <tomberry@live.it>
+# Contributor: Gour-Gadadhara Dasa <gour@atmarama.net>
+pkgname=xfce4-kbdleds-plugin
+pkgver=0.0.6
+pkgrel=8
+pkgdesc="Xfce keyboard LEDs panel plugin"
+arch=('i686' 'x86_64')
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-kbdleds-plugin"
+license=('GPL2')
+conflicts=("xfce4-kbdleds-plugin-git")
+depends=('xfce4-panel')
+makedepends=('intltool')
+source=("http://git.xfce.org/panel-plugins/${pkgname}/snapshot/${pkgname}-${pkgver}.tar.bz2")
+install="${pkgname}.install"
+sha256sums=('2c36c6ac5ef2bd564058e6040888b21a67939ba79041249d10a9ccc2b6b6bca2')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+# vim:set ts=2 sw=2 et:
diff --git a/xfce4-kbdleds-plugin.install b/xfce4-kbdleds-plugin.install
new file mode 100644
index 000000000000..375ad822c231
--- /dev/null
+++ b/xfce4-kbdleds-plugin.install
@@ -0,0 +1,13 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+# vim:set ts=2 sw=2 et: