summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWouters Dorian2015-09-12 14:18:03 +0200
committerWouters Dorian2015-09-12 14:18:03 +0200
commita97112aef47549af212e86a5cf283b26750fdc98 (patch)
treef30c3da02c8656ff777967770c864930434fd34e
downloadaur-a97112aef47549af212e86a5cf283b26750fdc98.tar.gz
Port PKGBUILD from AUR3
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b12ad51d4f6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by makepkg 4.2.1
+# Wed Mar 18 16:54:38 UTC 2015
+pkgbase = xfce4-multiload-nandhp-plugin-git
+ pkgdesc = Multiload panel plugin for Xfce panel
+ pkgver = 20130612
+ pkgrel = 2
+ url = http://github.com/nandhp/multiload-nandhp
+ arch = i686
+ arch = x86_64
+ groups = xfce4-goodies
+ license = GPL2
+ makedepends = git
+ makedepends = intltool
+ depends = pacman
+ depends = xfce4-panel>=4.7.4
+ depends = libxfcegui4
+ depends = libgtop
+ source = git://github.com/nandhp/multiload-nandhp.git
+ md5sums = SKIP
+
+pkgname = xfce4-multiload-nandhp-plugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e8cb466a3a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Dorian Wouters <gravgun at openmailbox dot org>
+# Contributor: Pierre Carru <pierre.carru@gmail.com>
+pkgname=xfce4-multiload-nandhp-plugin-git
+pkgver=20130612
+pkgrel=2
+pkgdesc='Multiload panel plugin for Xfce panel'
+arch=('i686' 'x86_64')
+url="http://github.com/nandhp/multiload-nandhp"
+license=('GPL2')
+groups=('xfce4-goodies')
+depends=('pacman' 'xfce4-panel>=4.7.4' 'libxfce4ui' 'libgtop')
+makedepends=('git' 'intltool')
+
+source=('git://github.com/nandhp/multiload-nandhp.git')
+md5sums=('SKIP')
+
+_gitname='multiload-nandhp'
+
+build() {
+ cd $_gitname
+
+ ./autogen.sh
+ ./configure --prefix=/usr \
+ --enable-fast-install \
+ --disable-static \
+ --with-xfce4
+ make
+}
+
+package() {
+ cd $_gitname
+ make DESTDIR="$pkgdir" install
+ rm -f $pkgdir/usr/lib/xfce4/panel/plugins/libmultiload.la
+}
+