summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-29 16:23:42 +0200
committerChristian Hesse2015-06-29 16:23:42 +0200
commitb3c371ba6b870c4b67f5c5fcf095ab8183cc9c2b (patch)
tree22488c5ee845438bb0efc03ae32a159d4b5e2aae
downloadaur-xfce4-notifyd-git.tar.gz
initial import of xfce4-notifyd-git 0.2.4.r63.gdf7c16d-1
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD48
-rw-r--r--xfce4-notifyd-git.install11
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d21ad28b754
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = xfce4-notifyd-git
+ pkgdesc = notification daemon for the xfce desktop - git checkout
+ pkgver = 0.2.4.r63.gdf7c16d
+ pkgrel = 1
+ url = http://goodies.xfce.org/projects/applications/xfce4-notifyd
+ install = xfce4-notifyd-git.install
+ arch = i686
+ arch = x86_64
+ groups = xfce4-goodies
+ license = GPL
+ makedepends = xfce4-dev-tools
+ makedepends = exo
+ makedepends = intltool
+ makedepends = git
+ depends = libxfce4ui
+ depends = hicolor-icon-theme
+ provides = notification-daemon
+ provides = xfce4-notifyd
+ conflicts = xfce4-notifyd
+ options = !libtool
+ source = git://git.xfce.org/apps/xfce4-notifyd
+ sha256sums = SKIP
+
+pkgname = xfce4-notifyd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea62394790f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+# Contributor: Zbyszek Tokarczyk <ztokarczyk (at) Gmail.com>
+
+pkgname=xfce4-notifyd-git
+pkgver=0.2.4.r63.gdf7c16d
+pkgrel=1
+pkgdesc='notification daemon for the xfce desktop - git checkout'
+arch=('i686' 'x86_64')
+license=('GPL')
+url='http://goodies.xfce.org/projects/applications/xfce4-notifyd'
+groups=('xfce4-goodies')
+depends=('libxfce4ui' 'hicolor-icon-theme')
+makedepends=('xfce4-dev-tools' 'exo' 'intltool' 'git')
+conflicts=('xfce4-notifyd')
+provides=('notification-daemon' 'xfce4-notifyd')
+options=('!libtool')
+install=${pkgname}.install
+source=('git://git.xfce.org/apps/xfce4-notifyd')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd xfce4-notifyd/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+build() {
+ cd xfce4-notifyd/
+
+ ./autogen.sh \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/xfce4 \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+package() {
+ cd xfce4-notifyd/
+
+ make DESTDIR=${pkgdir} install
+}
+
diff --git a/xfce4-notifyd-git.install b/xfce4-notifyd-git.install
new file mode 100644
index 000000000000..81f2ba659316
--- /dev/null
+++ b/xfce4-notifyd-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}