summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wolf2019-08-12 15:15:25 +0200
committerSebastian Wolf2019-08-12 15:15:25 +0200
commit5a4483493fe385d31779029a6715046221914caa (patch)
treef07adc59fc51373b70dd4a559bb7dd95aabe4048
parent8928eebd09f929c0d5b9b88f6490098044dde50f (diff)
downloadaur-xfce4-panel-borderfix.tar.gz
Bump to 4.14.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a393cd8f3ec4..9a16a4908341 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,26 @@
-# Generated by mksrcinfo v8
-# Fri May 18 07:22:07 UTC 2018
pkgbase = xfce4-panel-borderfix
pkgdesc = Panel for the Xfce desktop environment with a patch fixing border behavior using two monitors stacked on top each other
- pkgver = 4.12.2
+ pkgver = 4.14.0
pkgrel = 1
url = http://www.xfce.org/
arch = x86_64
groups = xfce4
license = GPL2
makedepends = intltool
- makedepends = gtk-doc
+ makedepends = gobject-introspection
+ makedepends = vala
depends = exo
depends = garcon
depends = libxfce4ui
- depends = libwnck
+ depends = xfconf
+ depends = libwnck3
depends = hicolor-icon-theme
depends = desktop-file-utils
provides = xfce4-panel
conflicts = xfce4-panel
- source = https://archive.xfce.org/src/xfce/xfce4-panel/4.12/xfce4-panel-4.12.2.tar.bz2
+ source = https://archive.xfce.org/src/xfce/xfce4-panel/4.14/xfce4-panel-4.14.0.tar.bz2
source = borderfix.patch
- sha256sums = 42058abb81b8f87691d3999627447de71c3285bcf055f308aab5cefab2de0ce9
+ sha256sums = d5f8f3bd7e142139987e5e62cda26135a424baabb5e47aa0c23b4169d0a66ef4
sha256sums = effbe9c073f37987f877a168beddcfc03a38ec3adcba57a2cce3ce93b3420176
pkgname = xfce4-panel-borderfix
diff --git a/PKGBUILD b/PKGBUILD
index 0cb7cfb434f5..fa1cf7f1ceed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Contributor: Sebastian Wolf <fatmike303@gmail.com>
+# Maintainer: Sebastian Wolf <fatmike303@gmail.com>
#
# This fixes the following issue:
# https://bugzilla.xfce.org/show_bug.cgi?id=9693
pkgname=xfce4-panel-borderfix
_pkgname=xfce4-panel
-pkgver=4.12.2
+pkgver=4.14.0
pkgrel=1
pkgdesc="Panel for the Xfce desktop environment with a patch fixing border behavior using two monitors stacked on top each other"
arch=('x86_64')
@@ -14,14 +14,14 @@ license=('GPL2')
groups=('xfce4')
provides=($_pkgname)
conflicts=($_pkgname)
-depends=('exo' 'garcon' 'libxfce4ui' 'libwnck' 'hicolor-icon-theme' 'desktop-file-utils')
-makedepends=('intltool' 'gtk-doc')
+depends=('exo' 'garcon' 'libxfce4ui' 'xfconf' 'libwnck3' 'hicolor-icon-theme' 'desktop-file-utils')
+makedepends=('intltool' 'gobject-introspection' 'vala')
source=(
https://archive.xfce.org/src/xfce/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.bz2
'borderfix.patch'
)
sha256sums=(
- '42058abb81b8f87691d3999627447de71c3285bcf055f308aab5cefab2de0ce9'
+ 'd5f8f3bd7e142139987e5e62cda26135a424baabb5e47aa0c23b4169d0a66ef4'
'effbe9c073f37987f877a168beddcfc03a38ec3adcba57a2cce3ce93b3420176'
)
@@ -31,7 +31,6 @@ prepare() {
build() {
cd "$srcdir/$_pkgname-$pkgver"
-
./configure \
--prefix=/usr \
--sysconfdir=/etc \
@@ -39,8 +38,6 @@ build() {
--localstatedir=/var \
--disable-static \
--enable-gio-unix \
- --enable-gtk-doc \
- --enable-gtk3 \
--disable-debug
make
}
@@ -49,5 +46,3 @@ package() {
cd "$srcdir/$_pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
-
-# vim:set ts=2 sw=2 et: