summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wolf2018-05-18 09:24:13 +0200
committerSebastian Wolf2018-05-18 09:24:13 +0200
commit8928eebd09f929c0d5b9b88f6490098044dde50f (patch)
tree5727aae22d1bc85292d082c16fad1bf17e53b6d9
downloadaur-8928eebd09f929c0d5b9b88f6490098044dde50f.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD53
-rw-r--r--borderfix.patch29
3 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a393cd8f3ec4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Fri May 18 07:22:07 UTC 2018
+pkgbase = xfce4-panel-borderfix
+ pkgdesc = Panel for the Xfce desktop environment with a patch fixing border behavior using two monitors stacked on top each other
+ pkgver = 4.12.2
+ pkgrel = 1
+ url = http://www.xfce.org/
+ arch = x86_64
+ groups = xfce4
+ license = GPL2
+ makedepends = intltool
+ makedepends = gtk-doc
+ depends = exo
+ depends = garcon
+ depends = libxfce4ui
+ depends = libwnck
+ depends = hicolor-icon-theme
+ depends = desktop-file-utils
+ provides = xfce4-panel
+ conflicts = xfce4-panel
+ source = https://archive.xfce.org/src/xfce/xfce4-panel/4.12/xfce4-panel-4.12.2.tar.bz2
+ source = borderfix.patch
+ sha256sums = 42058abb81b8f87691d3999627447de71c3285bcf055f308aab5cefab2de0ce9
+ sha256sums = effbe9c073f37987f877a168beddcfc03a38ec3adcba57a2cce3ce93b3420176
+
+pkgname = xfce4-panel-borderfix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cb7cfb434f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Contributor: Sebastian Wolf <fatmike303@gmail.com>
+#
+# This fixes the following issue:
+# https://bugzilla.xfce.org/show_bug.cgi?id=9693
+
+pkgname=xfce4-panel-borderfix
+_pkgname=xfce4-panel
+pkgver=4.12.2
+pkgrel=1
+pkgdesc="Panel for the Xfce desktop environment with a patch fixing border behavior using two monitors stacked on top each other"
+arch=('x86_64')
+url="http://www.xfce.org/"
+license=('GPL2')
+groups=('xfce4')
+provides=($_pkgname)
+conflicts=($_pkgname)
+depends=('exo' 'garcon' 'libxfce4ui' 'libwnck' 'hicolor-icon-theme' 'desktop-file-utils')
+makedepends=('intltool' 'gtk-doc')
+source=(
+ https://archive.xfce.org/src/xfce/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.bz2
+ 'borderfix.patch'
+)
+sha256sums=(
+ '42058abb81b8f87691d3999627447de71c3285bcf055f308aab5cefab2de0ce9'
+ 'effbe9c073f37987f877a168beddcfc03a38ec3adcba57a2cce3ce93b3420176'
+)
+
+prepare() {
+ patch -d "$srcdir/$_pkgname-$pkgver" -p1 < borderfix.patch
+}
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-gio-unix \
+ --enable-gtk-doc \
+ --enable-gtk3 \
+ --disable-debug
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/borderfix.patch b/borderfix.patch
new file mode 100644
index 000000000000..b9a2e291d79c
--- /dev/null
+++ b/borderfix.patch
@@ -0,0 +1,29 @@
+diff --git a/panel/panel-window.c b/panel/panel-window.c
+index c21aac3..d0c91f0 100644
+--- a/panel/panel-window.c
++++ b/panel/panel-window.c
+@@ -2104,18 +2104,18 @@ panel_window_screen_layout_changed (GdkScreen *screen,
+ || (window->struts_edge == STRUTS_EDGE_RIGHT
+ && b.x + b.width > a.x + a.width))
+ {
+- dest_y = MAX (a.y, b.y);
+- dest_h = MIN (a.y + a.height, b.y + b.height) - dest_y;
+- if (dest_h > 0)
++ dest_x = MAX (a.x, b.x);
++ dest_w = MIN (a.x + a.width, b.x + b.width) - dest_x;
++ if (dest_w > 0)
+ window->struts_edge = STRUTS_EDGE_NONE;
+ }
+ else if ((window->struts_edge == STRUTS_EDGE_TOP && b.y < a.y)
+ || (window->struts_edge == STRUTS_EDGE_BOTTOM
+ && b.y + b.height > a.y + a.height))
+ {
+- dest_x = MAX (a.x, b.x);
+- dest_w = MIN (a.x + a.width, b.x + b.width) - dest_x;
+- if (dest_w > 0)
++ dest_y = MAX (a.y, b.y);
++ dest_h = MIN (a.y + a.height, b.y + b.height) - dest_y;
++ if (dest_h > 0)
+ window->struts_edge = STRUTS_EDGE_NONE;
+ }
+ }