summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkrims0n2016-04-07 13:00:10 +0200
committerkrims0n2016-04-07 13:00:10 +0200
commit04ef8690c943572489d91688bc5ca048d6487f78 (patch)
tree31d8c213707dd488b65c9dc9a498346f35e3bf33
downloadaur-04ef8690c943572489d91688bc5ca048d6487f78.tar.gz
Initial commit.
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD50
-rw-r--r--xfce4-panel-hidpi.install14
-rw-r--r--xfce4-panel-hidpi.patch15
4 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..109c7a84d89f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = xfce4-panel-hidpi
+ pkgdesc = Panel for the Xfce desktop environment with bigger icons in tasklist for HiDPI displays
+ pkgver = 4.12.0
+ pkgrel = 1
+ url = http://www.xfce.org/
+ install = xfce4-panel-hidpi.install
+ arch = i686
+ arch = x86_64
+ groups = xfce4
+ license = GPL2
+ makedepends = intltool
+ makedepends = gtk-doc
+ depends = exo
+ depends = garcon
+ depends = libxfce4ui
+ depends = libwnck
+ depends = hicolor-icon-theme
+ depends = desktop-file-utils
+ provides = xfce4-panel=4.12.0
+ conflicts = xfce4-panel
+ conflicts = xfce4-panel-devel
+ conflicts = xfce4-panel-git
+ source = http://archive.xfce.org/src/xfce/xfce4-panel-hidpi/4.12/xfce4-panel-4.12.0.tar.bz2
+ source = xfce4-panel-hidpi.patch
+ sha256sums = 30920fc2e2fc26279a82b5261a155c2cc15ab2aa1ced2275684a6ff8261b97b0
+ sha256sums = 5415a842fdd811a6bd5ac726c80110b663feee12b0847378559ed97846fb22fe
+
+pkgname = xfce4-panel-hidpi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37e01f10b094
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: krimson32 <krims0n32 omnomnom gmail.com>
+# Contributor: krimson32 <krims0n32 omnomnom gmail.com>
+
+_pkgname=xfce4-panel
+pkgname=${_pkgname}-hidpi
+pkgver=4.12.0
+pkgrel=1
+pkgdesc="Panel for the Xfce desktop environment with bigger icons in tasklist for HiDPI displays"
+arch=('i686' 'x86_64')
+url="http://www.xfce.org/"
+license=('GPL2')
+groups=('xfce4')
+depends=('exo' 'garcon' 'libxfce4ui' 'libwnck' 'hicolor-icon-theme'
+ 'desktop-file-utils')
+makedepends=('intltool' 'gtk-doc')
+conflicts=("${_pkgname}" "${_pkgname}-devel" "${_pkgname}-git")
+provides=("${_pkgname}=${pkgver}")
+install=$pkgname.install
+source=(http://archive.xfce.org/src/xfce/$pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.bz2 xfce4-panel-hidpi.patch)
+sha256sums=('30920fc2e2fc26279a82b5261a155c2cc15ab2aa1ced2275684a6ff8261b97b0'
+ '5415a842fdd811a6bd5ac726c80110b663feee12b0847378559ed97846fb22fe')
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ patch -p1 -i $srcdir/xfce4-panel-hidpi.patch
+}
+
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-gio-unix \
+ --enable-gtk-doc \
+ --enable-gtk3 \
+ --disable-debug
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/xfce4-panel-hidpi.install b/xfce4-panel-hidpi.install
new file mode 100644
index 000000000000..c7a5da3595e8
--- /dev/null
+++ b/xfce4-panel-hidpi.install
@@ -0,0 +1,14 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/xfce4-panel-hidpi.patch b/xfce4-panel-hidpi.patch
new file mode 100644
index 000000000000..44b2f5f0a2ce
--- /dev/null
+++ b/xfce4-panel-hidpi.patch
@@ -0,0 +1,15 @@
+diff -aur xfce4-panel-4.12.0.pristine/plugins/tasklist/tasklist-widget.c xfce4-panel-4.12.0.new/plugins/tasklist/tasklist-widget.c
+--- xfce4-panel-4.12.0.pristine/plugins/tasklist/tasklist-widget.c 2016-02-09 12:01:32.935816562 +0100
++++ xfce4-panel-4.12.0.new/plugins/tasklist/tasklist-widget.c 2016-02-09 15:57:11.018924063 +0100
+@@ -2449,10 +2449,7 @@
+ return;
+
+ /* get the window icon */
+- if (tasklist->show_labels)
+- pixbuf = wnck_window_get_mini_icon (window);
+- else
+- pixbuf = wnck_window_get_icon (window);
++ pixbuf = wnck_window_get_icon (window);
+
+ /* leave when there is no valid pixbuf */
+ if (G_UNLIKELY (pixbuf == NULL))