summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbudRich2022-03-31 16:47:05 +0200
committerbudRich2022-03-31 16:47:05 +0200
commit4ac60d032a9b041a2f6ae52383f511148eb974d3 (patch)
tree553fa6da031789a1f324987f513680a90f015c64
downloadaur-4ac60d032a9b041a2f6ae52383f511148eb974d3.tar.gz
initial release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9954c74e0cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xfce4-panel-i3-plugins
+ pkgdesc = Xfce4-panel plugins modified to work better with i3wm
+ pkgver = 2022.03.31.1
+ pkgrel = 1
+ url = https://github.com/budRich/xfce4-panel-i3-plugins
+ arch = any
+ license = GPL2
+ makedepends = xfce4-panel
+ makedepends = xfce4-dev-tools
+ depends = i3-wm
+ depends = i3ass
+ depends = xfce4-panel
+ source = https://github.com/budRich/xfce4-panel-i3-plugins/archive/2022.03.31.1/xfce4-panel-i3-plugins-2022.03.31.1.tar.gz
+ sha256sums = a93e6785eee59aa2f53b9d1a86716cd60b297b964b947f84840c054e2ca64958
+
+pkgname = xfce4-panel-i3-plugins
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..569950d0b959
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: budRich
+# Contributor: budRich
+
+pkgname=xfce4-panel-i3-plugins
+pkgver=2022.03.31.1
+pkgrel=1
+pkgdesc='Xfce4-panel plugins modified to work better with i3wm'
+arch=('any')
+url='https://github.com/budRich/xfce4-panel-i3-plugins'
+license=('GPL2')
+depends=('i3-wm' 'i3ass' 'xfce4-panel')
+makedepends=('xfce4-panel' 'xfce4-dev-tools')
+source=("$url/archive/$pkgver/${pkgname}-$pkgver.tar.gz")
+sha256sums=('a93e6785eee59aa2f53b9d1a86716cd60b297b964b947f84840c054e2ca64958')
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make && make DESTDIR="$pkgdir/" PREFIX=/usr install
+}