summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2018-07-15 17:26:51 -0400
committerTed Alff2018-07-15 17:26:51 -0400
commit257ec1081c9a1ea413b098515be7e51eff79c351 (patch)
treeccf83a68081466bc542dbc707a80fe5f0a160d61
downloadaur-257ec1081c9a1ea413b098515be7e51eff79c351.tar.gz
Initial commit.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85c92e05fa37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Jul 15 21:26:41 UTC 2018
+pkgbase = xfce4-panel-profiles
+ pkgdesc = Simple application to manage Xfce panel layouts
+ pkgver = 1.0.7
+ pkgrel = 1
+ url = https://launchpad.net/xfpanel-switch
+ arch = any
+ license = GPL3
+ makedepends = intltool
+ makedepends = git
+ depends = xfce4-panel
+ depends = gtk3
+ depends = python-gobject
+ conflicts = xfpanel-switch
+ source = git://git.xfce.org/apps/xfce4-panel-profiles#tag=xfce4-panel-profiles-1.0.7
+ sha256sums = SKIP
+
+pkgname = xfce4-panel-profiles
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5b80d9f6e09
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+# Contributor: Bernhard Landauer <oberon@manjaro.org>
+
+pkgname=xfce4-panel-profiles
+pkgver=1.0.7
+pkgrel=1
+pkgdesc="Simple application to manage Xfce panel layouts"
+arch=('any')
+url="https://launchpad.net/xfpanel-switch"
+license=('GPL3')
+depends=('xfce4-panel' 'gtk3' 'python-gobject')
+makedepends=('intltool' 'git')
+conflicts=('xfpanel-switch')
+replces=('xfpanel-switch')
+source=("git://git.xfce.org/apps/xfce4-panel-profiles#tag=${pkgname}-${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}" #-${pkgver}"
+ ./configure --prefix=/usr --python=python
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}" #-${pkgver}"
+ make install DESTDIR="${pkgdir}"
+}