summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2021-02-23 14:11:08 -0500
committerTed Alff2021-02-23 14:11:08 -0500
commita1e13e34ae054a0da190f88ac3fc6ddaa2841c98 (patch)
treeba806e0a7483800a3e0dc8137a127ffaf4d5ac7b
parenta72fa607e138aa37419850d4a9cdd3544f0f93d8 (diff)
downloadaur-a1e13e34ae054a0da190f88ac3fc6ddaa2841c98.tar.gz
Version bump 1.0.13
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--fix_check_desktop_fn.patch21
3 files changed, 8 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42f4d11ca158..a68fe599a5b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xfce4-panel-profiles
pkgdesc = Simple application to manage Xfce panel layouts
- pkgver = 1.0.12
- pkgrel = 2
+ pkgver = 1.0.13
+ pkgrel = 1
url = https://git.xfce.org/apps/xfce4-panel-profiles/about/
arch = any
groups = xfce4-goodies
@@ -10,10 +10,8 @@ pkgbase = xfce4-panel-profiles
depends = xfce4-panel
depends = python-gobject
conflicts = xfpanel-switch
- source = https://archive.xfce.org/src/apps/xfce4-panel-profiles/1.0/xfce4-panel-profiles-1.0.12.tar.bz2
- source = fix_check_desktop_fn.patch
- sha256sums = 246e459d2d2f3f524968440ed7fddb2a891567ebc05f10a800f7f5821b3452a7
- sha256sums = 0f126a008693bf86a8606564cbdafeec50b580eff1a273f60cc4e67dc1830748
+ source = https://archive.xfce.org/src/apps/xfce4-panel-profiles/1.0/xfce4-panel-profiles-1.0.13.tar.bz2
+ sha256sums = bc387c13f94109422dc72b0fcb919b0dc11619ba589d03e492252b0d2513b170
pkgname = xfce4-panel-profiles
diff --git a/PKGBUILD b/PKGBUILD
index 12f6729663ff..64e805562b39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Bernhard Landauer <oberon@manjaro.org>
pkgname=xfce4-panel-profiles
-pkgver=1.0.12
-pkgrel=2
+pkgver=1.0.13
+pkgrel=1
pkgdesc="Simple application to manage Xfce panel layouts"
arch=('any')
url="https://git.xfce.org/apps/xfce4-panel-profiles/about/"
@@ -13,15 +13,8 @@ depends=('xfce4-panel' 'python-gobject')
makedepends=('intltool')
conflicts=('xfpanel-switch')
replces=('xfpanel-switch')
-source=("https://archive.xfce.org/src/apps/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2"
- 'fix_check_desktop_fn.patch')
-sha256sums=('246e459d2d2f3f524968440ed7fddb2a891567ebc05f10a800f7f5821b3452a7'
- '0f126a008693bf86a8606564cbdafeec50b580eff1a273f60cc4e67dc1830748')
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -uNp2 -r- -i ../fix_check_desktop_fn.patch
-}
+source=("https://archive.xfce.org/src/apps/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('bc387c13f94109422dc72b0fcb919b0dc11619ba589d03e492252b0d2513b170')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/fix_check_desktop_fn.patch b/fix_check_desktop_fn.patch
deleted file mode 100644
index 83fb2315233a..000000000000
--- a/fix_check_desktop_fn.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naur ./xfce4-panel-profiles-1.0.12.orig/xfce4-panel-profiles/panelconfig.py ./xfce4-panel-profiles-1.0.12/xfce4-panel-profiles/panelconfig.py
---- ./xfce4-panel-profiles-1.0.12.orig/xfce4-panel-profiles/panelconfig.py 2021-01-04 20:57:26.586270762 -0500
-+++ ./xfce4-panel-profiles-1.0.12/xfce4-panel-profiles/panelconfig.py 2021-01-04 20:59:11.042768564 -0500
-@@ -119,12 +119,15 @@
- self.remove_keys(rem_keys)
-
- def check_desktop(self, path):
-- if not os.path.isfile(path):
-+ try:
-+ _bytes = self.get_desktop_source_file(path).read()
-+ except FileNotFoundError:
-+ # If the .desktop file does not exist at all return False
- return False
-
- # Check if binary exists
- keyfile = GLib.KeyFile.new()
-- decoded = bytes.decode()
-+ decoded = _bytes.decode()
- if keyfile.load_from_data(decoded, len(decoded),
- GLib.KeyFileFlags.NONE):
- try: