summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2017-09-09 08:36:18 -0400
committerTed Alff2017-09-09 08:36:18 -0400
commitaffcaf5cd6748b4ea9d6c590b48508b44c3920f8 (patch)
tree3f264cb78ccd92143bc2d0eb2a9e2c4e7679691b
downloadaur-affcaf5cd6748b4ea9d6c590b48508b44c3920f8.tar.gz
Initial upload
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD50
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4216b8216466
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Sat Sep 9 12:36:10 UTC 2017
+pkgbase = xfce4-pulseaudio-plugin-git
+ pkgdesc = Pulseaudio plugin for Xfce4 panel
+ pkgver = 0.3.0+2+gdea2be9
+ pkgrel = 1
+ url = https://goodies.xfce.org/projects/panel-plugins/xfce4-pulseaudio-plugin
+ arch = i686
+ arch = x86_64
+ groups = xfce4-goodies
+ license = GPL2
+ makedepends = intltool
+ makedepends = git
+ makedepends = xfce4-dev-tools
+ makedepends = python
+ depends = xfce4-panel
+ depends = libpulse
+ depends = libkeybinder3
+ depends = libnotify
+ optdepends = pavucontrol: default pulseaudio mixer
+ provides = xfce4-pulseaudio-plugin=0.3.0+2+gdea2be9
+ conflicts = xfce4-pulseaudio-plugin
+ source = git://git.xfce.org/panel-plugins/xfce4-pulseaudio-plugin
+ sha256sums = SKIP
+
+pkgname = xfce4-pulseaudio-plugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de1fe4929d79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+_pkgname=xfce4-pulseaudio-plugin
+pkgname=${_pkgname}-git
+pkgver=0.3.0+2+gdea2be9
+pkgrel=1
+pkgdesc="Pulseaudio plugin for Xfce4 panel"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="https://goodies.xfce.org/projects/panel-plugins/xfce4-pulseaudio-plugin"
+groups=('xfce4-goodies')
+depends=('xfce4-panel' 'libpulse' 'libkeybinder3' 'libnotify')
+makedepends=('intltool' 'git' 'xfce4-dev-tools' 'python') #for gdbus-codegen
+optdepends=('pavucontrol: default pulseaudio mixer')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}=${pkgver%.r*}")
+source=("git://git.xfce.org/panel-plugins/${_pkgname}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --tags | sed "s/^${_pkgname}-//;s/-/+/g"
+}
+
+prepare() {
+ cd $_pkgname
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd "$_pkgname"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --enable-keybinder \
+ --enable-libnotify \
+ --enable-maintainer-mode
+
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
+}
+
+package() {
+ cd "$_pkgname"
+
+ make DESTDIR="${pkgdir}" install
+}