summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPablo Lezaeta Reyes2015-05-26 04:54:42 -0300
committerPablo Lezaeta Reyes2015-05-26 04:54:42 -0300
commit72bdaa1218024298274dbe648611c5e2cd1f8621 (patch)
treef4c48d5df554717fb30c704eebb557587e26f315
downloadaur-72bdaa1218024298274dbe648611c5e2cd1f8621.tar.gz
added xfce thing
Signed-off-by: Pablo Lezaeta Reyes <prflr88@gmail.com>
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD58
-rw-r--r--xfce4-quicklauncher-plugin-1.9.4-desktop-file.patch10
-rw-r--r--xfce4-quicklauncher-plugin-1.9.4-fix-missing-english-translation.patch103
-rw-r--r--xfce4-quicklauncher-plugin-1.9.4-fix-multiscreen.patch27
-rw-r--r--xfce4-quicklauncher-plugin-1.9.4-save-settings.patch12
-rw-r--r--xfce4-quicklauncher-plugin-1.9.4-xfce4-settings-manager.patch11
7 files changed, 248 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db223df6d78d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = xfce4-quicklauncher-plugin
+ pkgdesc = Plugin that creates little application launchers in the Xfce4 panel
+ pkgver = 1.9.4
+ pkgrel = 11
+ url = http://goodies.xfce.org/projects/panel-plugins/xfce4-quicklauncher-plugin
+ arch = i686
+ arch = x86_64
+ groups = xfce4-goodies
+ license = GPL2
+ makedepends = intltool
+ depends = xfce4-panel
+ depends = libxfcegui4
+ source = http://archive.xfce.org/src/panel-plugins/xfce4-quicklauncher-plugin/1.9/xfce4-quicklauncher-plugin-1.9.4.tar.bz2
+ source = xfce4-quicklauncher-plugin-1.9.4-desktop-file.patch
+ source = xfce4-quicklauncher-plugin-1.9.4-fix-missing-english-translation.patch
+ source = xfce4-quicklauncher-plugin-1.9.4-fix-multiscreen.patch
+ source = xfce4-quicklauncher-plugin-1.9.4-save-settings.patch
+ source = xfce4-quicklauncher-plugin-1.9.4-xfce4-settings-manager.patch
+ sha256sums = 0b253d96e3b3fb02508e1100cbf39bfb8b40e9c75da75053e6432d83dedfffdf
+ sha256sums = b652819d9f4b1c1b1851e7fbd6f811c9087ca500cd8231abf7aa28072293254e
+ sha256sums = 3d7b41a5f4c8a7506f57f612b68b6b92cdd2d251cc7d3b7a7762bbaed60d612d
+ sha256sums = f2ec190adcf1d4bef2317b29a3005ce3066b34f9cf5d6a48c045112f1c16c4c3
+ sha256sums = 7944d9ac739cefd37fc00abca2ed6d7c45b00ed7afd02bb8779d9a11b54d986e
+ sha256sums = 0c678f3128df6b3061fa409a06c2399e43031f7424a1aaa6643fa98aa02e25c7
+
+pkgname = xfce4-quicklauncher-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b32f1e66d9ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# $Id: PKGBUILD 233049 2015-03-08 08:14:35Z $
+# Contributor: Pablo Lezaeta <prflr88@gmail.com>
+# Contributor: Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor: Tobias Kieslich <tobias (at) archlinux.org>
+
+pkgname=xfce4-quicklauncher-plugin
+pkgver=1.9.4
+pkgrel=11
+pkgdesc="Plugin that creates little application launchers in the Xfce4 panel"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-quicklauncher-plugin"
+groups=('xfce4-goodies')
+depends=('xfce4-panel' 'libxfcegui4')
+makedepends=('intltool')
+source=(http://archive.xfce.org/src/panel-plugins/$pkgname/1.9/$pkgname-$pkgver.tar.bz2
+ xfce4-quicklauncher-plugin-1.9.4-desktop-file.patch
+ xfce4-quicklauncher-plugin-1.9.4-fix-missing-english-translation.patch
+ xfce4-quicklauncher-plugin-1.9.4-fix-multiscreen.patch
+ xfce4-quicklauncher-plugin-1.9.4-save-settings.patch
+ xfce4-quicklauncher-plugin-1.9.4-xfce4-settings-manager.patch)
+sha256sums=('0b253d96e3b3fb02508e1100cbf39bfb8b40e9c75da75053e6432d83dedfffdf'
+ 'b652819d9f4b1c1b1851e7fbd6f811c9087ca500cd8231abf7aa28072293254e'
+ '3d7b41a5f4c8a7506f57f612b68b6b92cdd2d251cc7d3b7a7762bbaed60d612d'
+ 'f2ec190adcf1d4bef2317b29a3005ce3066b34f9cf5d6a48c045112f1c16c4c3'
+ '7944d9ac739cefd37fc00abca2ed6d7c45b00ed7afd02bb8779d9a11b54d986e'
+ '0c678f3128df6b3061fa409a06c2399e43031f7424a1aaa6643fa98aa02e25c7')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # Patches from Fedora
+ patch -Np0 -i "$srcdir/xfce4-quicklauncher-plugin-1.9.4-desktop-file.patch"
+ patch -Np0 -i "$srcdir/xfce4-quicklauncher-plugin-1.9.4-fix-multiscreen.patch"
+ patch -Np1 -i "$srcdir/xfce4-quicklauncher-plugin-1.9.4-save-settings.patch"
+ patch -Np1 -i "$srcdir/xfce4-quicklauncher-plugin-1.9.4-fix-missing-english-translation.patch"
+ patch -Np0 -i "$srcdir/xfce4-quicklauncher-plugin-1.9.4-xfce4-settings-manager.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-debug
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/xfce4-quicklauncher-plugin-1.9.4-desktop-file.patch b/xfce4-quicklauncher-plugin-1.9.4-desktop-file.patch
new file mode 100644
index 000000000000..907c1f23e2dc
--- /dev/null
+++ b/xfce4-quicklauncher-plugin-1.9.4-desktop-file.patch
@@ -0,0 +1,10 @@
+--- panel-plugin/quicklauncher.desktop.in.in.orig 2009-07-04 00:46:34.000000000 +0200
++++ panel-plugin/quicklauncher.desktop.in.in 2009-07-04 00:46:51.000000000 +0200
+@@ -4,4 +4,6 @@
+ _Name=Quicklauncher
+ _Comment=Program with several launchers
+ Icon=gnome-fs-executable
+-X-XFCE-Module=@INTERNAL_PLUGIN_PATH@/libquicklauncher.so
++X-XFCE-Module=quicklauncher
++X-XFCE-Module-Path=@INTERNAL_PLUGIN_PATH@
++X-XFCE-Unique=false
diff --git a/xfce4-quicklauncher-plugin-1.9.4-fix-missing-english-translation.patch b/xfce4-quicklauncher-plugin-1.9.4-fix-missing-english-translation.patch
new file mode 100644
index 000000000000..96f25677032d
--- /dev/null
+++ b/xfce4-quicklauncher-plugin-1.9.4-fix-missing-english-translation.patch
@@ -0,0 +1,103 @@
+diff -Nur -x '*.orig' -x '*~' xfce4-quicklauncher-plugin-1.9.4/configure xfce4-quicklauncher-plugin-1.9.4.new/configure
+--- xfce4-quicklauncher-plugin-1.9.4/configure 2007-06-27 21:07:14.000000000 +0200
++++ xfce4-quicklauncher-plugin-1.9.4.new/configure 2008-03-04 22:11:23.000000000 +0100
+@@ -21181,7 +21181,7 @@
+
+
+
+- ALL_LINGUAS="cs el eu fr gl hu ja pl ru vi"
++ ALL_LINGUAS="cs el en eu fr gl hu ja pl ru vi"
+
+
+ for ac_header in locale.h
+diff -Nur -x '*.orig' -x '*~' xfce4-quicklauncher-plugin-1.9.4/po/en.po xfce4-quicklauncher-plugin-1.9.4.new/po/en.po
+--- xfce4-quicklauncher-plugin-1.9.4/po/en.po 1970-01-01 01:00:00.000000000 +0100
++++ xfce4-quicklauncher-plugin-1.9.4.new/po/en.po 2008-03-04 22:10:58.000000000 +0100
+@@ -0,0 +1,87 @@
++# English translation of xfce4-quicklauncher-plugin.
++# Copyright (C) 2007 THE xfce4-quicklauncher-plugin'S COPYRIGHT HOLDER
++# This file is distributed under the same license as the xfce4-quicklauncher-plugin package.
++# Jeff Bailes <thepizzaking@gmail.com>, 2007.
++# , fuzzy
++#
++#
++msgid ""
++msgstr ""
++"Project-Id-Version: xfce4-quicklauncher-plugin\n"
++"Report-Msgid-Bugs-To: \n"
++"POT-Creation-Date: 2007-05-17 21:37+0200\n"
++"PO-Revision-Date: 2007-03-31 10:17+1000\n"
++"Last-Translator: Jeff Bailes <thepizzaking@gmail.com>\n"
++"Language-Team: English\n"
++"MIME-Version: 1.0\n"
++"Content-Type: text/plain; charset=UTF-8\n"
++"Content-Transfer-Encoding: 8bit"
++
++#: ../panel-plugin/callbacks.c:79
++msgid "Configure Quicklauncher"
++msgstr "Configure Quicklauncher"
++
++#: ../panel-plugin/callbacks.c:93
++msgid "Lines: "
++msgstr "Lines: "
++
++#: ../panel-plugin/callbacks.c:123
++msgid "Espace entre les lanceurs :"
++msgstr "Space between launchers"
++
++#: ../panel-plugin/callbacks.c:131
++msgid "afficher les tooltips"
++msgstr "Show tooltips"
++
++#: ../panel-plugin/callbacks.c:135
++msgid "afficher les labels"
++msgstr "Show labels"
++
++#: ../panel-plugin/callbacks.c:216
++msgid "icone"
++msgstr "icon"
++
++#: ../panel-plugin/callbacks.c:222
++msgid "commande"
++msgstr "command"
++
++#: ../panel-plugin/callbacks.c:228
++msgid "nom"
++msgstr "name"
++
++#: ../panel-plugin/callbacks.c:327
++msgid "Open icon"
++msgstr "Open icon"
++
++#: ../panel-plugin/main.c:163 ../panel-plugin/quicklauncher.desktop.in.in.h:2
++msgid "Quicklauncher"
++msgstr "Quicklauncher"
++
++#: ../panel-plugin/main.c:166
++msgid "Allows you to add launchers easily and display them on many lines."
++msgstr "Allows you to add launchers easily and display them on many lines."
++
++#: ../panel-plugin/main.c:168
++msgid "Other plugins available here"
++msgstr "Other plugins available here"
++
++#: ../panel-plugin/main.c:320
++msgid "Lock"
++msgstr "Lock"
++
++#: ../panel-plugin/main.c:323
++msgid "Parameters"
++msgstr "Parameters"
++
++#: ../panel-plugin/main.c:326
++msgid "Applications"
++msgstr "Applications"
++
++#: ../panel-plugin/main.c:329
++msgid "Help"
++msgstr "Help"
++
++#: ../panel-plugin/quicklauncher.desktop.in.in.h:1
++msgid "Program with several launchers"
++msgstr "Program with several launchers"
++
diff --git a/xfce4-quicklauncher-plugin-1.9.4-fix-multiscreen.patch b/xfce4-quicklauncher-plugin-1.9.4-fix-multiscreen.patch
new file mode 100644
index 000000000000..9845ce122c40
--- /dev/null
+++ b/xfce4-quicklauncher-plugin-1.9.4-fix-multiscreen.patch
@@ -0,0 +1,27 @@
+--- panel-plugin/main.c.org 2008-05-13 09:29:29.000000000 -0600
++++ panel-plugin/main.c 2008-05-13 09:29:33.000000000 -0600
+@@ -148,6 +148,7 @@
+ t_qck_launcher_opt_dlg* dlg;
+ xfce_panel_plugin_block_menu(plugin);
+ dlg = create_qck_launcher_dlg();
++ gtk_window_set_screen (GTK_WINDOW (dlg->dialog), gtk_widget_get_screen (plugin));
+ qck_launcher_opt_dlg_set_quicklauncher(quicklauncher);
+ gtk_dialog_run(GTK_DIALOG(dlg->dialog));
+ xfce_panel_plugin_unblock_menu(plugin);
+@@ -160,6 +161,7 @@
+ GtkWidget *about;
+ const gchar* authors[2] = {"Bountykiller <masse_nicolas@yahoo.fr>", NULL};
+ about = gtk_about_dialog_new();
++ gtk_window_set_screen (GTK_WINDOW (about), gtk_widget_get_screen (plugin));
+ gtk_about_dialog_set_name(GTK_ABOUT_DIALOG(about), _("Quicklauncher"));
+ gtk_about_dialog_set_logo(GTK_ABOUT_DIALOG(about), NULL);
+ gtk_about_dialog_set_authors(GTK_ABOUT_DIALOG(about), (const gchar**) authors);
+@@ -461,7 +463,7 @@
+ if(launcher->quicklauncher->_last_zoomed_launcher == launcher)
+ {
+ g_return_val_if_fail(launcher->clicked_img, FALSE);
+- xfce_exec(launcher->command, FALSE, FALSE, NULL);
++ xfce_exec_on_screen(gtk_widget_get_screen (box), launcher->command, FALSE, FALSE, NULL);
+ gtk_image_set_from_pixbuf (GTK_IMAGE(launcher->image), launcher->def_img);
+ }
+ else
diff --git a/xfce4-quicklauncher-plugin-1.9.4-save-settings.patch b/xfce4-quicklauncher-plugin-1.9.4-save-settings.patch
new file mode 100644
index 000000000000..85dd2172940b
--- /dev/null
+++ b/xfce4-quicklauncher-plugin-1.9.4-save-settings.patch
@@ -0,0 +1,12 @@
+Index: xfce4-quicklauncher-plugin-1.9.4/panel-plugin/main.c
+===================================================================
+--- xfce4-quicklauncher-plugin-1.9.4/panel-plugin/main.c (révision 3779)
++++ xfce4-quicklauncher-plugin-1.9.4/panel-plugin/main.c (révision 3780)
+@@ -151,6 +151,7 @@
+ gtk_window_set_screen (GTK_WINDOW (dlg->dialog), gtk_widget_get_screen (plugin));
+ qck_launcher_opt_dlg_set_quicklauncher(quicklauncher);
+ gtk_dialog_run(GTK_DIALOG(dlg->dialog));
++ quicklauncher_save(plugin, quicklauncher);
+ xfce_panel_plugin_unblock_menu(plugin);
+ }
+
diff --git a/xfce4-quicklauncher-plugin-1.9.4-xfce4-settings-manager.patch b/xfce4-quicklauncher-plugin-1.9.4-xfce4-settings-manager.patch
new file mode 100644
index 000000000000..8314d7a3cb82
--- /dev/null
+++ b/xfce4-quicklauncher-plugin-1.9.4-xfce4-settings-manager.patch
@@ -0,0 +1,11 @@
+--- panel-plugin/main.c.orig 2009-09-09 21:15:01.000000000 +0200
++++ panel-plugin/main.c 2009-09-09 21:23:12.000000000 +0200
+@@ -320,7 +320,7 @@
+ launcher = launcher_new(_("Lock"), "xflock4", XFCE_ICON_CATEGORY_SYSTEM,
+ NULL, quicklauncher);
+ quicklauncher_add_element(quicklauncher, launcher);
+- launcher = launcher_new(_("Parameters"),"xfce-setting-show", XFCE_ICON_CATEGORY_SETTINGS,
++ launcher = launcher_new(_("Parameters"),"xfce4-settings-manager", XFCE_ICON_CATEGORY_SETTINGS,
+ NULL, quicklauncher);
+ quicklauncher_add_element(quicklauncher, launcher);
+ launcher = launcher_new(_("Applications"), "xfce4-appfinder", XFCE_ICON_CATEGORY_UTILITY,