summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre Miranda2024-04-03 21:10:23 +0200
committerAndre Miranda2024-04-03 21:10:23 +0200
commit5401bbc05264b508e20712b5c55d75e9af03d19e (patch)
treeb174f5ed6eabda8cb6b9b9983cd6269bfbe1ead0
parent22a8df760e18c8ee1dbca63337c1f72cc9db8f34 (diff)
downloadaur-xfce4-screenshooter-git.tar.gz
Fix build with latest git
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1ad8367acb5..42a74a243da2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xfce4-screenshooter-git
pkgdesc = Plugin that makes screenshots for the Xfce panel.
- pkgver = 1.9.10.r38.g13d0c95
+ pkgver = 1.10.5.r50.g2a7d7de
pkgrel = 1
url = https://docs.xfce.org/apps/screenshooter/start
install = xfce4-screenshooter-git.install
@@ -10,11 +10,12 @@ pkgbase = xfce4-screenshooter-git
license = GPL2
makedepends = xfce4-dev-tools
makedepends = intltool
+ makedepends = git
depends = xfce4-panel
depends = libsoup
provides = xfce4-screenshooter
conflicts = xfce4-screenshooter
- source = xfce4-screenshooter-git::git+https://gitlab.xfce.org/apps/xfce4-screenshooter
+ source = xfce4-screenshooter-git::git+https://gitlab.xfce.org/apps/xfce4-screenshooter.git
sha256sums = SKIP
pkgname = xfce4-screenshooter-git
diff --git a/PKGBUILD b/PKGBUILD
index 88d3cd7540dc..3bd2185a69c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Skunnyk <skunnyk@archlinux.fr>
# Maintainer: Andre Miranda <andreldm at xfce dot org>
pkgname=xfce4-screenshooter-git
-pkgver=1.9.10.r38.g13d0c95
+pkgver=1.10.5.r50.g2a7d7de
pkgrel=1
pkgdesc="Plugin that makes screenshots for the Xfce panel."
arch=('i686' 'x86_64')
@@ -9,19 +9,23 @@ url="https://docs.xfce.org/apps/screenshooter/start"
license=('GPL2')
groups=('xfce4-goodies')
depends=('xfce4-panel' 'libsoup')
-makedepends=('xfce4-dev-tools' 'intltool')
+makedepends=('xfce4-dev-tools' 'intltool' 'git')
provides=('xfce4-screenshooter')
conflicts=('xfce4-screenshooter')
install=$pkgname.install
-source=($pkgname::git+https://gitlab.xfce.org/apps/xfce4-screenshooter)
+source=($pkgname::git+https://gitlab.xfce.org/apps/xfce4-screenshooter.git)
sha256sums=('SKIP')
+
pkgver() {
cd "$srcdir/$pkgname"
git describe --long | sed -r 's/^xfce4-screenshooter-//;s/([^-]*-g)/r\1/;s/-/./g'
}
-build() {
+prepare () {
cd "$srcdir/$pkgname"
+
+ git submodule update --init
+
./autogen.sh \
--prefix=/usr \
--sysconfdir=/etc \
@@ -29,10 +33,14 @@ build() {
--localstatedir=/var \
--disable-static \
--disable-debug
+}
+
+build() {
+ cd "$srcdir/$pkgname"
make
}
+
package() {
cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir" install
}
-# vim:set ts=2 sw=2 et: