summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBradley Kennedy2015-09-27 01:53:11 -0400
committerBradley Kennedy2015-09-27 01:53:11 -0400
commita26dc14885d9649a05911a58286f71d595e3e048 (patch)
tree62ed65648929e48877b7daefe1f132824424156d
downloadaur-a26dc14885d9649a05911a58286f71d595e3e048.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD53
-rw-r--r--xfce4-sensors-plugin-nvidia.install13
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea586f9603dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = xfce4-sensors-plugin-nvidia
+ pkgdesc = A lm_sensors plugin for the Xfce panel with nvidia gpu support
+ pkgver = 1.2.6
+ pkgrel = 2
+ url = http://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin
+ install = xfce4-sensors-plugin-nvidia.install
+ arch = i686
+ arch = x86_64
+ groups = xfce4-goodies
+ license = GPL2
+ makedepends = intltool
+ makedepends = hddtemp
+ makedepends = gnu-netcat
+ depends = xfce4-panel
+ depends = lm_sensors
+ depends = libnotify
+ depends = hicolor-icon-theme
+ depends = libxnvctrl
+ optdepends = hddtemp: for monitoring the temperature of hard drives
+ conflicts = xfce4-sensors-plugin
+ source = http://archive.xfce.org/src/panel-plugins/xfce4-sensors-plugin/1.2/xfce4-sensors-plugin-1.2.6.tar.bz2
+ sha256sums = 235ef842bd45e701bceebb21a384ab09f21afceea8ed95f91bb4c6cf3abe1bc0
+
+pkgname = xfce4-sensors-plugin-nvidia
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..775b1ac69b8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# $Id$
+# See AUR interface for current maintainer
+# Edited to include libxnvctrl dependancy
+# Based on http://xfce.10915.n7.nabble.com/NVidia-data-td16172.html
+# also based on arch bug report https://bugs.archlinux.org/task/25548
+
+# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Merk Matthias <macem@chello.at>
+
+pkgname=xfce4-sensors-plugin-nvidia
+pkgver=1.2.6
+pkgrel=2
+pkgdesc="A lm_sensors plugin for the Xfce panel with nvidia gpu support"
+arch=('i686' 'x86_64')
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
+license=('GPL2')
+groups=('xfce4-goodies')
+depends=('xfce4-panel' 'lm_sensors' 'libnotify' 'hicolor-icon-theme' 'libxnvctrl')
+makedepends=('intltool' 'hddtemp' 'gnu-netcat')
+optdepends=('hddtemp: for monitoring the temperature of hard drives')
+conflicts=('xfce4-sensors-plugin')
+install=$pkgname.install
+# _pkgname lets us rename the package without altering the script too much
+_pkgname=xfce4-sensors-plugin
+source=(http://archive.xfce.org/src/panel-plugins/$_pkgname/1.2/$_pkgname-$pkgver.tar.bz2)
+sha256sums=('235ef842bd45e701bceebb21a384ab09f21afceea8ed95f91bb4c6cf3abe1bc0')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ # Satisfy the check that hddtemp is queryable via netcat
+ # (https://bugs.archlinux.org/task/28275)
+ echo ohai | nc -l -p 7634 -s localhost -c &
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --datadir=/usr/share \
+ --datarootdir=/usr/share \
+ --disable-static \
+ --disable-debug
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/xfce4-sensors-plugin-nvidia.install b/xfce4-sensors-plugin-nvidia.install
new file mode 100644
index 000000000000..e4f8fd06c1ed
--- /dev/null
+++ b/xfce4-sensors-plugin-nvidia.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et: