summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFirstAirBender2021-06-05 12:42:50 -0600
committerFirstAirBender2021-06-05 12:42:50 -0600
commitb96fb7adfc20524f989dc9c51a450c66a33d8475 (patch)
tree518de48a44fe081d02359c6bcf773f637de91e85
parent39140ae74c10ee873552dc410d4421a8f95b4307 (diff)
downloadaur-b96fb7adfc20524f989dc9c51a450c66a33d8475.tar.gz
patch nvidia.c file for 1.3.95 release
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
-rw-r--r--nvidia.c.patch4
3 files changed, 20 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8dff0abc1397..87817c55c326 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xfce4-sensors-plugin-nvidia
pkgdesc = A lm_sensors plugin for the Xfce panel with nvidia gpu support
- pkgver = 1.3.92
+ pkgver = 1.3.95
pkgrel = 1
url = https://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin
arch = i686
@@ -17,8 +17,9 @@ pkgbase = xfce4-sensors-plugin-nvidia
depends = libxnvctrl
optdepends = hddtemp: for monitoring the temperature of hard drives
conflicts = xfce4-sensors-plugin
- source = https://archive.xfce.org/src/panel-plugins/xfce4-sensors-plugin/1.3/xfce4-sensors-plugin-1.3.92.tar.bz2
- sha256sums = 3dc6643d2c064b7718badff44b948f8d410f00f13db197820b26ae38045f5112
+ source = https://archive.xfce.org/src/panel-plugins/xfce4-sensors-plugin/1.3/xfce4-sensors-plugin-1.3.95.tar.bz2
+ source = nvidia.c.patch
+ sha256sums = 83c64ae4618dd592971cfa0bc285a9b47af801a3ed856835cdb2a4c533c7846c
+ sha256sums = 5ed9142eb3b213f7b9b354ba3e967994a9046c78579256567ebda7e462237d8a
pkgname = xfce4-sensors-plugin-nvidia
-
diff --git a/PKGBUILD b/PKGBUILD
index 78ee53d714c4..87a9f34255cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pkgname=xfce4-sensors-plugin
pkgname=xfce4-sensors-plugin-nvidia
-pkgver=1.3.92
+pkgver=1.3.95
pkgrel=1
pkgdesc="A lm_sensors plugin for the Xfce panel with nvidia gpu support"
arch=('i686' 'x86_64')
@@ -20,8 +20,16 @@ depends=('xfce4-panel' 'lm_sensors' 'libnotify' 'hicolor-icon-theme' 'libxnvctrl
makedepends=('intltool' 'hddtemp' 'gnu-netcat')
optdepends=('hddtemp: for monitoring the temperature of hard drives')
conflicts=('xfce4-sensors-plugin')
-source=(https://archive.xfce.org/src/panel-plugins/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.bz2)
-sha256sums=('3dc6643d2c064b7718badff44b948f8d410f00f13db197820b26ae38045f5112')
+source=(
+ https://archive.xfce.org/src/panel-plugins/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.bz2
+ nvidia.c.patch
+)
+sha256sums=('83c64ae4618dd592971cfa0bc285a9b47af801a3ed856835cdb2a4c533c7846c'
+ '5ed9142eb3b213f7b9b354ba3e967994a9046c78579256567ebda7e462237d8a')
+
+prepare() {
+ patch ./"$_pkgname-$pkgver"/lib/nvidia.c -i ./nvidia.c.patch
+}
build() {
cd "$srcdir/$_pkgname-$pkgver"
diff --git a/nvidia.c.patch b/nvidia.c.patch
new file mode 100644
index 000000000000..b5dd93b4c16c
--- /dev/null
+++ b/nvidia.c.patch
@@ -0,0 +1,4 @@
+37a38
+> #include <X11/Xlib.h>
+41d41
+< #include <X11/Xlib.h>