summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2017-07-05 17:44:42 -0400
committerTed Alff2017-07-05 17:44:42 -0400
commite3f1a66a619b9b23f2500ff7bcfc7c9679b1548a (patch)
treef66ba45c188017a3f207ca863c6549b62414b10a
parent897590decc93203d79327b29985dc6242bacbc91 (diff)
downloadaur-e3f1a66a619b9b23f2500ff7bcfc7c9679b1548a.tar.gz
Adopted
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
-rw-r--r--dbus-update-environment.patch36
-rw-r--r--xfce4-session-git.install13
4 files changed, 21 insertions, 79 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06bac6d62504..fafb5882d8aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
+# Generated by mksrcinfo v8
+# Wed Jul 5 21:44:31 UTC 2017
pkgbase = xfce4-session-git
- pkgdesc = Xfce session manager - git checkout
- pkgver = 4.12.0.r101.ge6aafcf
+ pkgdesc = Xfce session manager (git checkout)
+ pkgver = 4.13.0.r38.g8ca48fe
pkgrel = 1
url = http://www.xfce.org/
- install = xfce4-session-git.install
arch = i686
arch = x86_64
- groups = xfce4
license = GPL2
- makedepends = git
makedepends = intltool
+ makedepends = git
makedepends = xfce4-dev-tools
depends = libxfce4ui
depends = libwnck3
@@ -25,14 +25,13 @@ pkgbase = xfce4-session-git
optdepends = gnome-screensaver: for locking screen with xflock4
optdepends = xlockmore: for locking screen with xflock4
optdepends = slock: for locking screen with xflock4
- provides = xfce4-session
+ provides = xfce4-session=4.13.0
conflicts = xfce4-session
- replaces = xfce4-session
- source = git://git.xfce.org/xfce/xfce4-session
- source = dbus-update-environment.patch
+ conflicts = xfce4-session-devel
+ replaces = xfce-utils
+ source = xfce4-session::git://git.xfce.org/xfce/xfce4-session
source = xfce-polkit-gnome-authentication-agent-1.desktop
sha256sums = SKIP
- sha256sums = 0a3f23c2ee1b73cec3ecb999b2cc1b5d97e7023482e42b418e6f14cd4f671c0b
sha256sums = 74c94c5f7893d714e04ec7d8b8520c978a5748757a0cdcf5128492f09f31b643
pkgname = xfce4-session-git
diff --git a/PKGBUILD b/PKGBUILD
index 1aae5dc89446..83924df30c10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,33 @@
-# Maintainer: Paul Clark <paul500clark at gmail dot com>
-# Contributor: Silvio Knizek <killermoehre@gmx.net>
+# Maintainer: twa022 <twa022 at gmail dot com>
+# Contributor: Paul Clark <paul500clark at gmail dot com>
+# Contributor: Silvio Knizek <killermoehre@gmx.net>
# Contributor: Evangelos Foutras <evangelos@foutrelis.com>
# Contributor: Diego Principe <cdprincipeat gmaildot com>
# Contributor: Baurzhan Muftakhidinov <baurthefirst@gmail.com>
# Contributor: Pablo Lezaeta <prflr@gmail.com>
_pkgname=xfce4-session
-pkgname=xfce4-session-git
-pkgver=4.12.0.r101.ge6aafcf
+pkgname=${_pkgname}-git
+pkgver=4.13.0.r38.g8ca48fe
pkgrel=1
-pkgdesc="Xfce session manager - git checkout"
+pkgdesc="Xfce session manager (git checkout)"
arch=('i686' 'x86_64')
url="http://www.xfce.org/"
license=('GPL2')
-groups=('xfce4')
depends=('libxfce4ui' 'libwnck3' 'libsm' 'polkit' 'xorg-iceauth' 'xorg-xinit'
'xorg-xrdb' 'polkit-gnome' 'hicolor-icon-theme')
-makedepends=('git' 'intltool' 'xfce4-dev-tools')
+makedepends=('intltool' 'git' 'xfce4-dev-tools')
optdepends=('gnome-keyring: for keyring support when GNOME compatibility is enabled'
'xscreensaver: for locking screen with xflock4'
'gnome-screensaver: for locking screen with xflock4'
'xlockmore: for locking screen with xflock4'
'slock: for locking screen with xflock4')
-provides=('xfce4-session')
-conflicts=('xfce4-session')
-replaces=('xfce4-session')
-install=$pkgname.install
-source=(git://git.xfce.org/xfce/xfce4-session
- dbus-update-environment.patch
- xfce-polkit-gnome-authentication-agent-1.desktop)
+provides=("${_pkgname}=${pkgver%%.r*}")
+conflicts=("${_pkgname}" "${_pkgname}-devel")
+replaces=('xfce-utils')
+source=("${_pkgname}::git://git.xfce.org/xfce/xfce4-session"
+ 'xfce-polkit-gnome-authentication-agent-1.desktop')
sha256sums=('SKIP'
- '0a3f23c2ee1b73cec3ecb999b2cc1b5d97e7023482e42b418e6f14cd4f671c0b'
'74c94c5f7893d714e04ec7d8b8520c978a5748757a0cdcf5128492f09f31b643')
pkgver() {
@@ -49,9 +46,6 @@ build() {
--disable-static \
--disable-debug
- # Support using existing dbus-daemon
- patch -Np1 -i ../dbus-update-environment.patch
-
make
}
@@ -65,5 +59,3 @@ package() {
cp "$srcdir/xfce-polkit-gnome-authentication-agent-1.desktop" \
"$pkgdir/etc/xdg/autostart/"
}
-
-# vim:set ts=2 sw=2 et:
diff --git a/dbus-update-environment.patch b/dbus-update-environment.patch
deleted file mode 100644
index f15afe11a072..000000000000
--- a/dbus-update-environment.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -u -r xfce4-session-4.12.1/scripts/xinitrc.in xfce4-session-4.12.1-dbus/scripts/xinitrc.in
---- xfce4-session-4.12.1/scripts/xinitrc.in 2015-03-16 08:29:52.000000000 +0100
-+++ xfce4-session-4.12.1-dbus/scripts/xinitrc.in 2015-09-25 18:23:46.069944338 +0200
-@@ -132,7 +132,13 @@
- export DBUS_SESSION_BUS_ADDRESS
- else
- echo "Could not find dbus-launch; Xfce will not work properly" >&2
-- fi
-+ fi
-+else
-+ if which dbus-update-activation-environment >/dev/null 2>&1; then
-+ dbus-update-activation-environment --systemd --all
-+ else
-+ echo "Could not find dbus-update-activation-environment; Xfce will not work properly" >&2
-+ fi
- fi
-
- # this is only necessary when running w/o xfce4-session
-diff -u -r xfce4-session-4.12.1/scripts/xinitrc.in.in xfce4-session-4.12.1-dbus/scripts/xinitrc.in.in
---- xfce4-session-4.12.1/scripts/xinitrc.in.in 2014-10-20 07:23:02.000000000 +0200
-+++ xfce4-session-4.12.1-dbus/scripts/xinitrc.in.in 2015-09-25 18:24:06.106572945 +0200
-@@ -132,7 +132,13 @@
- export DBUS_SESSION_BUS_ADDRESS
- else
- echo "Could not find dbus-launch; Xfce will not work properly" >&2
-- fi
-+ fi
-+else
-+ if which dbus-update-activation-environment >/dev/null 2>&1; then
-+ dbus-update-activation-environment --systemd --all
-+ else
-+ echo "Could not find dbus-update-activation-environment; Xfce will not work properly" >&2
-+ fi
- fi
-
- # this is only necessary when running w/o xfce4-session
diff --git a/xfce4-session-git.install b/xfce4-session-git.install
deleted file mode 100644
index e4f8fd06c1ed..000000000000
--- a/xfce4-session-git.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}
-
-# vim:set ts=2 sw=2 et: