summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2022-11-01 23:15:18 -0400
committerTed Alff2022-11-01 23:15:18 -0400
commit0676a0c4682cbb39666dcb07ee5245c4cdd085aa (patch)
tree70dba587350526e859b716f400dbae80309a3713
parent03394f87d6bdcec117f315647760f9ba0fa52ee0 (diff)
downloadaur-0676a0c4682cbb39666dcb07ee5245c4cdd085aa.tar.gz
Version bump 4.17.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 716c51b7e1b9..6bad82b99236 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xfce4-settings-devel
pkgdesc = Settings manager for xfce
- pkgver = 4.15.3
+ pkgver = 4.17.0
pkgrel = 1
url = https://www.xfce.org/
arch = i686
@@ -11,9 +11,9 @@ pkgbase = xfce4-settings-devel
license = GPL2
makedepends = intltool
depends = exo
- depends = libxfce4util>=4.15.2
+ depends = libxfce4util>=4.17.2
depends = garcon
- depends = libxfce4ui>=4.15.1
+ depends = libxfce4ui>=4.17.0
depends = xfconf
depends = libnotify
depends = colord
@@ -22,12 +22,11 @@ pkgbase = xfce4-settings-devel
depends = gnome-themes-extra
depends = python
optdepends = libcanberra: for sound control
- provides = xfce4-settings=4.15.3
+ provides = xfce4-settings=4.17.0
conflicts = xfce4-settings
- source = https://archive.xfce.org/src/xfce/xfce4-settings/4.15/xfce4-settings-4.15.3.tar.bz2
- source = default-xsettings-xml.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/default-xsettings-xml.patch?h=packages/xfce4-settings
- sha256sums = 2933aee1c08188cc2cc313431eeee99fc54392a08e1fa4ca783e46057f87900c
+ source = https://archive.xfce.org/src/xfce/xfce4-settings/4.17/xfce4-settings-4.17.0.tar.bz2
+ source = default-xsettings-xml.patch::https://raw.githubusercontent.com/archlinux/svntogit-packages/packages/xfce4-settings/trunk/default-xsettings-xml.patch
+ sha256sums = 2838054e7d4d77275577051aa0e183963344d9affba087b65478211ba893cfa4
sha256sums = 8e9a6c70ab0ceb5d91b637dc290768f8a47edb5d7b6e2eebc4459dbc4ee040d7
pkgname = xfce4-settings-devel
-
diff --git a/PKGBUILD b/PKGBUILD
index 816dc84588ce..5480887090d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,33 @@
_pkgname=xfce4-settings
pkgname=${_pkgname}-devel
-pkgver=4.15.3
+pkgver=4.17.0
pkgrel=1
pkgdesc="Settings manager for xfce"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://www.xfce.org/"
license=('GPL2')
groups=('xfce4-devel')
-depends=('exo' 'libxfce4util>=4.15.2' 'garcon' 'libxfce4ui>=4.15.1' 'xfconf' 'libnotify' 'colord'
+depends=('exo' 'libxfce4util>=4.17.2' 'garcon' 'libxfce4ui>=4.17.0' 'xfconf' 'libnotify' 'colord'
'libxklavier' 'adwaita-icon-theme' 'gnome-themes-extra' 'python')
makedepends=('intltool')
optdepends=('libcanberra: for sound control')
provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
-source=("https://archive.xfce.org/src/xfce/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.bz2"
- 'default-xsettings-xml.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/default-xsettings-xml.patch?h=packages/xfce4-settings')
-sha256sums=('2933aee1c08188cc2cc313431eeee99fc54392a08e1fa4ca783e46057f87900c'
+source=("https://archive.xfce.org/src/xfce/${_pkgname}/${pkgver%.*}/${_pkgname}-${pkgver}.tar.bz2"
+ 'default-xsettings-xml.patch::https://raw.githubusercontent.com/archlinux/svntogit-packages/packages/xfce4-settings/trunk/default-xsettings-xml.patch')
+sha256sums=('2838054e7d4d77275577051aa0e183963344d9affba087b65478211ba893cfa4'
'8e9a6c70ab0ceb5d91b637dc290768f8a47edb5d7b6e2eebc4459dbc4ee040d7')
prepare() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "${_pkgname}-${pkgver}"
# Enable Adwaita theme and font hinting by default
- patch -Np1 -i "$srcdir/default-xsettings-xml.patch"
+ patch -Np1 -i ../default-xsettings-xml.patch
}
build() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "${_pkgname}-${pkgver}"
./configure \
--prefix=/usr \
@@ -46,6 +46,6 @@ build() {
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
+ cd "${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}