summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkunnyk2016-05-02 18:21:38 +0200
committerSkunnyk2016-05-02 18:21:38 +0200
commitbe3831d77fca6a2d05ed1f0e40e15035c39132e3 (patch)
tree8bc93c270241de12e8392341071a9445ba764a77
downloadaur-xfce4-smartbookmark-plugin-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
-rw-r--r--xfce4-smartbookmark-plugin.install12
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48ba0f90584b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = xfce4-smartbookmark-plugin-git
+ pkgdesc = Plugin for the Xfce4 panel that lets you quicksearch from selected websites
+ pkgver = 0.4.6.r22.g6be4a75
+ pkgrel = 1
+ url = http://goodies.xfce.org/projects/panel-plugins/xfce4-smartbookmark-plugin
+ install = xfce4-smartbookmark-plugin.install
+ arch = i686
+ arch = x86_64
+ groups = xfce4-goodies
+ license = GPL
+ makedepends = xfce4-dev-tools
+ makedepends = intltool
+ makedepends = git
+ depends = xfce4-panel
+ provides = xfce4-smartbookmark-plugin
+ conflicts = xfce4-smartbookmark-plugin
+ options = !libtool
+ source = git://git.xfce.org/panel-plugins/xfce4-smartbookmark-plugin
+ sha256sums = SKIP
+
+pkgname = xfce4-smartbookmark-plugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e82ade8886d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+pkgname=xfce4-smartbookmark-plugin-git
+_pkgname=${pkgname%-git}
+pkgver=0.4.6.r22.g6be4a75
+pkgrel=1
+pkgdesc='Plugin for the Xfce4 panel that lets you quicksearch from selected websites'
+arch=('i686' 'x86_64')
+license=('GPL')
+url='http://goodies.xfce.org/projects/panel-plugins/xfce4-smartbookmark-plugin'
+groups=('xfce4-goodies')
+depends=('xfce4-panel')
+conflicts=('xfce4-smartbookmark-plugin')
+provides=('xfce4-smartbookmark-plugin')
+makedepends=('xfce4-dev-tools' 'intltool' 'git')
+options=('!libtool')
+install=xfce4-smartbookmark-plugin.install
+source=('git://git.xfce.org/panel-plugins/xfce4-smartbookmark-plugin')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ }
+
+build() {
+ cd "$_pkgname"/
+
+ ./autogen.sh --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-maintainer-mode \
+ --disable-debug
+ make
+}
+
+package() {
+ cd "$_pkgname"
+
+ make DESTDIR="${pkgdir}" install
+}
+
diff --git a/xfce4-smartbookmark-plugin.install b/xfce4-smartbookmark-plugin.install
new file mode 100644
index 000000000000..6204edafc8f6
--- /dev/null
+++ b/xfce4-smartbookmark-plugin.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+