summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkunnyk2016-05-02 18:22:45 +0200
committerSkunnyk2016-05-02 18:22:45 +0200
commit3d7c2ca9e4ad5e8cb1878bdd6a83a1eda4ce8267 (patch)
tree51e2e6ba996c4cae727c868661e2fde52b0d1a59
downloadaur-xfce4-systemload-plugin-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD42
-rw-r--r--xfce4-systemload-plugin.install12
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52eeeb4360c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = xfce4-systemload-plugin-git
+ pkgdesc = A system load plugin for the Xfce4 panel
+ pkgver = 1.1.2.r66.gf0d2499
+ pkgrel = 1
+ url = http://goodies.xfce.org/projects/panel-plugins/xfce4-systemload-plugin
+ install = xfce4-systemload-plugin.install
+ arch = i686
+ arch = x86_64
+ groups = xfce4-goodies
+ license = GPL
+ makedepends = xfce4-dev-tools
+ makedepends = intltool
+ makedepends = git
+ depends = xfce4-panel
+ depends = upower
+ provides = xfce4-systemload-plugin
+ conflicts = xfce4-systemload-plugin
+ options = !libtool
+ source = git://git.xfce.org/panel-plugins/xfce4-systemload-plugin
+ sha256sums = SKIP
+
+pkgname = xfce4-systemload-plugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..339ccef57f6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+pkgname=xfce4-systemload-plugin-git
+_pkgname=${pkgname%-git}
+pkgver=1.1.2.r66.gf0d2499
+pkgrel=1
+pkgdesc='A system load plugin for the Xfce4 panel'
+arch=('i686' 'x86_64')
+license=('GPL')
+url='http://goodies.xfce.org/projects/panel-plugins/xfce4-systemload-plugin'
+groups=('xfce4-goodies')
+depends=('xfce4-panel' 'upower')
+conflicts=('xfce4-systemload-plugin')
+provides=('xfce4-systemload-plugin')
+makedepends=('xfce4-dev-tools' 'intltool' 'git')
+options=('!libtool')
+install=xfce4-systemload-plugin.install
+source=('git://git.xfce.org/panel-plugins/xfce4-systemload-plugin')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ }
+
+build() {
+ cd "$_pkgname"/
+
+ ./autogen.sh --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-maintainer-mode \
+ --disable-debug
+ make
+}
+
+package() {
+ cd "$_pkgname"
+
+ make DESTDIR="${pkgdir}" install
+}
+
diff --git a/xfce4-systemload-plugin.install b/xfce4-systemload-plugin.install
new file mode 100644
index 000000000000..6204edafc8f6
--- /dev/null
+++ b/xfce4-systemload-plugin.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+