summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2021-09-02 10:31:07 -0400
committerTed Alff2021-09-02 10:31:07 -0400
commit67b983d48096ada6e1b2e3ba43e17f73f3c5e21f (patch)
tree6bea01d2c261b0e03aa40106fd706c55d7e5f459
parente281de7e157376fee0731b36473b9c284e3f4d89 (diff)
downloadaur-67b983d48096ada6e1b2e3ba43e17f73f3c5e21f.tar.gz
Switch source/url to XFCE gitlab. Use current commit as they haven't released a new version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 24 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e806b2457b3b..2cbb88654a8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = xfce4-windowck-plugin
- pkgdesc = Xfce panel plugin which allows to put the maximized window title and buttons on the panel.
- pkgver = 0.4.10
+ pkgdesc = Xfce panel plugin for displaying window title and buttons
+ pkgver = 0.4.5+38+g16d4a27
pkgrel = 1
- url = https://github.com/invidian/xfce4-windowck-plugin
+ epoch = 1
+ url = https://gitlab.xfce.org/panel-plugins/xfce4-windowck-plugin/
arch = i686
arch = x86_64
arch = armv7h
@@ -12,11 +13,11 @@ pkgbase = xfce4-windowck-plugin
makedepends = xfce4-dev-tools
makedepends = python
makedepends = imagemagick
- depends = xfce4-panel>=4.16.0
+ makedepends = git
+ depends = xfce4-panel>=4.14.0
depends = libwnck3
options = !libtool
- source = xfce4-windowck-plugin-0.4.10.tar.gz::https://github.com/invidian/xfce4-windowck-plugin/archive/v0.4.10.tar.gz
- sha256sums = ff12ae63b26f5d62c839e9c15b329de2b1f372f105fbc063281a98a62097cac3
+ source = xfce4-windowck-plugin::git+https://gitlab.xfce.org/panel-plugins/xfce4-windowck-plugin/#commit=16d4a27a9e740058ddd6e7dc72e49b1e81504aa4
+ sha256sums = SKIP
pkgname = xfce4-windowck-plugin
-
diff --git a/PKGBUILD b/PKGBUILD
index b8e307a2a3fe..d6ec3f5b29b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,32 @@
# Contributor: Cedric Leporcq <cedric at gmail dot com>
pkgname=xfce4-windowck-plugin
-pkgver=0.4.10
+epoch=1
+pkgver=0.4.5+38+g16d4a27
pkgrel=1
-pkgdesc="Xfce panel plugin which allows to put the maximized window title and buttons on the panel."
+pkgdesc="Xfce panel plugin for displaying window title and buttons"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
-url="https://github.com/invidian/xfce4-windowck-plugin"
+url="https://gitlab.xfce.org/panel-plugins/xfce4-windowck-plugin/"
license=('GPL3')
-depends=('xfce4-panel>=4.16.0' 'libwnck3')
-makedepends=('intltool' 'xfce4-dev-tools' 'python' 'imagemagick')
+depends=('xfce4-panel>=4.14.0' 'libwnck3')
+makedepends=('intltool' 'xfce4-dev-tools' 'python' 'imagemagick' 'git')
options=('!libtool')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/invidian/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('ff12ae63b26f5d62c839e9c15b329de2b1f372f105fbc063281a98a62097cac3')
+_commit='16d4a27a9e740058ddd6e7dc72e49b1e81504aa4'
+source=("${pkgname}::git+${url}#commit=${_commit}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --long --tags | sed -r "s:^${_pkgname}-::;s:^v::;s/-/+/g"
+}
build() {
- cd "$srcdir/${pkgname}-$pkgver"
+ cd "$srcdir/${pkgname}"
./autogen.sh --prefix=/usr
make
}
package() {
- cd "$srcdir/${pkgname}-$pkgver"
+ cd "$srcdir/${pkgname}"
make DESTDIR="$pkgdir" install
}