summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkillermoehre2018-07-22 16:23:11 +0200
committerkillermoehre2018-07-22 16:23:11 +0200
commitf1647247da35069c71040a20c0276270425b1358 (patch)
tree69eb019a5e2e8bf747f3164d27f1d518cbaecfbb
downloadaur-f1647247da35069c71040a20c0276270425b1358.tar.gz
initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD43
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb2fabd0ee9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Sun Jul 22 14:22:42 UTC 2018
+pkgbase = xfconf-git
+ pkgdesc = A simple client-server configuration storage and query system - git checkout
+ pkgver = 4.13.5.r2.gc44883d
+ pkgrel = 1
+ url = http://www.xfce.org/
+ arch = i686
+ arch = x86_64
+ groups = xfce4
+ license = GPL2
+ makedepends = intltool
+ makedepends = git
+ makedepends = xfce4-dev-tools
+ depends = libxfce4util
+ depends = dbus-glib
+ provides = xfconf
+ conflicts = xfconf
+ conflicts = terminal
+ replaces = xfconf
+ replaces = terminal
+ source = git://git.xfce.org/xfce/xfconf
+ sha256sums = SKIP
+
+pkgname = xfconf-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0f455604e75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Silvio Knizek <killermoehre@gmx.net>
+_pkgname=xfconf
+pkgname="${_pkgname}-git"
+pkgver=4.13.5.r2.gc44883d
+pkgrel=1
+pkgdesc="A simple client-server configuration storage and query system - git checkout"
+arch=('i686' 'x86_64')
+url="http://www.xfce.org/"
+license=('GPL2')
+groups=('xfce4')
+depends=('libxfce4util' 'dbus-glib')
+makedepends=('intltool' 'git' 'xfce4-dev-tools')
+provides=("$_pkgname")
+conflicts=("$_pkgname" 'terminal')
+replaces=("$_pkgname" 'terminal')
+source=("git://git.xfce.org/xfce/$_pkgname")
+sha256sums=('SKIP')
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed -r "s/^${_pkgname}-//;s/([^-]*-g)/r\1/;s/-/./g"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ ./autogen.sh \
+ --disable-dependency-tracking \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/xfce4 \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-gtk-doc \
+ --enable-checks \
+ --with-perl-options=INSTALLDIRS="vendor"
+ make
+}
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir" install
+
+ # Fix insecure rpath, http://bugs.archlinux.org/task/19980
+ find "$pkgdir" -name Xfconf.so -exec chrpath -d {} +
+}