summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2017-03-30 21:00:03 -0600
committerBrian Bidulock2017-03-30 21:00:03 -0600
commit42f4c4b238d979536f5fde57557a5dc2a2b092b5 (patch)
treeef65b560179740262f688ee1f48c858c4323f068
parent11a50d501f2f2c52c80a4c110f27babd70d757a8 (diff)
downloadaur-42f4c4b238d979536f5fde57557a5dc2a2b092b5.tar.gz
version 1.42-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--arch-yaourt.patch72
3 files changed, 46 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46d72b1e0469..ab77ecf42868 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Dec 15 23:58:14 UTC 2015
pkgbase = xfe-arch
pkgdesc = An MS-Explorer like file manager for X with Archlinux xfp support.
- pkgver = 1.41
+ pkgver = 1.42
pkgrel = 1
url = http://roland65.free.fr/xfe
install = xfe.install
@@ -13,12 +11,12 @@ pkgbase = xfe-arch
depends = fox
depends = desktop-file-utils
optdepends = yaourt: xfp archlinux support
- provides = xfe=1.41
+ provides = xfe=1.42
conflicts = xfe
- source = http://downloads.sourceforge.net/sourceforge/xfe/xfe-1.41.tar.gz
+ source = http://downloads.sourceforge.net/sourceforge/xfe/xfe-1.42.tar.gz
source = arch-yaourt.patch
- md5sums = cd4978240decbf0449f07c5061b9c4b8
- md5sums = 6f1401fe5a2fb101ff3d5cbf3bca28d7
+ md5sums = 34326f185070db02e7419f85f7967cdf
+ md5sums = 680403ddc2a748b2fb304080b945ac45
pkgname = xfe-arch
diff --git a/PKGBUILD b/PKGBUILD
index 2c1c8d6034d6..406f0a38fae1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=xfe-arch
_pkgname=xfe
-pkgver=1.41
+pkgver=1.42
pkgrel=1
pkgdesc="An MS-Explorer like file manager for X with Archlinux xfp support."
arch=('i686' 'x86_64')
@@ -19,12 +19,12 @@ optdepends=('yaourt: xfp archlinux support')
install="$_pkgname.install"
source=("http://downloads.sourceforge.net/sourceforge/$_pkgname/$_pkgname-$pkgver.tar.gz"
"arch-yaourt.patch")
-md5sums=('cd4978240decbf0449f07c5061b9c4b8'
- '6f1401fe5a2fb101ff3d5cbf3bca28d7')
+md5sums=('34326f185070db02e7419f85f7967cdf'
+ '680403ddc2a748b2fb304080b945ac45')
prepare() {
cd "$srcdir/$_pkgname-$pkgver"
- patch -Np1 -b -z .orig <../arch-yaourt.patch
+ patch -Np2 -b -z .orig <../arch-yaourt.patch
aclocal
automake --add-missing
autoreconf
@@ -33,7 +33,7 @@ prepare() {
build() {
cd "$srcdir/$_pkgname-$pkgver"
./configure --prefix=/usr
- make
+ make V=0
}
package() {
diff --git a/arch-yaourt.patch b/arch-yaourt.patch
index 8dcda9b2ef20..40f6b3929924 100644
--- a/arch-yaourt.patch
+++ b/arch-yaourt.patch
@@ -1,7 +1,7 @@
-diff -up xfe-1.41/src/FilePanel.cpp.orig xfe-1.41/src/FilePanel.cpp
---- xfe-1.41/src/FilePanel.cpp.orig 2015-12-15 15:12:44.000000000 -0700
-+++ xfe-1.41/src/FilePanel.cpp 2015-12-15 16:45:39.000000000 -0700
-@@ -4472,27 +4472,32 @@ long FilePanel::onCmdPopupMenu(FXObject*
+diff -up src/xfe-1.42/src/FilePanel.cpp.orig src/xfe-1.42/src/FilePanel.cpp
+--- src/xfe-1.42/src/FilePanel.cpp.orig 2016-07-27 03:48:17.000000000 -0600
++++ src/xfe-1.42/src/FilePanel.cpp 2017-03-30 19:47:29.000000000 -0600
+@@ -4474,27 +4474,32 @@ long FilePanel::onCmdPopupMenu(FXObject*
// Last and before last file extensions
FXString ext1 = name.rafter('.', 1).lower();
FXString ext2 = name.rafter('.', 2).lower();
@@ -37,7 +37,7 @@ diff -up xfe-1.41/src/FilePanel.cpp.orig xfe-1.41/src/FilePanel.cpp
{
ar = true;
new FXMenuCommand(menu, _("&Extract here"), archexticon, current, FilePanel::ID_EXTRACT_HERE);
-@@ -4505,7 +4510,7 @@ long FilePanel::onCmdPopupMenu(FXObject*
+@@ -4507,7 +4512,7 @@ long FilePanel::onCmdPopupMenu(FXObject*
new FXMenuCommand(menu, _("E&xtract to..."), archexticon, current, FilePanel::ID_EXTRACT);
}
#if defined(linux)
@@ -46,7 +46,7 @@ diff -up xfe-1.41/src/FilePanel.cpp.orig xfe-1.41/src/FilePanel.cpp
{
ar = true;
new FXMenuCommand(menu, _("&View"), packageicon, current, FilePanel::ID_VIEW);
-@@ -5357,6 +5362,7 @@ long FilePanel::onCmdPkgInstall(FXObject
+@@ -5359,6 +5364,7 @@ long FilePanel::onCmdPkgInstall(FXObject
// Command to perform
FXString ext = FXPath::extension(name);
@@ -54,7 +54,7 @@ diff -up xfe-1.41/src/FilePanel.cpp.orig xfe-1.41/src/FilePanel.cpp
if (comparecase(ext, "rpm") == 0)
{
cmd = "rpm -Uvh " + path;
-@@ -5365,6 +5371,10 @@ long FilePanel::onCmdPkgInstall(FXObject
+@@ -5367,6 +5373,10 @@ long FilePanel::onCmdPkgInstall(FXObject
{
cmd = "dpkg -i "+ path;
}
@@ -65,7 +65,7 @@ diff -up xfe-1.41/src/FilePanel.cpp.orig xfe-1.41/src/FilePanel.cpp
// Wait cursor
getApp()->beginWaitCursor();
-@@ -5404,6 +5414,7 @@ long FilePanel::onCmdPkgUninstall(FXObje
+@@ -5406,6 +5416,7 @@ long FilePanel::onCmdPkgUninstall(FXObje
// Command to perform
FXString ext = FXPath::extension(name);
@@ -73,7 +73,7 @@ diff -up xfe-1.41/src/FilePanel.cpp.orig xfe-1.41/src/FilePanel.cpp
if (comparecase(ext, "rpm") == 0)
{
name = name.section('-', 0);
-@@ -5414,6 +5425,11 @@ long FilePanel::onCmdPkgUninstall(FXObje
+@@ -5416,6 +5427,11 @@ long FilePanel::onCmdPkgUninstall(FXObje
name = name.section('_', 0);
cmd = "dpkg -r "+ name;
}
@@ -85,7 +85,7 @@ diff -up xfe-1.41/src/FilePanel.cpp.orig xfe-1.41/src/FilePanel.cpp
// Wait cursor
getApp()->beginWaitCursor();
-@@ -5900,9 +5916,13 @@ long FilePanel::onCmdPkgQuery(FXObject*
+@@ -5902,9 +5918,13 @@ long FilePanel::onCmdPkgQuery(FXObject*
{
cmd = "rpm -qf " + ::quote(file);
}
@@ -100,7 +100,7 @@ diff -up xfe-1.41/src/FilePanel.cpp.orig xfe-1.41/src/FilePanel.cpp
return(0);
}
-@@ -5956,6 +5976,13 @@ long FilePanel::onCmdPkgQuery(FXObject*
+@@ -5958,6 +5978,13 @@ long FilePanel::onCmdPkgQuery(FXObject*
{
if (str.find(' ') != -1) // Space character exists in the string
{
@@ -114,9 +114,9 @@ diff -up xfe-1.41/src/FilePanel.cpp.orig xfe-1.41/src/FilePanel.cpp
str = "";
}
}
-diff -up xfe-1.41/src/help.h.orig xfe-1.41/src/help.h
---- xfe-1.41/src/help.h.orig 2015-12-15 15:12:53.000000000 -0700
-+++ xfe-1.41/src/help.h 2015-12-15 15:30:47.000000000 -0700
+diff -up src/xfe-1.42/src/help.h.orig src/xfe-1.42/src/help.h
+--- src/xfe-1.42/src/help.h.orig 2015-11-28 04:41:59.000000000 -0700
++++ src/xfe-1.42/src/help.h 2017-03-30 19:47:29.000000000 -0600
@@ -49,7 +49,7 @@
- Panels synchronization and switching\n \
- Integrated text editor and viewer (X File Write, Xfw)\n \
@@ -126,9 +126,9 @@ diff -up xfe-1.41/src/help.h.orig xfe-1.41/src/help.h
- Custom shell scripts (like Nautilus scripts)\n \
- Search files and directories\n \
- Natural sort order (foo10.txt comes after foo2.txt...)\n \
-diff -up xfe-1.41/src/main.cpp.orig xfe-1.41/src/main.cpp
---- xfe-1.41/src/main.cpp.orig 2015-12-15 15:12:59.000000000 -0700
-+++ xfe-1.41/src/main.cpp 2015-12-15 16:35:25.000000000 -0700
+diff -up src/xfe-1.42/src/main.cpp.orig src/xfe-1.42/src/main.cpp
+--- src/xfe-1.42/src/main.cpp.orig 2015-12-15 06:55:15.000000000 -0700
++++ src/xfe-1.42/src/main.cpp 2017-03-30 19:47:29.000000000 -0600
@@ -333,6 +333,7 @@ int main(int argc, char* argv[])
// For package query on Linux systems, try to guess if the default package format is deb or rpm:
// - if dpkg exists then the system uses deb packages
@@ -156,9 +156,9 @@ diff -up xfe-1.41/src/main.cpp.orig xfe-1.41/src/main.cpp
}
}
#endif
-diff -up xfe-1.41/src/Properties.cpp.orig xfe-1.41/src/Properties.cpp
---- xfe-1.41/src/Properties.cpp.orig 2015-12-15 15:13:09.000000000 -0700
-+++ xfe-1.41/src/Properties.cpp 2015-12-15 16:40:19.000000000 -0700
+diff -up src/xfe-1.42/src/Properties.cpp.orig src/xfe-1.42/src/Properties.cpp
+--- src/xfe-1.42/src/Properties.cpp.orig 2015-12-16 03:17:47.000000000 -0700
++++ src/xfe-1.42/src/Properties.cpp 2017-03-30 19:47:29.000000000 -0600
@@ -169,7 +169,7 @@ PropertiesBox::PropertiesBox(FXWindow* w
FXString grpid, usrid;
FXLabel* sizelabel = NULL;
@@ -189,10 +189,10 @@ diff -up xfe-1.41/src/Properties.cpp.orig xfe-1.41/src/Properties.cpp
{
editlbl = _("Install/Upgrade:");
}
-diff -up xfe-1.41/src/SearchPanel.cpp.orig xfe-1.41/src/SearchPanel.cpp
---- xfe-1.41/src/SearchPanel.cpp.orig 2015-12-15 15:13:19.000000000 -0700
-+++ xfe-1.41/src/SearchPanel.cpp 2015-12-15 16:49:20.000000000 -0700
-@@ -2262,14 +2262,15 @@ long SearchPanel::onCmdPopupMenu(FXObjec
+diff -up src/xfe-1.42/src/SearchPanel.cpp.orig src/xfe-1.42/src/SearchPanel.cpp
+--- src/xfe-1.42/src/SearchPanel.cpp.orig 2016-07-27 03:46:58.000000000 -0600
++++ src/xfe-1.42/src/SearchPanel.cpp 2017-03-30 19:47:29.000000000 -0600
+@@ -2263,14 +2263,15 @@ long SearchPanel::onCmdPopupMenu(FXObjec
// Last and before last file extensions
FXString ext1 = name.rafter('.', 1).lower();
FXString ext2 = name.rafter('.', 2).lower();
@@ -210,7 +210,7 @@ diff -up xfe-1.41/src/SearchPanel.cpp.orig xfe-1.41/src/SearchPanel.cpp
{
ar = true;
new FXMenuCommand(menu, _("&Extract here"), archexticon, this, SearchPanel::ID_EXTRACT);
-@@ -2280,7 +2281,7 @@ long SearchPanel::onCmdPopupMenu(FXObjec
+@@ -2281,7 +2282,7 @@ long SearchPanel::onCmdPopupMenu(FXObjec
new FXMenuCommand(menu, _("E&xtract to..."), archexticon, this, SearchPanel::ID_EXTRACT);
}
#if defined(linux)
@@ -219,7 +219,7 @@ diff -up xfe-1.41/src/SearchPanel.cpp.orig xfe-1.41/src/SearchPanel.cpp
{
ar = true;
new FXMenuCommand(menu, _("&View"), packageicon, this, SearchPanel::ID_VIEW);
-@@ -4318,9 +4319,13 @@ long SearchPanel::onCmdPkgQuery(FXObject
+@@ -4319,9 +4320,13 @@ long SearchPanel::onCmdPkgQuery(FXObject
{
cmd = "rpm -qf " + ::quote(file);
}
@@ -234,7 +234,7 @@ diff -up xfe-1.41/src/SearchPanel.cpp.orig xfe-1.41/src/SearchPanel.cpp
return(0);
}
-@@ -4377,6 +4382,13 @@ long SearchPanel::onCmdPkgQuery(FXObject
+@@ -4378,6 +4383,13 @@ long SearchPanel::onCmdPkgQuery(FXObject
str = "";
}
}
@@ -248,16 +248,16 @@ diff -up xfe-1.41/src/SearchPanel.cpp.orig xfe-1.41/src/SearchPanel.cpp
// Display the related output message
FXString message;
-@@ -4425,5 +4437,4 @@ long SearchPanel::onUpdPkgQuery(FXObject
+@@ -4426,5 +4438,4 @@ long SearchPanel::onUpdPkgQuery(FXObject
return(1);
}
-
#endif
-diff -up xfe-1.41/src/xfedefs.h.orig xfe-1.41/src/xfedefs.h
---- xfe-1.41/src/xfedefs.h.orig 2015-12-15 15:13:47.000000000 -0700
-+++ xfe-1.41/src/xfedefs.h 2015-12-15 16:11:22.000000000 -0700
-@@ -274,6 +274,7 @@
+diff -up src/xfe-1.42/src/xfedefs.h.orig src/xfe-1.42/src/xfedefs.h
+--- src/xfe-1.42/src/xfedefs.h.orig 2016-07-27 05:27:41.000000000 -0600
++++ src/xfe-1.42/src/xfedefs.h 2017-03-30 19:47:29.000000000 -0600
+@@ -294,6 +294,7 @@
// Package format
#define DEB_PKG 0
#define RPM_PKG 1
@@ -266,9 +266,9 @@ diff -up xfe-1.41/src/xfedefs.h.orig xfe-1.41/src/xfedefs.h
+#define OTHER_PKG 3
#endif
-diff -up xfe-1.41/src/XFilePackage.cpp.orig xfe-1.41/src/XFilePackage.cpp
---- xfe-1.41/src/XFilePackage.cpp.orig 2015-12-15 15:13:58.000000000 -0700
-+++ xfe-1.41/src/XFilePackage.cpp 2015-12-15 16:53:13.000000000 -0700
+diff -up src/xfe-1.42/src/XFilePackage.cpp.orig src/xfe-1.42/src/XFilePackage.cpp
+--- src/xfe-1.42/src/XFilePackage.cpp.orig 2015-12-15 06:53:31.000000000 -0700
++++ src/xfe-1.42/src/XFilePackage.cpp 2017-03-30 20:51:59.000000000 -0600
@@ -32,6 +32,7 @@
char** args;
FXbool dpkg = false;
@@ -411,6 +411,6 @@ diff -up xfe-1.41/src/XFilePackage.cpp.orig xfe-1.41/src/XFilePackage.cpp
{
- MessageBox::error(window, BOX_OK, _("Error"), _("No compatible package manager (rpm or dpkg) found!"));
+ MessageBox::error(window, BOX_OK, _("Error"), _("No compatible package manager (rpm, dpkg or yaourt) found!"));
- exit(EXIT_SUCCESS);
+ exit(EXIT_FAILURE);
}