summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXandrCopyrighted2024-01-28 01:52:31 -0500
committerXandrCopyrighted2024-01-28 01:52:31 -0500
commit5448e5042ec5a9389659de970f79f999a4a2c3aa (patch)
treec53c7e04ca8ff9f9513e42df96a271e332899027
downloadaur-5448e5042ec5a9389659de970f79f999a4a2c3aa.tar.gz
Hello, World
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..507a9b3c4189
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xfetch-bin
+ pkgdesc = The world's simplest fetch written in Rust.
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/XandrCopyrighted/xFetch/
+ arch = any
+ license = MIT
+ provides = xfetch
+ conflicts = xfetch-rs-git
+ conflicts = xfetch
+ source = https://github.com/XandrCopyrighted/xFetch/releases/download/2.0.0/xfetch.tar.gz
+ source = https://github.com/XandrCopyrighted/xFetch/blob/main/LICENSE
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = xfetch-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7504f0e45dc3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: XandrCopyrighted <xxandrr@proton.me>
+
+pkgname="xfetch-bin"
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="The world's simplest fetch written in Rust."
+arch=('any')
+url="https://github.com/XandrCopyrighted/xFetch/"
+license=('MIT')
+
+source=(
+ "https://github.com/XandrCopyrighted/xFetch/releases/download/2.0.0/xfetch.tar.gz"
+ "https://github.com/XandrCopyrighted/xFetch/blob/main/LICENSE"
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+)
+
+depends=()
+makedepends=()
+provides=("xfetch")
+conflicts=('xfetch-rs-git' 'xfetch')
+
+package() {
+ cd "$srcdir/"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/xfetch/LICENSE"
+ install -Dm755 xfetch "${pkgdir}/usr/bin/xfetch"
+}