summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordeusstultus2016-04-05 11:34:07 -0500
committerdeusstultus2016-04-05 11:34:07 -0500
commit691f41a9a473688b506a09d662cf6cb438757d10 (patch)
tree643350244a1918f54511bc71539960f90c486577
parent8ecf526a1fcd24872565973c6e83c2d9a649857b (diff)
downloadaur-691f41a9a473688b506a09d662cf6cb438757d10.tar.gz
pkgrel to 5. Reworked license verification
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--f.lux-eula.txt7
3 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38e019e7f55d..f8692d05b3cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xflux
pkgdesc = (f.lux for X) Changes monitor color temperature adaptively to ease eye strain (command-line version)
pkgver = 20130901
- pkgrel = 4
+ pkgrel = 5
url = https://justgetflux.com/
arch = i686
arch = x86_64
@@ -11,8 +11,8 @@ pkgbase = xflux
depends = gcc-libs
source = f.lux-eula.txt
source = f.lux-eula.html::https://justgetflux.com/news/pages/eula/index.html
- sha256sums = 1d989851f6f02a2eb280faec1e3bbb348ba9a5d1677da22fa89dfc02cb063030
- sha256sums = cc092411b8edbd2158436ffad45bafc03d9ff1eb1b2be31659bf7308c2c33b26
+ sha256sums = 05b1edc619263941960f37ebce2cf63baabdd5959a287b52b6829b7195d20653
+ sha256sums = SKIP
source_i686 = https://justgetflux.com/linux/xflux-pre.tgz
sha256sums_i686 = fda5d10c3ca16ba38eddc5fbdecebeccd607c4c95787b4379d1ab372760877b4
source_x86_64 = https://justgetflux.com/linux/xflux64.tgz
diff --git a/PKGBUILD b/PKGBUILD
index 25ac4f528fe9..aa886760dba6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=xflux
pkgver=20130901
-pkgrel=4
+pkgrel=5
pkgdesc="(f.lux for X) Changes monitor color temperature adaptively to ease eye strain (command-line version)"
arch=('i686' 'x86_64')
url="https://justgetflux.com/"
@@ -16,14 +16,22 @@ depends_x86_64=('gcc-libs')
source=('f.lux-eula.txt' 'f.lux-eula.html::https://justgetflux.com/news/pages/eula/index.html')
source_i686=('https://justgetflux.com/linux/xflux-pre.tgz')
source_x86_64=('https://justgetflux.com/linux/xflux64.tgz')
-sha256sums=('1d989851f6f02a2eb280faec1e3bbb348ba9a5d1677da22fa89dfc02cb063030'
- 'cc092411b8edbd2158436ffad45bafc03d9ff1eb1b2be31659bf7308c2c33b26')
+sha256sums=('05b1edc619263941960f37ebce2cf63baabdd5959a287b52b6829b7195d20653'
+ 'SKIP') #Verified through prepare() rather than sums as websites change
sha256sums_i686=('fda5d10c3ca16ba38eddc5fbdecebeccd607c4c95787b4379d1ab372760877b4')
sha256sums_x86_64=('cc50158fabaeee58c331f006cc1c08fd2940a126e99d37b76c8e878ef20c2021')
#EULA compliance
prepare() {
- #cat $srcdir/f.lux-eula.txt
+ #build and compare license from fetched html
+ echo f.lux End User License Agreement > license_verify
+
+ awk < f.lux-eula.html '/div id="post"/,/<\/div>/' | sed -e 's/<[^>]*>//g' -e 's/^ *//' >> license_verify
+ if [ "$(md5sum license_verify|cut -c1-32)" != "$(md5sum f.lux-eula.txt|cut -c1-32)" ]
+ then
+ echo "Downloaded license does not match that cached in package, aborting."
+ return 1
+ fi
echo 'Download of this software requires agreement with EULA at https://justgetflux.com/news/pages/eula/index.html'
}
diff --git a/f.lux-eula.txt b/f.lux-eula.txt
index a44f87d611f1..f39ceae62373 100644
--- a/f.lux-eula.txt
+++ b/f.lux-eula.txt
@@ -10,11 +10,12 @@ SUPPORT AND UPGRADES. This Agreement does not entitle you to any support, upgrad
INDEMNITY. You shall indemnify and hold harmless Company from any claims, damages, liabilities, costs and fees (including reasonable attorney fees) arising from your use of the Software as well as from your failure to comply with any term of this Agreement.
-WARRANTY DISCLAIMER. YOU AGREE THAT YOU ARE USING THE SOFTWARE SOLELY AT YOUR OWN RISK. COMPANY PROVIDES THE SOFTWARE “AS IS” AND WITHOUT WARRANTY OF ANY KIND, AND COMPANY FOR ITSELF AND ITS PUBLISHERS AND LICENSORS HEREBY DISCLAIMS ALL EXPRESS OR IMPLIED WARRANTIES, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, PERFORMANCE, ACCURACY, RELIABILITY, AND NON-INFRINGEMENT. YOU ACKNOWLEDGE THAT COMPANY EXPRESSLY DISCLAIMS USE OF THE SOFTWARE FOR ANY MEDICAL PURPOSE (INCLUDING, WITHOUT LIMITATION, THE DIAGNOSIS, EXAMINATION, OR TREATMENT OF ANY MEDICAL CONDITIONS). COMPANY DISCLAIMS ANY REPRESENTATIONS OR WARRANTIES REGARDING THE SOFTWARE MADE BY YOU OR ANY THIRD PARTY AND ANY SUCH REPRESENTATION OR WARRANTY IS NOT MADE ON COMPANY’S BEHALF. Company disclaims any and all liability to you, your employer, or any third party relating to the download, installation, or use of the Software in violation of the foregoing.
+WARRANTY DISCLAIMER. YOU AGREE THAT YOU ARE USING THE SOFTWARE SOLELY AT YOUR OWN RISK. COMPANY PROVIDES THE SOFTWARE “AS IS” AND WITHOUT WARRANTY OF ANY KIND, AND COMPANY FOR ITSELF AND ITS PUBLISHERS AND LICENSORS HEREBY DISCLAIMS ALL EXPRESS OR IMPLIED WARRANTIES, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, PERFORMANCE, ACCURACY, RELIABILITY, AND NON-INFRINGEMENT. YOU ACKNOWLEDGE THAT COMPANY EXPRESSLY DISCLAIMS USE OF THE SOFTWARE FOR ANY MEDICAL PURPOSE (INCLUDING, WITHOUT LIMITATION, THE DIAGNOSIS, EXAMINATION, OR TREATMENT OF ANY MEDICAL CONDITIONS). COMPANY DISCLAIMS ANY REPRESENTATIONS OR WARRANTIES REGARDING THE SOFTWARE MADE BY YOU OR ANY THIRD PARTY AND ANY SUCH REPRESENTATION OR WARRANTY IS NOT MADE ON COMPANY’S BEHALF. Company disclaims any and all liability to you, your employer, or any third party relating to the download, installation, or use of the Software in violation of the foregoing.
LIMITATION OF LIABILITY. COMPANY SHALL NOT BE RESPONSIBLE OR LIABLE WITH RESPECT TO ANY SUBJECT MATTER OF THIS AGREEMENT UNDER ANY CONTRACT, NEGLIGENCE, STRICT LIABILITY OR OTHER THEORY (A) FOR LOSS OR INACCURACY OF DATA OR (EXCEPT FOR RETURN OF AMOUNTS, IF ANY, PAID TO COMPANY BY YOU HEREUNDER) COST OF PROCUREMENT OF SUBSTITUTE GOODS, SERVICES OR TECHNOLOGY, OR (B) FOR ANY INDIRECT, INCIDENTAL OR CONSEQUENTIAL DAMAGES INCLUDING, BUT NOT LIMITED TO LOSS OF REVENUES AND LOSS OF PROFITS. COMPANY SHALL NOT BE RESPONSIBLE FOR ANY MATTER BEYOND ITS REASONABLE CONTROL. THE FOREGOING LIMITATIONS SHALL APPLY EVEN IF COMPANY SHALL HAVE BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THE ABOVE LIMITATION AND EXCLUSION MAY NOT APPLY TO YOU.
-TERMINATION. You may terminate this Agreement and the license granted herein at any time by destroying or removing from all computers, networks, and storage media all copies of the Software. Company may terminate this Agreement and the license granted herein immediately if you breach any provision of this Agreement or at any time for any or no reason. Upon receiving notice of termination from Company you will destroy or remove from all computers, networks, and storage media all copies of the Software. Sections 2 through 8 shall survive termination of this Agreement.
+TERMINATION. You may terminate this Agreement and the license granted herein at any time by destroying or removing from all computers, networks, and storage media all copies of the Software. Company may terminate this Agreement and the license granted herein immediately if you breach any provision of this Agreement or at any time for any or no reason. Upon receiving notice of termination from Company you will destroy or remove from all computers, networks, and storage media all copies of the Software. Sections 2 through 8 shall survive termination of this Agreement.
+
+MISCELLANEOUS. You shall comply with all applicable export laws, restrictions and regulations in connection with your use of the Software, and will not export or re-export the Software in violation thereof. As defined in FAR section 2.101, DFAR section 252.227-7014(a)(1) and DFAR section 252.227-7014(a)(5) or otherwise, all Software and accompanying documentation provided by Company are “commercial items,” “commercial computer software” and/or “commercial computer software documentation.” Consistent with DFAR section 227.7202 and FAR section 12.212, any use, modification, reproduction, release, performance, display, disclosure or distribution thereof by or for the U.S. Government shall be governed solely by these terms and shall be prohibited except to the extent expressly permitted by these terms. This Agreement is personal to you and you shall not assign or transfer the Agreement or the Software to any third party under any circumstances; Company may assign or transfer this Agreement without consent. This Agreement represents the complete agreement concerning this license between the parties and supersedes all prior agreements and representations between them. It may be amended only by a writing executed by both parties. If any provision of this Agreement is held to be unenforceable for any reason, such provision shall be reformed only to the extent necessary to make it enforceable. This Agreement shall be governed by and construed under New York law without regard to any conflicts of law provisions thereof.
-MISCELLANEOUS. You shall comply with all applicable export laws, restrictions and regulations in connection with your use of the Software, and will not export or re-export the Software in violation thereof. As defined in FAR section 2.101, DFAR section 252.227-7014(a)(1) and DFAR section 252.227-7014(a)(5) or otherwise, all Software and accompanying documentation provided by Company are “commercial items,” “commercial computer software” and/or “commercial computer software documentation.” Consistent with DFAR section 227.7202 and FAR section 12.212, any use, modification, reproduction, release, performance, display, disclosure or distribution thereof by or for the U.S. Government shall be governed solely by these terms and shall be prohibited except to the extent expressly permitted by these terms. This Agreement is personal to you and you shall not assign or transfer the Agreement or the Software to any third party under any circumstances; Company may assign or transfer this Agreement without consent. This Agreement represents the complete agreement concerning this license between the parties and supersedes all prior agreements and representations between them. It may be amended only by a writing executed by both parties. If any provision of this Agreement is held to be unenforceable for any reason, such provision shall be reformed only to the extent necessary to make it enforceable. This Agreement shall be governed by and construed under New York law without regard to any conflicts of law provisions thereof.