summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCzipperz2015-07-12 22:52:06 -0700
committerCzipperz2015-07-12 22:52:06 -0700
commit0a236ab4138935a57aedbb1e0e4cc3706c334c0a (patch)
treeae7ee0ee0436980b5edd015f24d9a380a574f2f7
downloadaur-0a236ab4138935a57aedbb1e0e4cc3706c334c0a.tar.gz
Init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD21
-rw-r--r--xfluxd-args.conf8
-rw-r--r--xfluxd-args.install12
-rw-r--r--xfluxd-args.service11
5 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..955270bb76ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by makepkg 4.2.1
+# Wed Apr 1 04:45:16 UTC 2015
+pkgbase = xfluxd-args
+ pkgdesc = Daemon for xflux that allows for any arguments to be passed in
+ pkgver = 1.0
+ pkgrel = 7
+ url = https://justgetflux.com/
+ install = xfluxd-args.install
+ arch = any
+ license = GPL3
+ depends = xflux
+ conflicts = xfluxd
+ source = xfluxd-args.conf
+ source = xfluxd-args.service
+ md5sums = edf22f4e3e1bfba14c12967536a9053d
+ md5sums = c645a1216c2ebc45cedc1e0347b55ce4
+
+pkgname = xfluxd-args
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3baef79af693
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Czipperz <czipperz@gmail.com>
+
+pkgname=xfluxd-args
+pkgver=1.0
+pkgrel=7
+pkgdesc="Daemon for xflux that allows for any arguments to be passed in"
+url=https://justgetflux.com/
+arch=('any')
+license=(GPL3)
+depends=(xflux)
+source=(xfluxd-args.conf xfluxd-args.service)
+install=xfluxd-args.install
+conflicts=('xfluxd' 'auto-xflux')
+md5sums=('edf22f4e3e1bfba14c12967536a9053d'
+ 'c645a1216c2ebc45cedc1e0347b55ce4')
+conflicts=('xfluxd')
+
+package() {
+ install -Dm664 ${srcdir}/xfluxd-args.conf ${pkgdir}/etc/xfluxd-args.conf
+ install -Dm664 ${srcdir}/xfluxd-args.service ${pkgdir}/usr/lib/systemd/user/xfluxd-args.service
+}
diff --git a/xfluxd-args.conf b/xfluxd-args.conf
new file mode 100644
index 000000000000..02d8c50e6b46
--- /dev/null
+++ b/xfluxd-args.conf
@@ -0,0 +1,8 @@
+# Your X screen
+DISPLAY=:0
+
+# Arguments to be passed in.
+# Make sure to include zip code (-z) or latitude and longitude (-l and -g respectively)
+# To adjust temp, use -k
+# Example: "-z 33333 -k 2700"
+ARGS=""
diff --git a/xfluxd-args.install b/xfluxd-args.install
new file mode 100644
index 000000000000..83eb7e03df0f
--- /dev/null
+++ b/xfluxd-args.install
@@ -0,0 +1,12 @@
+post_install() {
+ echo "==> Edit the config file in '/etc/xfluxd-args.conf'"
+ echo "==> Add xfluxd-args to systemctl if you wish (use the --user option to make it only for you)."
+}
+post_upgrade() {
+ echo "==> THE CONFIG FILE IN '/etc/xfluxd-args.conf' HAS BEEN REPLACED"
+ echo "==> Make sure to reload the daemon in systemctl once you have fixed your settings."
+}
+post_remove() {
+ echo "==> Make sure to disable it in systemctl!"
+ echo "==> You may have to remove the config file '/etc/xfluxd-args.conf'"
+}
diff --git a/xfluxd-args.service b/xfluxd-args.service
new file mode 100644
index 000000000000..d13dc31b5c85
--- /dev/null
+++ b/xfluxd-args.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Daemon for xflux that allows for any arguments to be passed in
+
+[Service]
+Type=forking
+EnvironmentFile=/etc/xfluxd-args.conf
+ExecStart=/usr/bin/xflux $ARGS
+Restart=always
+
+[Install]
+WantedBy=default.target