summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Kaylor2015-06-19 02:54:30 -0400
committerDavid Kaylor2015-06-19 02:54:30 -0400
commitdeb70eedb88d19fd3b80d444b9eece5a91deff5a (patch)
tree760fbf8d37993333bf8f4da52142973a1df1cc84
downloadaur-deb70eedb88d19fd3b80d444b9eece5a91deff5a.tar.gz
Initial commit
Changes committed: new file: .SRCINFO new file: PKGBUILD
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17405dcc4930
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = xfsdump
+ pkgdesc = Additional XFS filesystem utilities
+ pkgver = 3.1.4
+ pkgrel = 2
+ url = http://oss.sgi.com/projects/xfs/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = xfsprogs>=3.1.0
+ depends = attr>=2.4.43
+ depends = acl>=2.2.47
+ depends = dmapi>=2.2.10
+ options = !makeflags
+ options = !emptydirs
+ options = !libtool
+ source = ftp://oss.sgi.com/projects/xfs/cmd_tars/xfsdump-3.1.4.tar.gz
+ source = ftp://oss.sgi.com/projects/xfs/cmd_tars/xfsdump-3.1.4.tar.gz.sig
+ sha256sums = 570eafd0721515bdd79cb0e295b701d49cdf81e71a0a0ff0df6d4c5cc1960943
+ sha256sums = SKIP
+
+pkgname = xfsdump
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5381ce46ee5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: judd <jvinet@zeroflux.org>
+# Maintainer: dkaylor <dpkaylor@gmail.com>
+
+pkgname=xfsdump
+pkgver=3.1.4
+pkgrel=2
+pkgdesc="Additional XFS filesystem utilities"
+arch=(i686 x86_64)
+url="http://oss.sgi.com/projects/xfs/"
+license=('LGPL')
+depends=('xfsprogs>=3.1.0' 'attr>=2.4.43' 'acl>=2.2.47' 'dmapi>=2.2.10')
+options=('!makeflags' '!emptydirs' '!libtool')
+source=(ftp://oss.sgi.com/projects/xfs/cmd_tars/$pkgname-$pkgver.tar.gz{,.sig})
+sha256sums=('570eafd0721515bdd79cb0e295b701d49cdf81e71a0a0ff0df6d4c5cc1960943'
+ 'SKIP')
+validpgpkeys=('9893A827C19F7D96164A38FFADE82947F475FA1D') # Dave Chinner <david@fromorbit.com>
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DIST_ROOT="${pkgdir}" install
+
+ # hack to merge binaries from /sbin and /usr/sbin into /usr/bin #
+ mkdir -p $pkgdir/usr/bin
+ mv $pkgdir/{sbin/*,usr/sbin/xfsinvutil} $pkgdir/usr/bin
+ rm -rf $pkgdir/{sbin,usr/sbin}
+
+ chown -R root $pkgdir
+ chgrp -R root $pkgdir
+}