summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyngs2023-02-14 18:19:18 +0100
committerkyngs2023-02-14 18:19:18 +0100
commit355dcb404ea4f6750b35d82ac8d005debe0f2b1d (patch)
treed5b92585250681c1d51def1ccff8ea2be1ad9610
parent30ebc7315474a160f7f275cb4772232627cb519c (diff)
downloadaur-355dcb404ea4f6750b35d82ac8d005debe0f2b1d.tar.gz
Change upstream to the GH repo from sourceforge. (https://github.com/edison-fw/xFSTK)
Make the package build and work.
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 793164332fe1..6b4f5a1c4c05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,31 @@
-# Maintainer: Mihai Bisog <mihai.bisog@gmail.com>
+# Maintainer: kyngs
pkgname=xfstk-dldr
-pkgver=1.8.1
-pkgrel=2
+pkgver=1.8.6
+pkgrel=3
pkgdesc="Update Intel SoC firmware over USB using the DNX protocol"
arch=('i686' 'x86_64')
-url="http://sourceforge.net/projects/xfstk/"
+url="https://github.com/edison-fw/xFSTK"
license=('LGPL')
depends=('qt4' 'libusb-compat' 'boost')
makedepends=('doxygen' 'graphviz' 'cmake')
provides=('xfstk-dldr' 'xfstk-dldr-gui')
conflicts=('xfstk-dldr' 'xfstk-dldr-gui')
-source=("http://sourceforge.net/projects/xfstk/files/$pkgname-linux-source-$pkgver.tar.gz")
-md5sums=("c076b3bbbe9907ef2eb7958e17b152bd")
+source=("git+${url}#tag=v$pkgver")
+sha256sums=('SKIP')
prepare() {
- cd "xfstk-build/linux-source-package"
+ cd "xFSTK"
mkdir -p build
cd build
BUILD_VERSION=$pkgver cmake .. -DCMAKE_INSTALL_PREFIX:PATH=/usr
}
build() {
- cd "xfstk-build/linux-source-package/build"
+ cd "xFSTK/build"
make
}
package() {
- cd "xfstk-build/linux-source-package/build"
+ cd "xFSTK/build"
make DESTDIR="$pkgdir/" install
}