summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlivier Brunel2018-08-21 17:23:45 +0200
committerOlivier Brunel2018-08-26 18:40:05 +0200
commit5a03523a02a1c2f7610688fda800d19884f7111b (patch)
treeda05ed6b045559dd09b364c40bafb63c491b432c
parent69269ef70ad365b39978178046f8406966d8876b (diff)
downloadaur-5a03523a02a1c2f7610688fda800d19884f7111b.tar.gz
xfwm4-better-smartplacement: upgrade to 4.12.5
Signed-off-by: Olivier Brunel <jjk@jjacky.com>
-rw-r--r--.SRCINFO14
-rw-r--r--0001-Rewrote-smartPlacement.patch13
-rw-r--r--0002-smartPlacement-w-snap_to_border-we-snap-to-bottom-ri.patch6
-rw-r--r--0003-Fix-new-window-always-top-left-when-screen-not-full.patch6
-rw-r--r--PKGBUILD12
5 files changed, 26 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5643f0bf9fe..eee51ce0eb9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Mar 20 15:15:30 UTC 2017
+# Sun Aug 26 16:40:05 UTC 2018
pkgbase = xfwm4-better-smartplacement
pkgdesc = Xfce window manager w/ better smart placement of new windows
- pkgver = 4.12.4
+ pkgver = 4.12.5
pkgrel = 1
url = http://www.xfce.org/
arch = i686
@@ -17,14 +17,14 @@ pkgbase = xfwm4-better-smartplacement
provides = xfwm4
conflicts = xfwm4
options = !libtool
- source = http://archive.xfce.org/src/xfce/xfwm4/4.12/xfwm4-4.12.4.tar.bz2
+ source = https://archive.xfce.org/src/xfce/xfwm4/4.12/xfwm4-4.12.5.tar.bz2
source = 0001-Rewrote-smartPlacement.patch
source = 0002-smartPlacement-w-snap_to_border-we-snap-to-bottom-ri.patch
source = 0003-Fix-new-window-always-top-left-when-screen-not-full.patch
- sha1sums = d1019cce2a2f7978e36cb30fdc0f27cf9f626244
- sha1sums = 54a9c4938f23554f9452e355577055980104c310
- sha1sums = c50220a372564ebd83426176fc252782365c3872
- sha1sums = 37fb87c433488b09447af1b0eb9e20e501ef4450
+ sha1sums = c41e435d07d8b782e534bbdde45e429bc59b3fa2
+ sha1sums = 337ce16ecb4cd30625df2210dbdd898e160e8a0d
+ sha1sums = 248b47a1e3992c28f668e89f821ee86562a7ad8f
+ sha1sums = e325137f81ef39305c10ab82bdbf60f592fac65e
pkgname = xfwm4-better-smartplacement
diff --git a/0001-Rewrote-smartPlacement.patch b/0001-Rewrote-smartPlacement.patch
index e6931540a8a5..0c7c8ba27c75 100644
--- a/0001-Rewrote-smartPlacement.patch
+++ b/0001-Rewrote-smartPlacement.patch
@@ -1,4 +1,4 @@
-From 43f53e9bef9bc8004e4ab59e915de5a4202afa77 Mon Sep 17 00:00:00 2001
+From 489ba880f18bc527c4d56a6aa7c333d780fe7cc7 Mon Sep 17 00:00:00 2001
From: Olivier Brunel <jjk@jjacky.com>
Date: Sun, 8 Mar 2015 13:22:12 +0100
Subject: [PATCH 1/3] Rewrote smartPlacement()
@@ -17,13 +17,14 @@ Signed-off-by: Olivier Brunel <jjk@jjacky.com>
1 file changed, 270 insertions(+), 144 deletions(-)
diff --git a/src/placement.c b/src/placement.c
-index e9a32c72..a6ce2636 100644
+index 9090a3f2..0d94313a 100644
--- a/src/placement.c
+++ b/src/placement.c
-@@ -543,16 +543,139 @@ clientAutoMaximize (Client * c, int full_w, int full_h)
+@@ -542,17 +542,140 @@ clientAutoMaximize (Client * c, int full_w, int full_h)
+ }
}
- static void
++static void
+expand_horizontal (cairo_region_t *region,
+ cairo_rectangle_int_t *rect,
+ gint full_x,
@@ -149,7 +150,7 @@ index e9a32c72..a6ce2636 100644
+ }
+}
+
-+static void
+ static void
smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
{
- Client *c2;
@@ -474,5 +475,5 @@ index e9a32c72..a6ce2636 100644
static void
--
-2.12.0
+2.15.1
diff --git a/0002-smartPlacement-w-snap_to_border-we-snap-to-bottom-ri.patch b/0002-smartPlacement-w-snap_to_border-we-snap-to-bottom-ri.patch
index 425077b4f97f..7d98d34db11d 100644
--- a/0002-smartPlacement-w-snap_to_border-we-snap-to-bottom-ri.patch
+++ b/0002-smartPlacement-w-snap_to_border-we-snap-to-bottom-ri.patch
@@ -1,4 +1,4 @@
-From c91efb6c180e7b939addb4e65eddb100c48e0945 Mon Sep 17 00:00:00 2001
+From 815b4a27e6a455998a05b5c43252f561025be68f Mon Sep 17 00:00:00 2001
From: jjacky <i.am.jack.mail@gmail.com>
Date: Fri, 5 Apr 2013 15:22:11 +0200
Subject: [PATCH 2/3] smartPlacement: w/ snap_to_border we snap to bottom/right
@@ -13,7 +13,7 @@ Signed-off-by: Olivier Brunel <jjk@jjacky.com>
1 file changed, 21 insertions(+), 12 deletions(-)
diff --git a/src/placement.c b/src/placement.c
-index a6ce2636..41c48824 100644
+index 0d94313a..7264a845 100644
--- a/src/placement.c
+++ b/src/placement.c
@@ -702,7 +702,7 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
@@ -98,5 +98,5 @@ index a6ce2636..41c48824 100644
c->x += frame_left;
c->y += frame_top;
--
-2.12.0
+2.15.1
diff --git a/0003-Fix-new-window-always-top-left-when-screen-not-full.patch b/0003-Fix-new-window-always-top-left-when-screen-not-full.patch
index 47d08671015d..9463772907a2 100644
--- a/0003-Fix-new-window-always-top-left-when-screen-not-full.patch
+++ b/0003-Fix-new-window-always-top-left-when-screen-not-full.patch
@@ -1,4 +1,4 @@
-From 73bbf7fed10ae33551892dcd7e029301ec826147 Mon Sep 17 00:00:00 2001
+From 84944aa000ddfc656c60005e868e815493628ee3 Mon Sep 17 00:00:00 2001
From: jjacky <i.am.jack.mail@gmail.com>
Date: Mon, 6 May 2013 11:00:51 +0200
Subject: [PATCH 3/3] Fix new window always top-left when screen not full
@@ -14,7 +14,7 @@ Signed-off-by: Olivier Brunel <jjk@jjacky.com>
1 file changed, 4 insertions(+)
diff --git a/src/placement.c b/src/placement.c
-index 41c48824..19b02a84 100644
+index 7264a845..dc6b0fae 100644
--- a/src/placement.c
+++ b/src/placement.c
@@ -767,6 +767,7 @@ smartPlacement (Client * c, int full_x, int full_y, int full_w, int full_h)
@@ -36,5 +36,5 @@ index 41c48824..19b02a84 100644
cairo_region_destroy (region_used);
--
-2.12.0
+2.15.1
diff --git a/PKGBUILD b/PKGBUILD
index 5e3608d2bce0..8a85426e7063 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=xfwm4
pkgname=$_pkgname-better-smartplacement
-pkgver=4.12.4
+pkgver=4.12.5
pkgrel=1
pkgdesc="Xfce window manager w/ better smart placement of new windows"
arch=('i686' 'x86_64')
@@ -16,14 +16,14 @@ makedepends=('pkgconfig' 'intltool')
options=('!libtool')
provides=($_pkgname)
conflicts=($_pkgname)
-source=(http://archive.xfce.org/src/xfce/${_pkgname}/4.12/${_pkgname}-${pkgver}.tar.bz2
+source=(https://archive.xfce.org/src/xfce/${_pkgname}/4.12/${_pkgname}-${pkgver}.tar.bz2
0001-Rewrote-smartPlacement.patch
0002-smartPlacement-w-snap_to_border-we-snap-to-bottom-ri.patch
0003-Fix-new-window-always-top-left-when-screen-not-full.patch)
-sha1sums=('d1019cce2a2f7978e36cb30fdc0f27cf9f626244'
- '54a9c4938f23554f9452e355577055980104c310'
- 'c50220a372564ebd83426176fc252782365c3872'
- '37fb87c433488b09447af1b0eb9e20e501ef4450')
+sha1sums=('c41e435d07d8b782e534bbdde45e429bc59b3fa2'
+ '337ce16ecb4cd30625df2210dbdd898e160e8a0d'
+ '248b47a1e3992c28f668e89f821ee86562a7ad8f'
+ 'e325137f81ef39305c10ab82bdbf60f592fac65e')
prepare() {
cd ${srcdir}/${_pkgname}-${pkgver}