summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlivier Brunel2015-03-15 14:17:46 +0100
committerOlivier Brunel2015-06-08 19:25:25 +0200
commit13dc19b6ccd4edcc9695d2941f3cf54240efbda9 (patch)
treedb8eedaf6f4436511d4cdf2c534d41414c769fff
parentb83e5ce88c6d69d737080ef8bc218e6fa1940fb3 (diff)
downloadaur-13dc19b6ccd4edcc9695d2941f3cf54240efbda9.tar.gz
xfwm4-hover-inactive: upgrade to 4.12.1
Signed-off-by: Olivier Brunel <jjk@jjacky.com>
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Add-hover-effects-for-titlebar-s-buttons-of-inactive.patch14
-rw-r--r--0001-Fix-a-mishmash-between-width-and-height.patch37
-rw-r--r--PKGBUILD9
4 files changed, 56 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb8d91984aab..8f7fb0d5d088 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xfwm4-hover-inactive
pkgdesc = Xfce window manager w/ hover effect for inactive windows
- pkgver = 4.12.0
+ pkgver = 4.12.1
pkgrel = 1
url = http://www.xfce.org/
install = xfwm4-hover-inactive.install
@@ -16,10 +16,12 @@ pkgbase = xfwm4-hover-inactive
provides = xfwm4
conflicts = xfwm4
options = !libtool
- source = http://archive.xfce.org/src/xfce/xfwm4/4.12/xfwm4-4.12.0.tar.bz2
+ source = http://archive.xfce.org/src/xfce/xfwm4/4.12/xfwm4-4.12.1.tar.bz2
+ source = 0001-Fix-a-mishmash-between-width-and-height.patch
source = 0001-Add-hover-effects-for-titlebar-s-buttons-of-inactive.patch
- sha1sums = 5c3ea9faaa9b45a40ca7ecfff447cdca192534f6
- sha1sums = 29ee9bfaa981bfca46afd9a60fbcfad3634cee22
+ sha1sums = e7470b69bba29c9c0e0bcd1471e80b73c6ccfd91
+ sha1sums = 2fc881cf4fbdbd7c6f55eb5d4900dc133516ee14
+ sha1sums = 80e75265a7a4146035b0ba201e1cebb398e75e32
pkgname = xfwm4-hover-inactive
diff --git a/0001-Add-hover-effects-for-titlebar-s-buttons-of-inactive.patch b/0001-Add-hover-effects-for-titlebar-s-buttons-of-inactive.patch
index 5d30f6c5a1b4..6060165b3c81 100644
--- a/0001-Add-hover-effects-for-titlebar-s-buttons-of-inactive.patch
+++ b/0001-Add-hover-effects-for-titlebar-s-buttons-of-inactive.patch
@@ -1,4 +1,4 @@
-From f450803bd5dc90b9313c68f3581bb0488d22f296 Mon Sep 17 00:00:00 2001
+From c814e9ca7749cc5e80f708f3e0051a22f0886de7 Mon Sep 17 00:00:00 2001
From: jjacky <i.am.jack.mail@gmail.com>
Date: Thu, 4 Apr 2013 16:58:07 +0200
Subject: [PATCH] Add hover effects for (titlebar's) buttons of inactive
@@ -14,10 +14,10 @@ Signed-off-by: Olivier Brunel <jjk@jjacky.com>
2 files changed, 15 insertions(+), 18 deletions(-)
diff --git a/src/client.c b/src/client.c
-index 79de331..3812aac 100644
+index 7fa9e36..b207f36 100644
--- a/src/client.c
+++ b/src/client.c
-@@ -3942,6 +3942,12 @@ clientGetButtonPixmap (Client *c, int button, int state)
+@@ -3974,6 +3974,12 @@ clientGetButtonPixmap (Client *c, int button, int state)
int
clientGetButtonState (Client *c, int button, int state)
{
@@ -30,7 +30,7 @@ index 79de331..3812aac 100644
if (state == INACTIVE)
{
return (state);
-@@ -3953,12 +3959,6 @@ clientGetButtonState (Client *c, int button, int state)
+@@ -3985,12 +3991,6 @@ clientGetButtonState (Client *c, int button, int state)
return (PRESSED);
}
@@ -44,10 +44,10 @@ index 79de331..3812aac 100644
}
diff --git a/src/events.c b/src/events.c
-index 561cd5c..51411a8 100644
+index 50303b0..efc1db6 100644
--- a/src/events.c
+++ b/src/events.c
-@@ -1416,23 +1416,20 @@ handleEnterNotify (DisplayInfo *display_info, XCrossingEvent * ev)
+@@ -1421,23 +1421,20 @@ handleEnterNotify (DisplayInfo *display_info, XCrossingEvent * ev)
clientClearDelayedFocus ();
}
}
@@ -81,5 +81,5 @@ index 561cd5c..51411a8 100644
/* No need to process the event any further */
--
-2.3.1
+2.3.3
diff --git a/0001-Fix-a-mishmash-between-width-and-height.patch b/0001-Fix-a-mishmash-between-width-and-height.patch
new file mode 100644
index 000000000000..1cb314cab421
--- /dev/null
+++ b/0001-Fix-a-mishmash-between-width-and-height.patch
@@ -0,0 +1,37 @@
+From adcf17fe8a136c89196f952185056c12c3829a01 Mon Sep 17 00:00:00 2001
+From: Olivier Fourdan <fourdan@xfce.org>
+Date: Sun, 15 Mar 2015 11:24:15 +0100
+Subject: [PATCH] Fix a mishmash between width and height
+
+Bug: 11700
+
+Duh...
+
+Signed-off-by: Olivier Fourdan <fourdan@xfce.org>
+---
+ src/client.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/client.c b/src/client.c
+index 7fa9e36..38ecc6f 100644
+--- a/src/client.c
++++ b/src/client.c
+@@ -543,12 +543,12 @@ clientAdjustCoordGravity (Client *c, int gravity, XWindowChanges *wc, unsigned l
+
+ if (*mask & CWWidth)
+ {
+- wc->width = clientCheckHeight (c, wc->width, TRUE);
++ wc->width = clientCheckWidth (c, wc->width, TRUE);
+ }
+
+- if (*mask & CWWidth)
++ if (*mask & CWHeight)
+ {
+- wc->height = clientCheckWidth (c, wc->height, TRUE);
++ wc->height = clientCheckHeight (c, wc->height, TRUE);
+ }
+
+ switch (gravity)
+--
+2.3.3
+
diff --git a/PKGBUILD b/PKGBUILD
index 7d6a724913fb..d1034e9fe1f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=xfwm4
pkgname=$_pkgname-hover-inactive
-pkgver=4.12.0
+pkgver=4.12.1
pkgrel=1
pkgdesc="Xfce window manager w/ hover effect for inactive windows"
arch=('i686' 'x86_64')
@@ -18,12 +18,15 @@ provides=($_pkgname)
conflicts=($_pkgname)
install=${pkgname}.install
source=(http://archive.xfce.org/src/xfce/${_pkgname}/4.12/${_pkgname}-${pkgver}.tar.bz2
+ 0001-Fix-a-mishmash-between-width-and-height.patch
0001-Add-hover-effects-for-titlebar-s-buttons-of-inactive.patch)
-sha1sums=('5c3ea9faaa9b45a40ca7ecfff447cdca192534f6'
- '29ee9bfaa981bfca46afd9a60fbcfad3634cee22')
+sha1sums=('e7470b69bba29c9c0e0bcd1471e80b73c6ccfd91'
+ '2fc881cf4fbdbd7c6f55eb5d4900dc133516ee14'
+ '80e75265a7a4146035b0ba201e1cebb398e75e32')
prepare() {
cd ${srcdir}/${_pkgname}-${pkgver}
+ patch -p1 -i ../0001-Fix-a-mishmash-between-width-and-height.patch
patch -p1 -i ../0001-Add-hover-effects-for-titlebar-s-buttons-of-inactive.patch
}