summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjjacky2012-02-07 15:41:26 +0100
committerOlivier Brunel2015-06-08 19:23:06 +0200
commitd7b26b577dd431ce7731b8527779acc9173974ef (patch)
tree73209c60ba48c1e9035ddaf593b167550a925c9c
downloadaur-d7b26b577dd431ce7731b8527779acc9173974ef.tar.gz
first commit
Signed-off-by: Olivier Brunel <jjk@jjacky.com>
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD46
-rw-r--r--hover-inactive.patch65
-rw-r--r--xfwm4-hover-inactive.install11
4 files changed, 149 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..adaf16bdb02e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = xfwm4-hover-inactive
+ pkgdesc = Xfce window manager w/ hover effect for inactive windows
+ pkgver = 4.8.3
+ pkgrel = 1
+ url = http://www.xfce.org/
+ install = xfwm4-hover-inactive.install
+ arch = i686
+ arch = x86_64
+ groups = xfce4
+ license = GPL2
+ makedepends = pkgconfig
+ makedepends = intltool
+ depends = libxfce4ui
+ depends = libwnck
+ depends = hicolor-icon-theme
+ provides = xfwm4=4.8.3
+ conflicts = xfwm4
+ options = !libtool
+ source = http://archive.xfce.org/src/xfce/xfwm4/4.8/xfwm4-4.8.3.tar.bz2
+ source = hover-inactive.patch
+ md5sums = 66cb65797cea8a62563f69b833c7888b
+ md5sums = 2a64105b4db589ecc8cdfee29ff68851
+ sha1sums = 6d27deca383e0c2fba0cede0bbe0e9aee18e9257
+ sha1sums = b14eb1286dc618b8ffcb0bf2995c16bc1d4f9e6f
+
+pkgname = xfwm4-hover-inactive
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6f8c59ccac8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: jjacky
+# Contributor: AndyRTR <andyrtr@archlinux.org>
+# Contributor: tobias <tobias funnychar archlinux.org>
+
+_pkgname=xfwm4
+pkgname=$_pkgname-hover-inactive
+pkgver=4.8.3
+pkgrel=1
+pkgdesc="Xfce window manager w/ hover effect for inactive windows"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://www.xfce.org/"
+groups=('xfce4')
+depends=("libxfce4ui" 'libwnck' 'hicolor-icon-theme')
+makedepends=('pkgconfig' 'intltool')
+options=('!libtool')
+provides=('xfwm4=4.8.3')
+conflicts=('xfwm4')
+install=${pkgname}.install
+source=(http://archive.xfce.org/src/xfce/${_pkgname}/4.8/${_pkgname}-${pkgver}.tar.bz2
+ hover-inactive.patch)
+md5sums=('66cb65797cea8a62563f69b833c7888b'
+ '2a64105b4db589ecc8cdfee29ff68851')
+sha1sums=('6d27deca383e0c2fba0cede0bbe0e9aee18e9257'
+ 'b14eb1286dc618b8ffcb0bf2995c16bc1d4f9e6f')
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ patch -p1 -i ../hover-inactive.patch
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-startup-notification \
+ --enable-randr \
+ --enable-compositor \
+ --enable-xsync \
+ --disable-debug
+ make
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
diff --git a/hover-inactive.patch b/hover-inactive.patch
new file mode 100644
index 000000000000..3dc8789b4ef4
--- /dev/null
+++ b/hover-inactive.patch
@@ -0,0 +1,65 @@
+diff -r 6ae1e81f12d7 src/client.c
+--- a/src/client.c Tue Dec 20 20:30:57 2011 +0100
++++ b/src/client.c Tue Dec 20 20:41:38 2011 +0100
+@@ -3795,6 +3795,12 @@
+ int
+ clientGetButtonState (Client *c, int button, int state)
+ {
++ if ((c->button_status[button] == BUTTON_STATE_PRELIGHT) &&
++ clientGetButtonPixmap (c, button, PRELIGHT))
++ {
++ return (PRELIGHT);
++ }
++
+ if (state == INACTIVE)
+ {
+ return (state);
+@@ -3806,12 +3812,6 @@
+ return (PRESSED);
+ }
+
+- if ((c->button_status[button] == BUTTON_STATE_PRELIGHT) &&
+- clientGetButtonPixmap (c, button, PRELIGHT))
+- {
+- return (PRELIGHT);
+- }
+-
+ return (ACTIVE);
+ }
+
+diff -r 6ae1e81f12d7 src/events.c
+--- a/src/events.c Tue Dec 20 20:30:57 2011 +0100
++++ b/src/events.c Tue Dec 20 20:41:38 2011 +0100
+@@ -1380,23 +1380,20 @@
+ clientClearDelayedFocus ();
+ }
+ }
+- if (c == clientGetFocus ())
++ for (b = 0; b < BUTTON_COUNT; b++)
+ {
+- for (b = 0; b < BUTTON_COUNT; b++)
++ if (MYWINDOW_XWINDOW(c->buttons[b]) == ev->window)
+ {
+- if (MYWINDOW_XWINDOW(c->buttons[b]) == ev->window)
++ if (!xfwmPixmapNone(clientGetButtonPixmap(c, b, PRELIGHT)))
+ {
+- if (!xfwmPixmapNone(clientGetButtonPixmap(c, b, PRELIGHT)))
+- {
+- c->button_status[b] = BUTTON_STATE_PRELIGHT;
+- need_redraw = TRUE;
+- }
++ c->button_status[b] = BUTTON_STATE_PRELIGHT;
++ need_redraw = TRUE;
+ }
+ }
+- if (need_redraw)
+- {
+- frameQueueDraw (c, FALSE);
+- }
++ }
++ if (need_redraw)
++ {
++ frameQueueDraw (c, FALSE);
+ }
+
+ /* No need to process the event any further */
diff --git a/xfwm4-hover-inactive.install b/xfwm4-hover-inactive.install
new file mode 100644
index 000000000000..21b79d2d44de
--- /dev/null
+++ b/xfwm4-hover-inactive.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}