summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Popov2016-12-30 14:55:25 +0300
committerDmitry Popov2016-12-30 14:55:25 +0300
commit147b597ac06f857d6ea08c134c28d353caa36074 (patch)
treebe6ba6ad66978b7f7ee18c4184df06231af495a9
parentb148372354e3b9c195fd32558e45da8a1a9d7c7a (diff)
downloadaur-147b597ac06f857d6ea08c134c28d353caa36074.tar.gz
Bump version (to r2952.7948d1c) and fix patches accordingly
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--python_no_libs.patch10
3 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25197034467a..8b6ada82420b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = xgboost-git
- pkgver = r2828.ecec5f7
+ pkgver = r2952.7948d1c
pkgrel = 1
url = https://github.com/dmlc/xgboost
arch = x86_64
@@ -13,7 +13,7 @@ pkgbase = xgboost-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 610f3ec61f30907eab32ca00ebe84ca0bc5d5566d462ed9c477b130c02f38a74
+ sha256sums = fb7632bbde577bb07e3355adc6adf644f98f184df7a260f00fe08717f09cf044
pkgname = xgboost-git
pkgdesc = An optimized distributed gradient boosting library designed to be highly efficient, flexible and portable
diff --git a/PKGBUILD b/PKGBUILD
index a9c32ca6e104..2f7ec2b21036 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase=xgboost-git
pkgname=('xgboost-git'
'python-xgboost-git'
'python2-xgboost-git')
-pkgver=r2828.ecec5f7
+pkgver=r2952.7948d1c
pkgrel=1
url='https://github.com/dmlc/xgboost'
license=('APACHE')
@@ -18,7 +18,7 @@ arch=('x86_64')
sha256sums=('SKIP'
'SKIP'
'SKIP'
- '610f3ec61f30907eab32ca00ebe84ca0bc5d5566d462ed9c477b130c02f38a74')
+ 'fb7632bbde577bb07e3355adc6adf644f98f184df7a260f00fe08717f09cf044')
pkgver() {
cd "${_name}"
diff --git a/python_no_libs.patch b/python_no_libs.patch
index 9563e893f8a0..664ec57e97c7 100644
--- a/python_no_libs.patch
+++ b/python_no_libs.patch
@@ -1,5 +1,5 @@
diff --git a/python-package/setup.py b/python-package/setup.py
-index 5b66a09..b643550 100644
+index 27fc212..5a2b415 100644
--- a/python-package/setup.py
+++ b/python-package/setup.py
@@ -5,19 +5,9 @@ import sys
@@ -22,17 +22,19 @@ index 5b66a09..b643550 100644
# Please use setup_pip.py for generating and deploying pip installation
# detailed instruction in setup_pip.py
setup(name='xgboost',
-@@ -36,5 +26,4 @@ setup(name='xgboost',
+@@ -36,7 +26,6 @@ setup(name='xgboost',
# this will use MANIFEST.in during install where we specify additional files,
# this is the golden line
include_package_data=True,
- data_files=[('xgboost', LIB_PATH)],
+ license='Apache-2.0',
+ classifiers=['License :: OSI Approved :: Apache Software License'],
url='https://github.com/dmlc/xgboost')
diff --git a/python-package/xgboost/libpath.py b/python-package/xgboost/libpath.py
-index 2d69bda..d3ee109 100644
+index 46d2004..423b39b 100644
--- a/python-package/xgboost/libpath.py
+++ b/python-package/xgboost/libpath.py
-@@ -21,7 +21,8 @@
+@@ -21,7 +21,8 @@ def find_lib_path():
"""
curr_path = os.path.dirname(os.path.abspath(os.path.expanduser(__file__)))
# make pythonpack hack: copy this directory one level upper for setup.py