summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Popov2018-08-09 15:30:11 +0300
committerDmitry Popov2018-08-09 15:30:11 +0300
commit2c104022bc620a6fc0a489595e084d1015eae24f (patch)
tree5a51f5744f432dbab1466af23cd101f6f3f0ee27
parent88f42792b67ee5a1dce6dc2a94d16495fd6feb12 (diff)
downloadaur-2c104022bc620a6fc0a489595e084d1015eae24f.tar.gz
Bump version (to r3372.bbb771f3) and fix patches accordingly
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--python_no_libs.patch20
3 files changed, 23 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47420c13227d..7a09e06e364f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = xgboost-git
- pkgver = r2965.a073a2c3
+ pkgver = r3372.bbb771f3
pkgrel = 1
url = https://github.com/dmlc/xgboost
arch = x86_64
@@ -9,11 +9,13 @@ pkgbase = xgboost-git
source = git+https://github.com/dmlc/xgboost.git
source = git+https://github.com/dmlc/dmlc-core
source = git+https://github.com/dmlc/rabit
+ source = git+https://github.com/NVlabs/cub
source = python_no_libs.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = dd66a09be68f38fef140c948027e44e3733778e741c84491124b5de8acf6c336
+ sha256sums = SKIP
+ sha256sums = c10f13abd54197e4b10da7efcb699f290691a0369fc0fa6402f9c8302a3347ea
pkgname = xgboost-git
pkgdesc = An optimized distributed gradient boosting library designed to be highly efficient, flexible and portable
diff --git a/PKGBUILD b/PKGBUILD
index a23358dab8b3..cff5d4529cd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,20 +5,22 @@ pkgbase=xgboost-git
pkgname=('xgboost-git'
'python-xgboost-git'
'python2-xgboost-git')
-pkgver=r2965.a073a2c3
+pkgver=r3372.bbb771f3
pkgrel=1
url='https://github.com/dmlc/xgboost'
license=('APACHE')
source=('git+https://github.com/dmlc/xgboost.git'
'git+https://github.com/dmlc/dmlc-core'
'git+https://github.com/dmlc/rabit'
+ 'git+https://github.com/NVlabs/cub'
'python_no_libs.patch')
makedepends=('python2-setuptools' 'python-setuptools')
arch=('x86_64')
sha256sums=('SKIP'
'SKIP'
'SKIP'
- 'dd66a09be68f38fef140c948027e44e3733778e741c84491124b5de8acf6c336')
+ 'SKIP'
+ 'c10f13abd54197e4b10da7efcb699f290691a0369fc0fa6402f9c8302a3347ea')
pkgver() {
cd "${_name}"
@@ -30,6 +32,7 @@ prepare() {
git submodule init
git config submodule.dmlc-core.url "${srcdir}/dmlc-core"
git config submodule.rabit.url "${srcdir}/rabit"
+ git config submodule.cub.url "${srcdir}/cub"
git submodule update
patch -p1 < "${srcdir}/python_no_libs.patch"
}
diff --git a/python_no_libs.patch b/python_no_libs.patch
index 3459df2bc73c..502425ac4061 100644
--- a/python_no_libs.patch
+++ b/python_no_libs.patch
@@ -1,8 +1,8 @@
diff --git a/python-package/setup.py b/python-package/setup.py
-index 27fc212..5a2b415 100644
+index d4b6aa6b..a96660fa 100644
--- a/python-package/setup.py
+++ b/python-package/setup.py
-@@ -5,19 +5,9 @@ import sys
+@@ -5,27 +5,9 @@ import sys
import os
from setuptools import setup, find_packages
# import subprocess
@@ -17,12 +17,20 @@ index 27fc212..5a2b415 100644
-libpath = {'__file__': libpath_py}
-exec(compile(open(libpath_py, "rb").read(), libpath_py, 'exec'), libpath, libpath)
-
--LIB_PATH = [os.path.relpath(libfile, CURRENT_DIR) for libfile in libpath['find_lib_path']()]
+-LIB_PATH = []
+-for libfile in libpath['find_lib_path']():
+- try:
+- relpath = os.path.relpath(libfile, CURRENT_DIR)
+- LIB_PATH.append(relpath)
+- break # need only one
+- except ValueError:
+- continue
+-
-print("Install libxgboost from: %s" % LIB_PATH)
# Please use setup_pip.py for generating and deploying pip installation
# detailed instruction in setup_pip.py
setup(name='xgboost',
-@@ -36,7 +26,6 @@ setup(name='xgboost',
+@@ -43,7 +25,6 @@ setup(name='xgboost',
# this will use MANIFEST.in during install where we specify additional files,
# this is the golden line
include_package_data=True,
@@ -31,7 +39,7 @@ index 27fc212..5a2b415 100644
classifiers=['License :: OSI Approved :: Apache Software License'],
url='https://github.com/dmlc/xgboost')
diff --git a/python-package/xgboost/libpath.py b/python-package/xgboost/libpath.py
-index 46d2004..423b39b 100644
+index d87922c0..2752c504 100644
--- a/python-package/xgboost/libpath.py
+++ b/python-package/xgboost/libpath.py
@@ -21,7 +21,8 @@ def find_lib_path():
@@ -43,4 +51,4 @@ index 46d2004..423b39b 100644
+ os.path.join(curr_path, '../../lib/'),
os.path.join(curr_path, './lib/'),
os.path.join(sys.prefix, 'xgboost')]
- if os.name == 'nt':
+ if sys.platform == 'win32':