summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Popov2022-05-30 19:06:39 +0300
committerDmitry Popov2022-05-30 19:07:08 +0300
commit3091619155c86f4d6563d9e78443cd384bde3900 (patch)
tree2b0a2cb5bf4b2889d0d3cdeceaa5df7c6e88ccc0
parent6b824ed48658121caa989029850086a968273508 (diff)
downloadaur-3091619155c86f4d6563d9e78443cd384bde3900.tar.gz
Bump version (to r5804.6275cdc48) and fix patches accordingly
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD4
-rw-r--r--python_no_libs.patch10
3 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bb8155f2c36..01f92c13fc32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = xgboost-git
- pkgver = r4244.306e38ff3
+ pkgver = r5804.6275cdc48
pkgrel = 1
url = https://github.com/dmlc/xgboost
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = xgboost-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 4940b84afffe9c2be646d0f77bcfb0d8d36aadcabc4a83b40113e1d97ae917b5
+ sha256sums = SKIP
pkgname = xgboost-git
pkgdesc = An optimized distributed gradient boosting library designed to be highly efficient, flexible and portable
@@ -30,4 +30,3 @@ pkgname = python-xgboost-git
depends = python-scipy
provides = python-xgboost
conflicts = python-xgboost
-
diff --git a/PKGBUILD b/PKGBUILD
index 110aff0dd760..97dc21bb57af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgname=('xgboost-git'
if $_with_r; then
pkgname+=('r-xgboost-git')
fi
-pkgver=r4244.306e38ff3
+pkgver=r5804.6275cdc48
pkgrel=1
url='https://github.com/dmlc/xgboost'
license=('APACHE')
@@ -28,7 +28,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '4940b84afffe9c2be646d0f77bcfb0d8d36aadcabc4a83b40113e1d97ae917b5')
+ 'SKIP')
pkgver() {
cd "${_name}"
diff --git a/python_no_libs.patch b/python_no_libs.patch
index a4978b2aec4a..e5a1163e09f4 100644
--- a/python_no_libs.patch
+++ b/python_no_libs.patch
@@ -2,12 +2,12 @@ diff --git a/python-package/setup.py b/python-package/setup.py
index e1433af05..3fa20467d 100644
--- a/python-package/setup.py
+++ b/python-package/setup.py
-@@ -283,7 +283,6 @@ if __name__ == '__main__':
+@@ -339,7 +339,6 @@
cmdclass={
- 'build_ext': BuildExt,
- 'sdist': Sdist,
-- 'install_lib': InstallLib,
- 'install': Install
+ 'build_ext': BuildExt, # type: ignore
+ 'sdist': Sdist, # type: ignore
+- 'install_lib': InstallLib, # type: ignore
+ 'install': Install # type: ignore
},
extras_require={
diff --git a/python-package/xgboost/libpath.py b/python-package/xgboost/libpath.py