summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Popov2019-06-13 00:22:05 +0300
committerDmitry Popov2019-06-13 00:27:19 +0300
commit3afc6f59af6e249bf2b1bdec88922cfea20b4695 (patch)
tree50348144b2e7503a78a59bf50d90c2ce8a5bc7fe
parent2c104022bc620a6fc0a489595e084d1015eae24f (diff)
downloadaur-3afc6f59af6e249bf2b1bdec88922cfea20b4695.tar.gz
Bump version (to r3762.a2042b68) and fix patches accordingly
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--python_no_libs.patch23
3 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a09e06e364f..89f072f2c5a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = xgboost-git
- pkgver = r3372.bbb771f3
+ pkgver = r3762.a2042b68
pkgrel = 1
url = https://github.com/dmlc/xgboost
arch = x86_64
@@ -15,7 +15,7 @@ pkgbase = xgboost-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = c10f13abd54197e4b10da7efcb699f290691a0369fc0fa6402f9c8302a3347ea
+ sha256sums = e36d89ed5afab7af2ef4c36393bbce4fdbae0dcc739724fe9df8cfece71c59a2
pkgname = xgboost-git
pkgdesc = An optimized distributed gradient boosting library designed to be highly efficient, flexible and portable
diff --git a/PKGBUILD b/PKGBUILD
index cff5d4529cd1..8ecca51bf924 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase=xgboost-git
pkgname=('xgboost-git'
'python-xgboost-git'
'python2-xgboost-git')
-pkgver=r3372.bbb771f3
+pkgver=r3762.a2042b68
pkgrel=1
url='https://github.com/dmlc/xgboost'
license=('APACHE')
@@ -20,7 +20,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'c10f13abd54197e4b10da7efcb699f290691a0369fc0fa6402f9c8302a3347ea')
+ 'e36d89ed5afab7af2ef4c36393bbce4fdbae0dcc739724fe9df8cfece71c59a2')
pkgver() {
cd "${_name}"
diff --git a/python_no_libs.patch b/python_no_libs.patch
index 502425ac4061..38d778498bf6 100644
--- a/python_no_libs.patch
+++ b/python_no_libs.patch
@@ -1,10 +1,10 @@
diff --git a/python-package/setup.py b/python-package/setup.py
-index d4b6aa6b..a96660fa 100644
+index 30e0d070..f96ef69e 100644
--- a/python-package/setup.py
+++ b/python-package/setup.py
-@@ -5,27 +5,9 @@ import sys
- import os
+@@ -8,28 +8,9 @@ import os
from setuptools import setup, find_packages
+
# import subprocess
-sys.path.insert(0, '.')
@@ -27,22 +27,23 @@ index d4b6aa6b..a96660fa 100644
- continue
-
-print("Install libxgboost from: %s" % LIB_PATH)
- # Please use setup_pip.py for generating and deploying pip installation
- # detailed instruction in setup_pip.py
- setup(name='xgboost',
-@@ -43,7 +25,6 @@ setup(name='xgboost',
+-
+ # Get dmlc tracker script
+ shutil.copy('../dmlc-core/tracker/dmlc_tracker/tracker.py', 'xgboost/')
+
+@@ -50,7 +31,6 @@ setup(name='xgboost',
# this will use MANIFEST.in during install where we specify additional files,
# this is the golden line
include_package_data=True,
- data_files=[('xgboost', LIB_PATH)],
license='Apache-2.0',
- classifiers=['License :: OSI Approved :: Apache Software License'],
- url='https://github.com/dmlc/xgboost')
+ classifiers=['License :: OSI Approved :: Apache Software License',
+ 'Development Status :: 5 - Production/Stable',
diff --git a/python-package/xgboost/libpath.py b/python-package/xgboost/libpath.py
-index d87922c0..2752c504 100644
+index a313a1b8..f161d50a 100644
--- a/python-package/xgboost/libpath.py
+++ b/python-package/xgboost/libpath.py
-@@ -21,7 +21,8 @@ def find_lib_path():
+@@ -20,7 +20,8 @@ def find_lib_path():
"""
curr_path = os.path.dirname(os.path.abspath(os.path.expanduser(__file__)))
# make pythonpack hack: copy this directory one level upper for setup.py