summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Popov2020-02-14 00:09:59 +0300
committerDmitry Popov2020-02-14 00:11:40 +0300
commitddb21f864ea7e472ca9dc0e4523d226ed5c01d60 (patch)
tree26a5fff823536745d6be77a19763151d5106541d
parented4c6fc192829a4659d558f3b7648b51f71fa50e (diff)
downloadaur-ddb21f864ea7e472ca9dc0e4523d226ed5c01d60.tar.gz
Drop python2 support (as upstream did)
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD22
2 files changed, 3 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7fd8b67a6d6..db3a57095bae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,6 @@ pkgbase = xgboost-git
url = https://github.com/dmlc/xgboost
arch = x86_64
license = APACHE
- makedepends = python2-setuptools
makedepends = python-setuptools
source = git+https://github.com/dmlc/xgboost.git
source = git+https://github.com/dmlc/dmlc-core
@@ -20,7 +19,6 @@ pkgbase = xgboost-git
pkgname = xgboost-git
pkgdesc = An optimized distributed gradient boosting library designed to be highly efficient, flexible and portable
optdepends = python-xgboost-git: Python 3 Wrapper
- optdepends = python2-xgboost-git: Python 2 Wrapper
provides = xgboost
conflicts = xgboost
@@ -33,12 +31,3 @@ pkgname = python-xgboost-git
provides = python-xgboost
conflicts = python-xgboost
-pkgname = python2-xgboost-git
- pkgdesc = XGBoost Python 2 wrapper
- depends = xgboost
- depends = python2
- depends = python2-numpy
- depends = python2-scipy
- provides = python2-xgboost
- conflicts = python2-xgboost
-
diff --git a/PKGBUILD b/PKGBUILD
index 914ff2cdcc36..1a9f73ae31ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,7 @@
_name=xgboost
pkgbase=xgboost-git
pkgname=('xgboost-git'
- 'python-xgboost-git'
- 'python2-xgboost-git')
+ 'python-xgboost-git')
pkgver=r3854.97007765
pkgrel=1
url='https://github.com/dmlc/xgboost'
@@ -14,7 +13,7 @@ source=('git+https://github.com/dmlc/xgboost.git'
'git+https://github.com/dmlc/rabit'
'git+https://github.com/NVlabs/cub'
'python_no_libs.patch')
-makedepends=('python2-setuptools' 'python-setuptools')
+makedepends=('python-setuptools')
arch=('x86_64')
sha256sums=('SKIP'
'SKIP'
@@ -46,8 +45,7 @@ package_xgboost-git() {
pkgdesc='An optimized distributed gradient boosting library designed to be highly efficient, flexible and portable'
provides=('xgboost')
conflicts=('xgboost')
- optdepends=('python-xgboost-git: Python 3 Wrapper'
- 'python2-xgboost-git: Python 2 Wrapper')
+ optdepends=('python-xgboost-git: Python 3 Wrapper')
cd "${_name}"
@@ -76,20 +74,6 @@ package_xgboost-git() {
cp -r demo "${pkgdir}"/opt/xgboost
}
-package_python2-xgboost-git() {
- pkgdesc='XGBoost Python 2 wrapper'
- depends=('xgboost'
- 'python2'
- 'python2-numpy'
- 'python2-scipy')
- conflicts=('python2-xgboost')
- provides=('python2-xgboost')
-
- cd "${_name}/python-package"
-
- python2 setup.py install --root="${pkgdir}" --optimize=1
-}
-
package_python-xgboost-git() {
pkgdesc='XGBoost Python 3 wrapper'
depends=('xgboost'