summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergio Correia2015-06-16 14:09:50 -0400
committerSergio Correia2015-06-16 14:09:50 -0400
commit191cd67e58b7f9da1549344c17330af9a4f90556 (patch)
tree753dccb1aaa725d87d7372b1fb420510140f0092
downloadaur-191cd67e58b7f9da1549344c17330af9a4f90556.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD45
-rw-r--r--gcc4.4.diff35
-rw-r--r--xgraph-12.1-replace-helvetica-with-dejavu.patch15
4 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a9abeddb887
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = xgraph
+ pkgdesc = X-Windows application for interactive plotting and graphing
+ pkgver = 12.1
+ pkgrel = 5
+ url = http://www.isi.edu/nsnam/xgraph/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = libx11
+ depends = ttf-dejavu
+ source = http://www.isi.edu/nsnam/dist/xgraph-12.1.tar.gz
+ source = gcc4.4.diff
+ source = xgraph-12.1-replace-helvetica-with-dejavu.patch
+ sha256sums = 0aa17d3fa3abfa8b6679fc26812a988332a2a0f1f48973d17429089015672b08
+ sha256sums = cda2660d2c92b5dfe18571914364c1e4eccd1b35439fddcfe94be7321aafdfc9
+ sha256sums = 0eb5c0e591d637b9318065abd72b588a50aaa7cce7c772f286a4c4683f831a26
+
+pkgname = xgraph
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db8dc2a3b947
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Sergio Correia <sergio@correia.cc>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Alexandros Konstantinakis - Karmis <el04092@users.ntua.gr>
+
+pkgname=xgraph
+pkgver=12.1
+pkgrel=5
+pkgdesc="X-Windows application for interactive plotting and graphing"
+url="http://www.isi.edu/nsnam/xgraph/"
+license=('custom')
+arch=('i686' 'x86_64')
+depends=('libx11' 'ttf-dejavu')
+source=(http://www.isi.edu/nsnam/dist/"${pkgname}"-"${pkgver}".tar.gz
+ gcc4.4.diff
+ xgraph-12.1-replace-helvetica-with-dejavu.patch)
+sha256sums=('0aa17d3fa3abfa8b6679fc26812a988332a2a0f1f48973d17429089015672b08'
+ 'cda2660d2c92b5dfe18571914364c1e4eccd1b35439fddcfe94be7321aafdfc9'
+ '0eb5c0e591d637b9318065abd72b588a50aaa7cce7c772f286a4c4683f831a26')
+
+prepare() {
+ cd "${srcdir}"/"${pkgname}"-"${pkgver}"
+ patch -uNp1 -i ../gcc4.4.diff
+ patch -uNp1 -i ../xgraph-12.1-replace-helvetica-with-dejavu.patch
+}
+
+build() {
+ cd "${srcdir}"/"${pkgname}"-"${pkgver}"
+ unset CPPFLAGS # b0rken FORTIFY_SOURCE
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "${srcdir}"/"${pkgname}"-"${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${pkgdir}"/usr/share/man/manm/"${pkgname}".man \
+ "${pkgdir}"/usr/share/man/man1/"${pkgname}".1
+ rm -r "${pkgdir}"/usr/share/man/manm
+
+ install -Dm644 copyright.h \
+ "${pkgdir}"/usr/share/licenses/"${pkgname}"/copyright.h
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gcc4.4.diff b/gcc4.4.diff
new file mode 100644
index 000000000000..90d5f8a1b514
--- /dev/null
+++ b/gcc4.4.diff
@@ -0,0 +1,35 @@
+diff -aur xgraph-12.1.orig/dialog.c xgraph-12.1.new/dialog.c
+--- xgraph-12.1.orig/dialog.c 2009-06-16 20:27:46.000000000 +0200
++++ xgraph-12.1.new/dialog.c 2009-06-16 20:32:30.000000000 +0200
+@@ -777,7 +777,7 @@
+ memset(new_info->lines, 0, sizeof(Window) * E_LINES);
+
+ lineptr = text;
+- while (getline(&lineptr, line)) {
++ while (xgraph_getline(&lineptr, line)) {
+ if (new_info->num_lines >= new_info->alloc_lines) {
+ int old_alloc_lines_size = new_info->alloc_lines * sizeof(Window);
+ new_info->alloc_lines *= 2;
+@@ -884,11 +884,11 @@
+ else
+ fputs(err_text, stderr);
+ }
+-
++
+
+
+ int
+-getline(tptr, lptr)
++xgraph_getline(tptr, lptr)
+ char **tptr;
+ char *lptr;
+
+@@ -914,7 +914,7 @@
+ return 0;
+ }
+ }
+-
++
+
+
+ static void
diff --git a/xgraph-12.1-replace-helvetica-with-dejavu.patch b/xgraph-12.1-replace-helvetica-with-dejavu.patch
new file mode 100644
index 000000000000..5c785b5fd1f0
--- /dev/null
+++ b/xgraph-12.1-replace-helvetica-with-dejavu.patch
@@ -0,0 +1,15 @@
+diff --git a/init.c b/init.c
+index ff560cf..32b3450 100644
+--- a/init.c
++++ b/init.c
+@@ -63,8 +63,8 @@ static char rcsid[] = "$Id: init.c,v 1.2 1999/12/19 00:52:06 heideman Exp $";
+ #define DEF_LINE_WIDTH "0"
+ #define DEF_GRID_SIZE "0"
+ #define DEF_GRID_STYLE "10"
+-#define DEF_LABEL_FONT "helvetica-10"
+-#define DEF_TITLE_FONT "helvetica-18"
++#define DEF_LABEL_FONT "dejavu-10"
++#define DEF_TITLE_FONT "dejavu-18"
+ #define DEF_GEOMETRY ""
+ #define DEF_REVERSE "off"
+ /* PW Changes these to please JM */