summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEray AYDIN2017-06-20 03:48:04 +0300
committerEray AYDIN2017-06-20 03:48:04 +0300
commit330813d278bf2c44e6bc5c922269aa04d57bc53a (patch)
treeb5982c5d7c492a45979ea3d02d320fa59c40c7e1
downloadaur-330813d278bf2c44e6bc5c922269aa04d57bc53a.tar.gz
first initialize of xgraphic
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ea6dbca00c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xgraphic
+ pkgdesc = Switch between nvidia and bumblebee
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/erayaydin/xgraphic
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = python
+ options = !makeflags
+ options = !emptydirs
+ source = git+https://github.com/erayaydin/xgraphic.git
+ md5sums = SKIP
+
+pkgname = xgraphic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b8eaba7b128
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Eray Aydın <eray@labkod.com>
+pkgname=xgraphic
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Switch between nvidia and bumblebee"
+arch=('i686' 'x86_64')
+url="https://github.com/erayaydin/xgraphic"
+license=('MIT')
+depends=('python')
+install=
+source=("git+https://github.com/erayaydin/xgraphic.git")
+md5sums=('SKIP')
+options=('!makeflags' '!emptydirs')
+
+package() {
+ cd "$srcdir/$pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}