summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEray AYDIN2017-06-21 11:25:53 +0300
committerEray AYDIN2017-06-21 11:25:53 +0300
commit93fb80207b8e1c7312dd3c3f8e1205bdbb88ba02 (patch)
tree085911f8baeacaec481658d86b1aef6e178dc8df
parent330813d278bf2c44e6bc5c922269aa04d57bc53a (diff)
downloadaur-93fb80207b8e1c7312dd3c3f8e1205bdbb88ba02.tar.gz
Updated to first minor update
-rw-r--r--PKGBUILD19
-rw-r--r--xgraphic.install4
2 files changed, 16 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4b8eaba7b128..54498bee4952 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,21 @@ pkgname=xgraphic
pkgver=0.1.0
pkgrel=1
pkgdesc="Switch between nvidia and bumblebee"
-arch=('i686' 'x86_64')
+arch=('any')
url="https://github.com/erayaydin/xgraphic"
license=('MIT')
depends=('python')
-install=
-source=("git+https://github.com/erayaydin/xgraphic.git")
-md5sums=('SKIP')
-options=('!makeflags' '!emptydirs')
+makedepends=('python-distribute')
+install=${pkgname}.install
+source=("https://github.com/erayaydin/xgraphic/archive/v${pkgver}.tar.gz")
+sha256sums=('f123a031d83a0e5974b4fc75adb95309b290780879ed4ee0e53830bdd2e84345')
package() {
- cd "$srcdir/$pkgname"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$srcdir/$pkgname-$pkgver/"
+
+ msg "Copying license..."
+ install -D -m 644 LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+ msg "Running setup.py"
+ python setup.py install --root=${pkgdir} --prefix=/usr
}
diff --git a/xgraphic.install b/xgraphic.install
new file mode 100644
index 000000000000..11a118144c5c
--- /dev/null
+++ b/xgraphic.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo ">>> You should execute XGraphic configuration file in ~/.xinitrc before 'exec' line"
+ echo ">>> /etc/xgraphic/xgraphic"
+}