summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2022-08-27 12:23:04 +0800
committertaotieren2022-08-27 12:23:31 +0800
commite6b96e74780befbbe6ac302ed0ad3df045e94509 (patch)
treebf77afbe462584637caa386476bf2b7251eeb1da
parent991ec181b857779e05dfd02fdb53f558edcab282 (diff)
downloadaur-e6b96e74780befbbe6ac302ed0ad3df045e94509.tar.gz
Update PKGBUILD
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4390d0e58ec4..93bb0acc1c2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,6 +4,7 @@ pkgbase = xguipro-git
pkgrel = 1
url = https://github.com/HVML/xGUI-Pro
arch = any
+ groups = hvml-git
license = LGPL-3.0
makedepends = git
makedepends = cmake
@@ -21,9 +22,11 @@ pkgbase = xguipro-git
makedepends = icu
makedepends = webkit2gtk-hvml
depends = glib2
- optdepends = domruler
- optdepends = purc-fetcher
- optdepends = purc
+ optdepends = domruler: DOM Ruler is a library to maintain a DOM tree, lay out and stylize the DOM elements by using CSS.
+ optdepends = purc: The prime HVML interpreter for C Language.
+ optdepends = purc-fetcher: The remote data fetcher for PurC.
+ optdepends = purc-midnight-commander: A generic HVML renderer in text mode for development and debugging.
+ optdepends = webkit2gtk-hvml: Web content engine for GTK (HVML)
provides = xguipro
provides = xGUI-Pro
conflicts = xguipro
diff --git a/PKGBUILD b/PKGBUILD
index 1b02eec84e7d..5f02fa8d1df0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,18 @@ pkgdesc="xGUI (the X Graphics User Interface) Pro is a modern, cross-platform, a
arch=('any')
url="https://github.com/HVML/xGUI-Pro"
license=('LGPL-3.0')
+groups=('hvml-git')
provides=(${pkgname%-git} 'xGUI-Pro')
conflicts=(${pkgname%-git})
#replaces=(${pkgname})
depends=('glib2')
makedepends=('git' 'cmake' 'ninja')
makedepends=('git' 'cmake' 'ninja' 'ccache' 'gcc' 'python' 'libxml2' 'ruby' 'curl' 'openssl' 'sqlite' 'pkgconf' 'zlib' 'icu' 'webkit2gtk-hvml')
-optdepends=('domruler' 'purc-fetcher' 'purc')
+optdepends=('domruler: DOM Ruler is a library to maintain a DOM tree, lay out and stylize the DOM elements by using CSS.'
+ 'purc: The prime HVML interpreter for C Language.'
+ 'purc-fetcher: The remote data fetcher for PurC.'
+ 'purc-midnight-commander: A generic HVML renderer in text mode for development and debugging.'
+ 'webkit2gtk-hvml: Web content engine for GTK (HVML)')
backup=()
options=('!strip')
#install=${pkgname}.install