summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Borsboom2015-10-20 22:05:12 +0200
committerArthur Borsboom2015-10-20 22:05:12 +0200
commit599dcbeabb7064818687064f8fbc243cc60e95bb (patch)
tree1347f924f87fd7d1082a95a98f48060c925b4111
downloadaur-599dcbeabb7064818687064f8fbc243cc60e95bb.tar.gz
Initial recommit of xhtml-docs package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD38
-rw-r--r--xhtml-docs.install30
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..832074a454d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = xhtml-docs
+ pkgdesc = Set of HTML documentation for XHTML 1.0 & 1.1
+ pkgver = 1.1
+ pkgrel = 3
+ url = http://www.w3.org/TR/xhtml11/
+ arch = any
+ license = GPL
+ options = docs
+ source = http://www.w3.org/TR/xhtml11/xhtml11.tgz
+ md5sums = 56366fb9ff58b79a2de71f127b9baf76
+
+pkgname = xhtml-docs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71eabc364017
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Arthur Borsboom <arthurborsboom@gmail.com>
+# Contributor: Mohammadreza Abdollahzadeh <morealaz@gmail.com>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Peter Simons <simons@cryp.to>
+# Contributor: G. Richard Bellamy <rbellamy@pteradigm.com>
+
+pkgname=xhtml-docs
+pkgver=1.1
+pkgrel=3
+pkgdesc="Set of HTML documentation for XHTML 1.0 & 1.1"
+arch=('any')
+url="http://www.w3.org/"
+license=('GPL')
+
+options=('docs')
+
+source=('http://www.w3.org/TR/xhtml11/xhtml11.tgz'
+ 'http://www.w3.org/TR/xhtml1/xhtml1.tgz'
+ 'xhtml-docs.install')
+sha512sums=('8a38a61d44809459f1f8b02992a623836df1b4b7fb6b5e844ca039264d4c99e80170c84d8b90dede7142f5972e9668f4ff71c9e0ded82887e5b4116cf56a8506'
+ '184758381c5e2d36b80fa1e4470e864777383ff7539b48291036f8a3f1dba0b354a32142bfcc9071147fb20bcd4c0d4d541e09e865047938ab4cf9ae5a806412'
+ 'dc2130bd15792b766bb5c3588ee999dcc3b90c78fbf5f4ec8e4eeebd6c5977ca787f44aa4fa32e6301df13be8ec1274d820fd9cd35e2b72cd51a94fea01b5996')
+
+install=('xhtml-docs.install')
+
+package(){
+ # no need to traverse into $pkgname, since we're actually just copying its contents...
+
+ install -d "${pkgdir}/usr/share/doc/xhtml"
+ rsync -av xhtml1-20020801/ "${pkgdir}/usr/share/doc/xhtml/1.0" --exclude DTD
+ rsync -av xhtml11-20101123/ "${pkgdir}/usr/share/doc/xhtml/1.1" --exclude DTD --exclude SCHEMA
+ rsync -av xhtml1-20020801/DTD/ "${pkgdir}/usr/share/doc/xhtml/DTD"
+ rsync -av xhtml11-20101123/DTD/ "${pkgdir}/usr/share/doc/xhtml/DTD"
+ rsync -av xhtml11-20101123/SCHEMA/ "${pkgdir}/usr/share/doc/xhtml/SCHEMA"
+ ln -s "${pkgdir}/usr/share/doc/xhtml/DTD" "${pkgdir}/usr/share/doc/xhtml/1.0/DTD"
+ ln -s "${pkgdir}/usr/share/doc/xhtml/DTD" "${pkgdir}/usr/share/doc/xhtml/1.1/DTD"
+ ln -s "${pkgdir}/usr/share/doc/xhtml/SCHEMA" "${pkgdir}/usr/share/doc/xhtml/1.1/SCHEMA"
+}
diff --git a/xhtml-docs.install b/xhtml-docs.install
new file mode 100644
index 000000000000..7f59848c6970
--- /dev/null
+++ b/xhtml-docs.install
@@ -0,0 +1,30 @@
+pkgname=xhtml-docs
+
+post_install() {
+ xhtml1_dir="/usr/share/doc/xhtml/DTD"
+ xmlcatalog --noout -add public '-//W3C//DTD XHTML 1.0 Strict//EN' "$xhtml1_dir/xhtml1-strict.dtd" /etc/xml/catalog
+ xmlcatalog --noout -add public '-//W3C//DTD XHTML 1.0 Transitional//EN' "$xhtml1_dir/xhtml1-transitional.dtd" /etc/xml/catalog
+ xmlcatalog --noout -add public '-//W3C//DTD XHTML 1.0 Frameset//EN' "$xhtml1_dir/xhtml1-frameset.dtd" /etc/xml/catalog
+ xmlcatalog --noout -add public '-//W3C//ENTITIES Latin 1 for XHTML//EN' "$xhtml1_dir/xhtml-lat1.ent" /etc/xml/catalog
+ xmlcatalog --noout -add public '-//W3C//ENTITIES Special for XHTML//EN' "$xhtml1_dir/xhtml-special.ent" /etc/xml/catalog
+ xmlcatalog --noout -add public '-//W3C//ENTITIES Symbols for XHTML//EN' "$xhtml1_dir/xhtml-symbol.ent" /etc/xml/catalog
+ xmlcatalog --noout -add rewriteSystem 'http://www.w3.org/TR/xhtml1/DTD/' "$xhtml1_dir/" /etc/xml/catalog
+ xmlcatalog --noout -add rewriteSystem 'http://www.w3.org/TR/2002/REC-xhtml1-20020801/DTD/' "$xhtml1_dir/" /etc/xml/catalog
+ xmlcatalog --noout -add rewriteURI 'http://www.w3.org/TR/xhtml1/DTD/' "$xhtml1_dir/" /etc/xml/catalog
+ xmlcatalog --noout -add rewriteURI 'http://www.w3.org/TR/2002/REC-xhtml1-20020801/DTD/' "$xhtml1_dir/" /etc/xml/catalog
+}
+
+pre_remove() {
+ xhtml1_dir="/usr/share/doc/xhtml/DTD"
+ xmlcatalog --noout -del '-//W3C//DTD XHTML 1.0 Strict//EN' /etc/xml/catalog
+ xmlcatalog --noout -del '-//W3C//DTD XHTML 1.0 Transitional//EN' /etc/xml/catalog
+ xmlcatalog --noout -del '-//W3C//DTD XHTML 1.0 Frameset//EN' /etc/xml/catalog
+ xmlcatalog --noout -del '-//W3C//ENTITIES Latin 1 for XHTML//EN' /etc/xml/catalog
+ xmlcatalog --noout -del '-//W3C//ENTITIES Special for XHTML//EN' /etc/xml/catalog
+ xmlcatalog --noout -del '-//W3C//ENTITIES Symbols for XHTML//EN' /etc/xml/catalog
+ xmlcatalog --noout -del 'http://www.w3.org/TR/xhtml1/DTD/' /etc/xml/catalog
+ xmlcatalog --noout -del 'http://www.w3.org/TR/2002/REC-xhtml1-20020801/DTD/' /etc/xml/catalog
+ xmlcatalog --noout -del 'http://www.w3.org/TR/xhtml1/DTD/' /etc/xml/catalog
+ xmlcatalog --noout -del 'http://www.w3.org/TR/2002/REC-xhtml1-20020801/DTD/' /etc/xml/catalog
+} >/dev/null 2>&1
+